kernel: update 3.9 to 3.9.3

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 36676
This commit is contained in:
Jonas Gorski 2013-05-20 16:57:00 +00:00
parent c6f70381c9
commit a01be4a217
7 changed files with 15 additions and 15 deletions

View file

@ -14,8 +14,8 @@ endif
ifeq ($(LINUX_VERSION),3.8.12)
LINUX_KERNEL_MD5SUM:=a4be720ca9e61445562565856bb5154d
endif
ifeq ($(LINUX_VERSION),3.9.2)
LINUX_KERNEL_MD5SUM:=e406cc1bb5618a4ea88470f4d3d3d6e1
ifeq ($(LINUX_VERSION),3.9.3)
LINUX_KERNEL_MD5SUM:=266e58f4e2f68f48b906ae109aba4dea
endif
# disable the md5sum check for unknown kernel versions

View file

@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 atm
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
LINUX_VERSION:=3.9.2
LINUX_VERSION:=3.9.3
include $(INCLUDE_DIR)/target.mk

View file

@ -13,7 +13,7 @@ FEATURES:=squashfs pci
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.9.2
LINUX_VERSION:=3.9.3
include $(INCLUDE_DIR)/target.mk

View file

@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
@@ -1273,6 +1273,7 @@ static int packet_rcv_spkt(struct sk_buf
@@ -1266,6 +1266,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* When we registered the protocol we saved the socket in the data
@@ -1280,6 +1281,7 @@ static int packet_rcv_spkt(struct sk_buf
@@ -1273,6 +1274,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* Yank back the headers [hope the device set this
@@ -1292,7 +1294,7 @@ static int packet_rcv_spkt(struct sk_buf
@@ -1285,7 +1287,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
@@ -1498,12 +1500,12 @@ static int packet_rcv(struct sk_buff *sk
@@ -1491,12 +1493,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
@@ -1622,12 +1624,12 @@ static int tpacket_rcv(struct sk_buff *s
@@ -1615,12 +1617,12 @@ static int tpacket_rcv(struct sk_buff *s
struct timespec ts;
struct skb_shared_hwtstamps *shhwtstamps = skb_hwtstamps(skb);
@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
@@ -2539,6 +2541,7 @@ static int packet_create(struct net *net
@@ -2532,6 +2534,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
@@ -3152,6 +3155,16 @@ packet_setsockopt(struct socket *sock, i
@@ -3145,6 +3148,16 @@ packet_setsockopt(struct socket *sock, i
po->tp_tx_has_off = !!val;
return 0;
}
@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
@@ -3206,6 +3219,13 @@ static int packet_getsockopt(struct sock
@@ -3199,6 +3212,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;

View file

@ -1,6 +1,6 @@
--- a/drivers/rtc/Kconfig
+++ b/drivers/rtc/Kconfig
@@ -843,6 +843,15 @@ config RTC_DRV_NUC900
@@ -841,6 +841,15 @@ config RTC_DRV_NUC900
If you say yes here you get support for the RTC subsystem of the
NUC910/NUC920 used in embedded systems.

View file

@ -1,6 +1,6 @@
--- a/drivers/rtc/Kconfig
+++ b/drivers/rtc/Kconfig
@@ -490,6 +490,15 @@ config RTC_DRV_RV3029C2
@@ -488,6 +488,15 @@ config RTC_DRV_RV3029C2
This driver can also be built as a module. If so, the module
will be called rtc-rv3029c2.

View file

@ -173,7 +173,7 @@
goto err;
--- a/net/core/sock.c
+++ b/net/core/sock.c
@@ -2857,6 +2857,8 @@ static __net_initdata struct pernet_oper
@@ -2845,6 +2845,8 @@ static __net_initdata struct pernet_oper
static int __init proto_init(void)
{