tools/cmake: update to 3.4.0
Update cmake to 3.4.0. Refresh patches. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 47568
This commit is contained in:
parent
058275197b
commit
9ffd80fef5
3 changed files with 6 additions and 6 deletions
|
@ -7,12 +7,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=cmake
|
PKG_NAME:=cmake
|
||||||
PKG_VERSION:=3.3.2
|
PKG_VERSION:=3.4.0
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.cmake.org/files/v3.3/ \
|
PKG_SOURCE_URL:=http://www.cmake.org/files/v3.4/ \
|
||||||
https://fossies.org/linux/misc/
|
https://fossies.org/linux/misc/
|
||||||
PKG_MD5SUM:=5febbd11bcaac854a27eebaf4a124be2
|
PKG_MD5SUM:=cd3034e0a44256a0917e254167217fc8
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
HOST_CONFIGURE_PARALLEL:=1
|
HOST_CONFIGURE_PARALLEL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Tests/RunCMake/CMakeLists.txt
|
--- a/Tests/RunCMake/CMakeLists.txt
|
||||||
+++ b/Tests/RunCMake/CMakeLists.txt
|
+++ b/Tests/RunCMake/CMakeLists.txt
|
||||||
@@ -160,15 +160,6 @@
|
@@ -216,15 +216,6 @@
|
||||||
add_RunCMake_test(no_install_prefix)
|
add_RunCMake_test(no_install_prefix)
|
||||||
add_RunCMake_test(configure_file)
|
add_RunCMake_test(configure_file)
|
||||||
|
|
||||||
|
@ -18,7 +18,7 @@
|
||||||
add_RunCMake_test(FindPkgConfig)
|
add_RunCMake_test(FindPkgConfig)
|
||||||
--- a/Tests/CMakeLists.txt
|
--- a/Tests/CMakeLists.txt
|
||||||
+++ b/Tests/CMakeLists.txt
|
+++ b/Tests/CMakeLists.txt
|
||||||
@@ -358,10 +358,6 @@
|
@@ -390,10 +390,6 @@
|
||||||
|
|
||||||
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
||||||
|
|
||||||
|
|
|
@ -23,7 +23,7 @@ diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation
|
||||||
index 7c31f3a..2672730 100644
|
index 7c31f3a..2672730 100644
|
||||||
--- a/Source/kwsys/SystemInformation.cxx
|
--- a/Source/kwsys/SystemInformation.cxx
|
||||||
+++ b/Source/kwsys/SystemInformation.cxx
|
+++ b/Source/kwsys/SystemInformation.cxx
|
||||||
@@ -91,6 +91,15 @@ typedef int siginfo_t;
|
@@ -90,6 +90,15 @@ typedef int siginfo_t;
|
||||||
# include <ifaddrs.h>
|
# include <ifaddrs.h>
|
||||||
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
|
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
|
||||||
# endif
|
# endif
|
||||||
|
|
Loading…
Reference in a new issue