upgrade to 0.53.1

SVN-Revision: 25830
This commit is contained in:
Imre Kaloz 2011-03-02 14:20:51 +00:00
parent 8c0df5f96c
commit 9f803ade18
4 changed files with 21 additions and 9 deletions

View file

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear PKG_NAME:=dropbear
PKG_VERSION:=0.52 PKG_VERSION:=0.53.1
PKG_RELEASE:=5 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \ PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \ http://matt.ucc.asn.au/dropbear/releases/ \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/ http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e PKG_MD5SUM:=6b8d901859d9b8a18e2f6bfe0a892a03
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
@ -63,7 +63,8 @@ CONFIGURE_ARGS += \
--disable-loginfunc \ --disable-loginfunc \
--disable-pututline \ --disable-pututline \
--disable-pututxline \ --disable-pututxline \
--disable-zlib --disable-zlib \
--enable-bundled-libtom
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections TARGET_LDFLAGS += -Wl,--gc-sections

View file

@ -1,6 +1,6 @@
--- a/svr-chansession.c --- a/svr-chansession.c
+++ b/svr-chansession.c +++ b/svr-chansession.c
@@ -852,12 +852,12 @@ static void execchild(void *user_data) { @@ -881,12 +881,12 @@ static void execchild(void *user_data) {
/* We can only change uid/gid as root ... */ /* We can only change uid/gid as root ... */
if (getuid() == 0) { if (getuid() == 0) {
@ -9,10 +9,10 @@
(initgroups(ses.authstate.pw_name, (initgroups(ses.authstate.pw_name,
- ses.authstate.pw_gid) < 0)) { - ses.authstate.pw_gid) < 0)) {
+ ses.authstate.pw_gid) < 0))) { + ses.authstate.pw_gid) < 0))) {
dropbear_exit("error changing user group"); dropbear_exit("Error changing user group");
} }
- if (setuid(ses.authstate.pw_uid) < 0) { - if (setuid(ses.authstate.pw_uid) < 0) {
+ if ((ses.authstate.pw_uid != 0) && (setuid(ses.authstate.pw_uid) < 0)) { + if ((ses.authstate.pw_uid != 0) && (setuid(ses.authstate.pw_uid) < 0)) {
dropbear_exit("error changing user"); dropbear_exit("Error changing user");
} }
} else { } else {

View file

@ -0,0 +1,11 @@
--- a/options.h
+++ b/options.h
@@ -49,7 +49,7 @@
several kB in binary size however will make the symmetrical ciphers and hashes
slower, perhaps by 50%. Recommended for small systems that aren't doing
much traffic. */
-/*#define DROPBEAR_SMALL_CODE*/
+#define DROPBEAR_SMALL_CODE
/* Enable X11 Forwarding - server only */
#define ENABLE_X11FWD

View file

@ -1,6 +1,6 @@
--- a/cli-runopts.c --- a/cli-runopts.c
+++ b/cli-runopts.c +++ b/cli-runopts.c
@@ -271,6 +271,10 @@ void cli_getopts(int argc, char ** argv) @@ -287,6 +287,10 @@ void cli_getopts(int argc, char ** argv)
debug_trace = 1; debug_trace = 1;
break; break;
#endif #endif
@ -11,7 +11,7 @@
case 'F': case 'F':
case 'e': case 'e':
case 'c': case 'c':
@@ -282,7 +286,6 @@ void cli_getopts(int argc, char ** argv) @@ -298,7 +302,6 @@ void cli_getopts(int argc, char ** argv)
#ifndef ENABLE_CLI_LOCALTCPFWD #ifndef ENABLE_CLI_LOCALTCPFWD
case 'L': case 'L':
#endif #endif