upgrade to uClibc 0.9.28.2
SVN-Revision: 6353
This commit is contained in:
parent
aa22253602
commit
9edce6b311
10 changed files with 56 additions and 326 deletions
|
@ -9,13 +9,14 @@ include $(INCLUDE_DIR)/target.mk
|
|||
|
||||
PKG_NAME:=uClibc
|
||||
PKG_VERSION:=0.9.28
|
||||
PKG_EXTRAVERSION:=.2
|
||||
|
||||
PKG_SOURCE:=uClibc-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE:=uClibc-$(PKG_VERSION)$(PKG_EXTRAVERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.uclibc.org/downloads
|
||||
PKG_MD5SUM:=1ada58d919a82561061e4741fb6abd29
|
||||
PKG_MD5SUM:=959f25286e317f0d9e2103445c5a14c2
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/uClibc-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/uClibc-$(PKG_VERSION)$(PKG_EXTRAVERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
|
|
51
toolchain/uClibc/patches/100-revert_broken_stuff.patch
Normal file
51
toolchain/uClibc/patches/100-revert_broken_stuff.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
diff -ur uClibc-0.9.28.2/libc/sysdeps/linux/common/bits/uClibc_pthread.h uClibc-0.9.28.1/libc/sysdeps/linux/common/bits/uClibc_pthread.h
|
||||
--- uClibc-0.9.28.2/libc/sysdeps/linux/common/bits/uClibc_pthread.h 2007-02-22 00:28:41.000000000 +0100
|
||||
+++ uClibc-0.9.28.1/libc/sysdeps/linux/common/bits/uClibc_pthread.h 2007-01-26 00:54:19.000000000 +0100
|
||||
@@ -24,27 +23,27 @@
|
||||
#define _UCLIBC_PTHREAD_H
|
||||
|
||||
#ifndef _PTHREAD_H
|
||||
-# error "Always include <pthread.h> rather than <bits/uClibc_pthread.h>"
|
||||
+#error Always include <pthread.h> rather than <bits/uClibc_pthread.h>
|
||||
#endif
|
||||
|
||||
-#if defined _LIBC
|
||||
-/* Threading functions internal to uClibc. Make these thread functions
|
||||
- * weak so that we can elide them from single-threaded processes. */
|
||||
-extern int weak_function __pthread_mutex_init (pthread_mutex_t *__mutex,
|
||||
- __const pthread_mutexattr_t *__mutex_attr);
|
||||
-extern int weak_function __pthread_mutex_destroy (pthread_mutex_t *__mutex);
|
||||
-extern int weak_function __pthread_mutex_lock (pthread_mutex_t *__mutex);
|
||||
-extern int weak_function __pthread_mutex_unlock (pthread_mutex_t *__mutex);
|
||||
-extern void __uclibc_mutex_unlock (void *) attribute_hidden;
|
||||
-extern int weak_function __pthread_mutex_trylock (pthread_mutex_t *__mutex);
|
||||
-
|
||||
-struct _pthread_cleanup_buffer;
|
||||
-extern void weak_function _pthread_cleanup_push_defer (
|
||||
- struct _pthread_cleanup_buffer *__buffer,
|
||||
- void (*__routine) (void *), void *__arg);
|
||||
-extern void weak_function _pthread_cleanup_pop_restore (
|
||||
- struct _pthread_cleanup_buffer *__buffer,
|
||||
- int __execute);
|
||||
-#endif
|
||||
+#if defined _LIBC
|
||||
+/* Threading functions internal to uClibc. Make these thread functions
|
||||
+ * weak so that we can elide them from single-threaded processes. */
|
||||
+extern int __pthread_mutex_init (pthread_mutex_t *__mutex,
|
||||
+ __const pthread_mutexattr_t *__mutex_attr);
|
||||
+extern int __pthread_mutex_destroy (pthread_mutex_t *__mutex);
|
||||
+extern int __pthread_mutex_lock (pthread_mutex_t *__mutex);
|
||||
+extern int __pthread_mutex_unlock (pthread_mutex_t *__mutex);
|
||||
+extern void __uclibc_mutex_unlock (void *) attribute_hidden;
|
||||
+extern int __pthread_mutex_trylock (pthread_mutex_t *__mutex);
|
||||
+
|
||||
+struct _pthread_cleanup_buffer;
|
||||
+extern void _pthread_cleanup_push_defer (
|
||||
+ struct _pthread_cleanup_buffer *__buffer,
|
||||
+ void (*__routine) (void *), void *__arg);
|
||||
+extern void _pthread_cleanup_pop_restore (
|
||||
+ struct _pthread_cleanup_buffer *__buffer,
|
||||
+ int __execute);
|
||||
+#endif
|
||||
|
||||
#endif
|
|
@ -1,13 +0,0 @@
|
|||
diff -ur uClibc-0.9.28/libc/sysdeps/linux/mips/sigaction.c uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/sigaction.c
|
||||
--- uClibc-0.9.28/libc/sysdeps/linux/mips/sigaction.c 2005-08-18 00:49:44.000000000 +0200
|
||||
+++ uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/sigaction.c 2005-10-20 13:19:05.000000000 +0200
|
||||
@@ -49,7 +49,8 @@
|
||||
memcpy (&kact.sa_mask, &act->sa_mask, sizeof (kact.sa_mask));
|
||||
kact.sa_flags = act->sa_flags;
|
||||
|
||||
- kact.sa_flags = act->sa_flags | SA_RESTORER;
|
||||
+/* http://bugs.uclibc.org/view.php?id=480
|
||||
+ kact.sa_flags = act->sa_flags | SA_RESTORER; */
|
||||
#ifdef HAVE_SA_RESTORER
|
||||
kact.sa_restorer = act->sa_restorer;
|
||||
#endif
|
|
@ -1,27 +0,0 @@
|
|||
diff -ur uClibc-0.9.28/libc/sysdeps/linux/mips/pipe.S uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/pipe.S
|
||||
--- uClibc-0.9.28/libc/sysdeps/linux/mips/pipe.S 2005-08-18 00:49:44.000000000 +0200
|
||||
+++ uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/pipe.S 2005-10-20 12:34:52.000000000 +0200
|
||||
@@ -10,22 +10,17 @@
|
||||
.globl pipe
|
||||
.ent pipe, 0
|
||||
pipe:
|
||||
- addiu sp,sp,-24
|
||||
- sw a0,16(sp)
|
||||
li v0,__NR_pipe
|
||||
syscall
|
||||
beqz a3, 1f
|
||||
- la t3, errno
|
||||
- sw v0, (t3)
|
||||
+ sw v0, errno
|
||||
li v0, -1
|
||||
b 2f
|
||||
1:
|
||||
- lw a0, 16(sp)
|
||||
sw v0, 0(a0)
|
||||
sw v1, 4(a0)
|
||||
li v0, 0
|
||||
2:
|
||||
- addiu sp,sp,24
|
||||
j ra
|
||||
.end pipe
|
||||
.size pipe,.-pipe
|
|
@ -1,223 +0,0 @@
|
|||
diff -Nur uClibc-0.9.28/libc/sysdeps/linux/powerpc/bits/syscalls.h uClibc-0.9.28-owrt/libc/sysdeps/linux/powerpc/bits/syscalls.h
|
||||
--- uClibc-0.9.28/libc/sysdeps/linux/powerpc/bits/syscalls.h 2005-08-18 00:49:41.000000000 +0200
|
||||
+++ uClibc-0.9.28-owrt/libc/sysdeps/linux/powerpc/bits/syscalls.h 2006-08-25 17:58:21.000000000 +0200
|
||||
@@ -5,67 +5,164 @@
|
||||
# error "Never use <bits/syscalls.h> directly; include <sys/syscall.h> instead."
|
||||
#endif
|
||||
|
||||
+#include <errno.h>
|
||||
+
|
||||
/* This includes the `__NR_<name>' syscall numbers taken from the Linux kernel
|
||||
* header files. It also defines the traditional `SYS_<name>' macros for older
|
||||
* programs. */
|
||||
#include <bits/sysnum.h>
|
||||
|
||||
-
|
||||
-#define __STRINGIFY(s) __STRINGIFY2 (s)
|
||||
-#define __STRINGIFY2(s) #s
|
||||
-
|
||||
-#undef JUMPTARGET
|
||||
-#ifdef __PIC__
|
||||
-#define __MAKE_SYSCALL __STRINGIFY(__uClibc_syscall@plt)
|
||||
+/* Define a macro which expands inline into the wrapper code for a system
|
||||
+ call. This use is for internal calls that do not need to handle errors
|
||||
+ normally. It will never touch errno.
|
||||
+ On powerpc a system call basically clobbers the same registers like a
|
||||
+ function call, with the exception of LR (which is needed for the
|
||||
+ "sc; bnslr+" sequence) and CR (where only CR0.SO is clobbered to signal
|
||||
+ an error return status). */
|
||||
+
|
||||
+# undef INLINE_SYSCALL
|
||||
+#if 1
|
||||
+# define INLINE_SYSCALL(name, nr, args...) \
|
||||
+ ({ \
|
||||
+ INTERNAL_SYSCALL_DECL (sc_err); \
|
||||
+ long int sc_ret = INTERNAL_SYSCALL (name, sc_err, nr, args); \
|
||||
+ if (INTERNAL_SYSCALL_ERROR_P (sc_ret, sc_err)) \
|
||||
+ { \
|
||||
+ __set_errno (INTERNAL_SYSCALL_ERRNO (sc_ret, sc_err)); \
|
||||
+ sc_ret = -1L; \
|
||||
+ } \
|
||||
+ sc_ret; \
|
||||
+ })
|
||||
#else
|
||||
-#define __MAKE_SYSCALL __STRINGIFY(__uClibc_syscall)
|
||||
+# define INLINE_SYSCALL(name, nr, args...) \
|
||||
+ ({ \
|
||||
+ INTERNAL_SYSCALL_DECL (sc_err); \
|
||||
+ long int sc_ret = INTERNAL_SYSCALL (name, sc_err, nr, args); \
|
||||
+ if (INTERNAL_SYSCALL_ERROR_P (sc_ret, sc_err)) \
|
||||
+ { \
|
||||
+ sc_ret = __syscall_error(INTERNAL_SYSCALL_ERRNO (sc_ret, sc_err));\
|
||||
+ } \
|
||||
+ sc_ret; \
|
||||
+ })
|
||||
#endif
|
||||
|
||||
-#define unified_syscall_body(name) \
|
||||
- __asm__ ( \
|
||||
- ".section \".text\"\n\t" \
|
||||
- ".align 2\n\t" \
|
||||
- ".globl " __STRINGIFY(name) "\n\t" \
|
||||
- ".type " __STRINGIFY(name) ",@function\n\t" \
|
||||
- #name":\tli 0," __STRINGIFY(__NR_##name) "\n\t" \
|
||||
- "b " __MAKE_SYSCALL "\n\t" \
|
||||
- ".size\t" __STRINGIFY(name) ",.""-" __STRINGIFY(name) "\n" \
|
||||
- )
|
||||
+/* Define a macro which expands inline into the wrapper code for a system
|
||||
+ call. This use is for internal calls that do not need to handle errors
|
||||
+ normally. It will never touch errno.
|
||||
+ On powerpc a system call basically clobbers the same registers like a
|
||||
+ function call, with the exception of LR (which is needed for the
|
||||
+ "sc; bnslr+" sequence) and CR (where only CR0.SO is clobbered to signal
|
||||
+ an error return status). */
|
||||
+
|
||||
+# undef INTERNAL_SYSCALL_DECL
|
||||
+# define INTERNAL_SYSCALL_DECL(err) long int err
|
||||
+
|
||||
+# undef INTERNAL_SYSCALL
|
||||
+# define INTERNAL_SYSCALL_NCS(name, err, nr, args...) \
|
||||
+ ({ \
|
||||
+ register long int r0 __asm__ ("r0"); \
|
||||
+ register long int r3 __asm__ ("r3"); \
|
||||
+ register long int r4 __asm__ ("r4"); \
|
||||
+ register long int r5 __asm__ ("r5"); \
|
||||
+ register long int r6 __asm__ ("r6"); \
|
||||
+ register long int r7 __asm__ ("r7"); \
|
||||
+ register long int r8 __asm__ ("r8"); \
|
||||
+ register long int r9 __asm__ ("r9"); \
|
||||
+ register long int r10 __asm__ ("r10"); \
|
||||
+ register long int r11 __asm__ ("r11"); \
|
||||
+ register long int r12 __asm__ ("r12"); \
|
||||
+ LOADARGS_##nr(name, args); \
|
||||
+ __asm__ __volatile__ \
|
||||
+ ("sc \n\t" \
|
||||
+ "mfcr %0" \
|
||||
+ : "=&r" (r0), \
|
||||
+ "=&r" (r3), "=&r" (r4), "=&r" (r5), "=&r" (r6), "=&r" (r7), \
|
||||
+ "=&r" (r8), "=&r" (r9), "=&r" (r10), "=&r" (r11), "=&r" (r12) \
|
||||
+ : ASM_INPUT_##nr \
|
||||
+ : "cr0", "ctr", "memory"); \
|
||||
+ err = r0; \
|
||||
+ (int) r3; \
|
||||
+ })
|
||||
+# define INTERNAL_SYSCALL(name, err, nr, args...) \
|
||||
+ INTERNAL_SYSCALL_NCS (__NR_##name, err, nr, ##args)
|
||||
+
|
||||
+# undef INTERNAL_SYSCALL_ERROR_P
|
||||
+# define INTERNAL_SYSCALL_ERROR_P(val, err) \
|
||||
+ ((void) (val), __builtin_expect ((err) & (1 << 28), 0))
|
||||
+
|
||||
+# undef INTERNAL_SYSCALL_ERRNO
|
||||
+# define INTERNAL_SYSCALL_ERRNO(val, err) (val)
|
||||
+
|
||||
+# define LOADARGS_0(name, dummy) \
|
||||
+ r0 = (long int)name
|
||||
+# define LOADARGS_1(name, __arg1) \
|
||||
+ LOADARGS_0(name, 0); \
|
||||
+ r3 = (long int)__arg1
|
||||
+# define LOADARGS_2(name, __arg1, __arg2) \
|
||||
+ LOADARGS_1(name, __arg1); \
|
||||
+ r4 = (long int)__arg2
|
||||
+# define LOADARGS_3(name, __arg1, __arg2, __arg3) \
|
||||
+ LOADARGS_2(name, __arg1, __arg2); \
|
||||
+ r5 = (long int)__arg3
|
||||
+# define LOADARGS_4(name, __arg1, __arg2, __arg3, __arg4) \
|
||||
+ LOADARGS_3(name, __arg1, __arg2, __arg3); \
|
||||
+ r6 = (long int)__arg4
|
||||
+# define LOADARGS_5(name, __arg1, __arg2, __arg3, __arg4, __arg5) \
|
||||
+ LOADARGS_4(name, __arg1, __arg2, __arg3, __arg4); \
|
||||
+ r7 = (long int)__arg5
|
||||
+# define LOADARGS_6(name, __arg1, __arg2, __arg3, __arg4, __arg5, __arg6) \
|
||||
+ LOADARGS_5(name, __arg1, __arg2, __arg3, __arg4, __arg5); \
|
||||
+ r8 = (long int)__arg6
|
||||
+
|
||||
+# define ASM_INPUT_0 "0" (r0)
|
||||
+# define ASM_INPUT_1 ASM_INPUT_0, "1" (r3)
|
||||
+# define ASM_INPUT_2 ASM_INPUT_1, "2" (r4)
|
||||
+# define ASM_INPUT_3 ASM_INPUT_2, "3" (r5)
|
||||
+# define ASM_INPUT_4 ASM_INPUT_3, "4" (r6)
|
||||
+# define ASM_INPUT_5 ASM_INPUT_4, "5" (r7)
|
||||
+# define ASM_INPUT_6 ASM_INPUT_5, "6" (r8)
|
||||
|
||||
#undef _syscall0
|
||||
-#define _syscall0(type,name) \
|
||||
-type name(void); \
|
||||
-unified_syscall_body(name)
|
||||
+#define _syscall0(type,name) \
|
||||
+type name(void){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 0); \
|
||||
+}
|
||||
|
||||
#undef _syscall1
|
||||
#define _syscall1(type,name,type1,arg1) \
|
||||
-type name(type1 arg1); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 1, arg1); \
|
||||
+}
|
||||
|
||||
#undef _syscall2
|
||||
#define _syscall2(type,name,type1,arg1,type2,arg2) \
|
||||
-type name(type1 arg1, type2 arg2); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1, type2 arg2){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 2, arg1, arg2); \
|
||||
+}
|
||||
|
||||
#undef _syscall3
|
||||
#define _syscall3(type,name,type1,arg1,type2,arg2,type3,arg3) \
|
||||
-type name(type1 arg1, type2 arg2, type3 arg3); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1, type2 arg2, type3 arg3){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 3, arg1, arg2, arg3); \
|
||||
+}
|
||||
|
||||
#undef _syscall4
|
||||
#define _syscall4(type,name,type1,arg1,type2,arg2,type3,arg3,type4,arg4) \
|
||||
-type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 4, arg1, arg2, arg3, arg4); \
|
||||
+}
|
||||
|
||||
#undef _syscall5
|
||||
#define _syscall5(type,name,type1,arg1,type2,arg2,type3,arg3,type4,arg4,type5,arg5) \
|
||||
-type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4, type5 arg5); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4, type5 arg5){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 5, arg1, arg2, arg3, arg4, arg5); \
|
||||
+}
|
||||
|
||||
#undef _syscall6
|
||||
#define _syscall6(type,name,type1,arg1,type2,arg2,type3,arg3,type4,arg4,type5,arg5,type6,arg6) \
|
||||
-type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4, type5 arg5, type6 arg6); \
|
||||
-unified_syscall_body(name)
|
||||
+type name(type1 arg1, type2 arg2, type3 arg3, type4 arg4, type5 arg5, type6 arg6){ \
|
||||
+ return (type) INLINE_SYSCALL(name, 6, arg1, arg2, arg3, arg4, arg5, arg6); \
|
||||
+}
|
||||
|
||||
#endif /* _BITS_SYSCALLS_H */
|
||||
|
||||
diff -urP uClibc-0.9.28/libc/sysdeps/linux/powerpc/sys/procfs.h uClibc-0.9.28-uint128/libc/sysdeps/linux/powerpc/sys/procfs.h
|
||||
--- uClibc-0.9.28/libc/sysdeps/linux/powerpc/sys/procfs.h 2005-08-18 00:49:41.000000000 +0200
|
||||
+++ uClibc-0.9.28-uint128/libc/sysdeps/linux/powerpc/sys/procfs.h 2005-08-22 17:27:17.000000000 +0200
|
||||
@@ -42,15 +42,10 @@
|
||||
typedef double elf_fpreg_t;
|
||||
typedef elf_fpreg_t elf_fpregset_t[ELF_NFPREG];
|
||||
|
||||
-/* gcc 3.1 and newer support __uint128_t. */
|
||||
-#if !__GNUC_PREREQ(3,1)
|
||||
-typedef struct {
|
||||
- unsigned long u[4];
|
||||
-} __attribute((aligned(16))) __uint128_t;
|
||||
-#endif
|
||||
-
|
||||
/* Altivec registers */
|
||||
-typedef __uint128_t elf_vrreg_t;
|
||||
+typedef struct {
|
||||
+ unsigned int u[4];
|
||||
+} __attribute((aligned (16))) elf_vrreg_t;
|
||||
typedef elf_vrreg_t elf_vrregset_t[ELF_NVRREG];
|
||||
|
||||
struct elf_siginfo
|
|
@ -1,12 +0,0 @@
|
|||
--- uClibc-0.9.27-old/libc/sysdeps/linux/common/bits/in.h 2005-01-12 08:59:21.000000000 +0100
|
||||
+++ uClibc-0.9.27-new/libc/sysdeps/linux/common/bits/in.h 2005-08-23 02:12:47.000000000 +0200
|
||||
@@ -115,6 +115,9 @@
|
||||
#define IPV6_MTU_DISCOVER 23
|
||||
#define IPV6_MTU 24
|
||||
#define IPV6_RECVERR 25
|
||||
+#define IPV6_V6ONLY 26
|
||||
+#define IPV6_JOIN_ANYCAST 27
|
||||
+#define IPV6_LEAVE_ANYCAST 28
|
||||
|
||||
#define SCM_SRCRT IPV6_RXSRCRT
|
||||
|
|
@ -8,7 +8,7 @@ Fix portability of build infrastructure
|
|||
$(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
|
||||
$(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
|
||||
-$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
|
||||
- if [ "$(KERNEL_SOURCE)" == "$(DEVEL_PREFIX)" ] ; then \
|
||||
- if [ "$(KERNEL_SOURCE)" = "$(DEVEL_PREFIX)" ] ; then \
|
||||
- extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
|
||||
- else \
|
||||
- extra_exclude="" ; \
|
||||
|
@ -27,12 +27,3 @@ Fix portability of build infrastructure
|
|||
@if [ -x lib/ld-uClibc-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so ] ; then \
|
||||
set -e; \
|
||||
$(SHELL_SET_X); \
|
||||
@@ -370,7 +365,7 @@ distclean: clean
|
||||
release: distclean
|
||||
cd ..; \
|
||||
$(RM) -r uClibc-$(VERSION); \
|
||||
- cp -dRf uClibc uClibc-$(VERSION); \
|
||||
+ cp -PRf uClibc uClibc-$(VERSION); \
|
||||
find uClibc-$(VERSION)/ -type f \
|
||||
-name .\#* -exec $(RM) -r {} \; ; \
|
||||
find uClibc-$(VERSION)/ -type d \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff -ur uClibc-0.9.28/ldso/include/dl-string.h uClibc-0.9.28-owrt/ldso/include/dl-string.h
|
||||
--- uClibc-0.9.28/ldso/include/dl-string.h 2005-08-18 00:49:41.000000000 +0200
|
||||
+++ uClibc-0.9.28-owrt/ldso/include/dl-string.h 2006-09-11 11:42:08.000000000 +0200
|
||||
@@ -228,7 +228,8 @@
|
||||
char temp;
|
||||
do_rem(temp, i, 10);
|
||||
*--p = '0' + temp;
|
||||
- i /= 10;
|
||||
+ i /= 2;
|
||||
+ i *= -(-1ul / 5ul);
|
||||
} while (i > 0);
|
||||
return p;
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
diff -ur uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h
|
||||
--- uClibc.old/libc/sysdeps/linux/powerpc/bits/kernel_types.h 2005-08-18 00:49:41.000000000 +0200
|
||||
+++ uClibc.dev/libc/sysdeps/linux/powerpc/bits/kernel_types.h 2006-11-30 19:26:22.000000000 +0100
|
||||
@@ -4,7 +4,8 @@
|
||||
* our private content, and not the kernel header, will win.
|
||||
* -Erik
|
||||
*/
|
||||
-#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H
|
||||
+#if ! defined _PPC_POSIX_TYPES_H && ! defined _PPC64_POSIX_TYPES_H && !defined _ASM_POWERPC_POSIX_TYPES_H
|
||||
+#define _ASM_POWERPC_POSIX_TYPES_H
|
||||
#define _PPC_POSIX_TYPES_H
|
||||
#define _PPC64_POSIX_TYPES_H
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
diff -pur uClibc.old/libc/inet/resolv.c uClibc.dev/libc/inet/resolv.c
|
||||
--- uClibc.old/libc/inet/resolv.c 2005-08-18 00:49:41.000000000 +0200
|
||||
+++ uClibc.dev/libc/inet/resolv.c 2007-01-27 15:33:39.689171960 +0100
|
||||
@@ -2083,7 +2083,7 @@ int gethostbyname2_r(const char *name, i
|
||||
int old_errno = errno; /* Save the old errno and reset errno */
|
||||
__set_errno(0); /* to check for missing /etc/hosts. */
|
||||
|
||||
- if ((i=__get_hosts_byname_r(name, AF_INET, result_buf,
|
||||
+ if ((i=__get_hosts_byname_r(name, family, result_buf,
|
||||
buf, buflen, result, h_errnop))==0)
|
||||
return i;
|
||||
switch (*h_errnop) {
|
Loading…
Reference in a new issue