madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match the build system's value
SVN-Revision: 17084
This commit is contained in:
parent
b3b04354d3
commit
9ce792f444
1 changed files with 6 additions and 1 deletions
|
@ -1,6 +1,6 @@
|
|||
--- a/scripts/get_arch.mk
|
||||
+++ b/scripts/get_arch.mk
|
||||
@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
|
||||
@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
|
||||
$(Cannot determine ARCH)
|
||||
endif
|
||||
|
||||
|
@ -14,3 +14,8 @@
|
|||
# Don't allow ARCH to be overridden by a different value.
|
||||
ifeq (,$(ARCH))
|
||||
ARCH = $(ARCH-y)
|
||||
-else
|
||||
-ifneq ($(ARCH),$(ARCH-y))
|
||||
-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
|
||||
-endif
|
||||
endif
|
||||
|
|
Loading…
Reference in a new issue