kernel: update 3.14 to 3.14.27
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 43820
This commit is contained in:
parent
fd7be4073a
commit
9c8422a09b
8 changed files with 21 additions and 46 deletions
|
@ -6,14 +6,14 @@ LINUX_VERSION-3.3 = .8
|
||||||
LINUX_VERSION-3.8 = .13
|
LINUX_VERSION-3.8 = .13
|
||||||
LINUX_VERSION-3.10 = .58
|
LINUX_VERSION-3.10 = .58
|
||||||
LINUX_VERSION-3.13 = .7
|
LINUX_VERSION-3.13 = .7
|
||||||
LINUX_VERSION-3.14 = .26
|
LINUX_VERSION-3.14 = .27
|
||||||
LINUX_VERSION-3.18 =
|
LINUX_VERSION-3.18 =
|
||||||
|
|
||||||
LINUX_KERNEL_MD5SUM-3.3.8 = f1058f64eed085deb44f10cee8541d50
|
LINUX_KERNEL_MD5SUM-3.3.8 = f1058f64eed085deb44f10cee8541d50
|
||||||
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
|
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
|
||||||
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
|
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
|
||||||
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
|
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
|
||||||
LINUX_KERNEL_MD5SUM-3.14.26 = 9a91a9c507c9efb68c7075e151c30fa7
|
LINUX_KERNEL_MD5SUM-3.14.27 = 0af2d0702df6ee6d7181e697e0af3481
|
||||||
LINUX_KERNEL_MD5SUM-3.18 = 9e854df51ca3fef8bfe566dbd7b89241
|
LINUX_KERNEL_MD5SUM-3.18 = 9e854df51ca3fef8bfe566dbd7b89241
|
||||||
|
|
||||||
ifdef KERNEL_PATCHVER
|
ifdef KERNEL_PATCHVER
|
||||||
|
|
|
@ -1,16 +0,0 @@
|
||||||
Use the cross toolchain objdump command instead of assuming that the host
|
|
||||||
toolchain has it.
|
|
||||||
|
|
||||||
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|
||||||
|
|
||||||
--- a/arch/x86/boot/compressed/Makefile
|
|
||||||
+++ b/arch/x86/boot/compressed/Makefile
|
|
||||||
@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
|
|
||||||
suffix-$(CONFIG_KERNEL_LZO) := lzo
|
|
||||||
suffix-$(CONFIG_KERNEL_LZ4) := lz4
|
|
||||||
|
|
||||||
-RUN_SIZE = $(shell objdump -h vmlinux | \
|
|
||||||
+RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
|
|
||||||
perl $(srctree)/arch/x86/tools/calc_run_size.pl)
|
|
||||||
quiet_cmd_mkpiggy = MKPIGGY $@
|
|
||||||
cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
|
|
|
@ -14,7 +14,7 @@
|
||||||
endmenu
|
endmenu
|
||||||
--- a/drivers/mtd/mtdpart.c
|
--- a/drivers/mtd/mtdpart.c
|
||||||
+++ b/drivers/mtd/mtdpart.c
|
+++ b/drivers/mtd/mtdpart.c
|
||||||
@@ -668,6 +668,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
@@ -668,6 +668,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
||||||
return len;
|
return len;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -52,7 +52,7 @@
|
||||||
#ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
|
#ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
|
||||||
#define SPLIT_FIRMWARE_NAME CONFIG_MTD_SPLIT_FIRMWARE_NAME
|
#define SPLIT_FIRMWARE_NAME CONFIG_MTD_SPLIT_FIRMWARE_NAME
|
||||||
#else
|
#else
|
||||||
@@ -676,7 +707,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
@@ -676,7 +707,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
||||||
|
|
||||||
static void split_firmware(struct mtd_info *master, struct mtd_part *part)
|
static void split_firmware(struct mtd_info *master, struct mtd_part *part)
|
||||||
{
|
{
|
||||||
|
|
|
@ -14,7 +14,7 @@
|
||||||
default y
|
default y
|
||||||
--- a/drivers/mtd/mtdpart.c
|
--- a/drivers/mtd/mtdpart.c
|
||||||
+++ b/drivers/mtd/mtdpart.c
|
+++ b/drivers/mtd/mtdpart.c
|
||||||
@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
|
||||||
return len;
|
return len;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -17,7 +17,7 @@
|
||||||
u64 offset, uint32_t mask_flags)
|
u64 offset, uint32_t mask_flags)
|
||||||
{
|
{
|
||||||
part->name = name;
|
part->name = name;
|
||||||
@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
|
@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
|
||||||
part->mask_flags = mask_flags;
|
part->mask_flags = mask_flags;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -30,7 +30,7 @@
|
||||||
/****************************************************************************/
|
/****************************************************************************/
|
||||||
|
|
||||||
enum read_type {
|
enum read_type {
|
||||||
@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
|
@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
|
||||||
flash->mtd._write = m25p80_write;
|
flash->mtd._write = m25p80_write;
|
||||||
|
|
||||||
/* prefer "small sector" erase if possible */
|
/* prefer "small sector" erase if possible */
|
||||||
|
|
|
@ -200,7 +200,7 @@
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@@ -1465,6 +1495,7 @@ static int br_multicast_ipv4_rcv(struct
|
@@ -1465,6 +1495,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||||
struct sk_buff *skb,
|
struct sk_buff *skb,
|
||||||
u16 vid)
|
u16 vid)
|
||||||
{
|
{
|
||||||
|
@ -208,7 +208,7 @@
|
||||||
struct sk_buff *skb2 = skb;
|
struct sk_buff *skb2 = skb;
|
||||||
const struct iphdr *iph;
|
const struct iphdr *iph;
|
||||||
struct igmphdr *ih;
|
struct igmphdr *ih;
|
||||||
@@ -1538,7 +1569,7 @@ static int br_multicast_ipv4_rcv(struct
|
@@ -1538,7 +1569,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||||
case IGMP_HOST_MEMBERSHIP_REPORT:
|
case IGMP_HOST_MEMBERSHIP_REPORT:
|
||||||
case IGMPV2_HOST_MEMBERSHIP_REPORT:
|
case IGMPV2_HOST_MEMBERSHIP_REPORT:
|
||||||
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
|
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
|
||||||
|
@ -217,7 +217,7 @@
|
||||||
break;
|
break;
|
||||||
case IGMPV3_HOST_MEMBERSHIP_REPORT:
|
case IGMPV3_HOST_MEMBERSHIP_REPORT:
|
||||||
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
|
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
|
||||||
@@ -1547,7 +1578,7 @@ static int br_multicast_ipv4_rcv(struct
|
@@ -1547,7 +1578,7 @@ static int br_multicast_ipv4_rcv(struct
|
||||||
err = br_ip4_multicast_query(br, port, skb2, vid);
|
err = br_ip4_multicast_query(br, port, skb2, vid);
|
||||||
break;
|
break;
|
||||||
case IGMP_HOST_LEAVE_MESSAGE:
|
case IGMP_HOST_LEAVE_MESSAGE:
|
||||||
|
@ -226,7 +226,7 @@
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1565,6 +1596,7 @@ static int br_multicast_ipv6_rcv(struct
|
@@ -1565,6 +1596,7 @@ static int br_multicast_ipv6_rcv(struct
|
||||||
struct sk_buff *skb,
|
struct sk_buff *skb,
|
||||||
u16 vid)
|
u16 vid)
|
||||||
{
|
{
|
||||||
|
@ -234,7 +234,7 @@
|
||||||
struct sk_buff *skb2;
|
struct sk_buff *skb2;
|
||||||
const struct ipv6hdr *ip6h;
|
const struct ipv6hdr *ip6h;
|
||||||
u8 icmp6_type;
|
u8 icmp6_type;
|
||||||
@@ -1674,7 +1706,8 @@ static int br_multicast_ipv6_rcv(struct
|
@@ -1674,7 +1706,8 @@ static int br_multicast_ipv6_rcv(struct
|
||||||
}
|
}
|
||||||
mld = (struct mld_msg *)skb_transport_header(skb2);
|
mld = (struct mld_msg *)skb_transport_header(skb2);
|
||||||
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
|
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
|
||||||
|
@ -244,7 +244,7 @@
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
case ICMPV6_MLD2_REPORT:
|
case ICMPV6_MLD2_REPORT:
|
||||||
@@ -1691,7 +1724,7 @@ static int br_multicast_ipv6_rcv(struct
|
@@ -1691,7 +1724,7 @@ static int br_multicast_ipv6_rcv(struct
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
mld = (struct mld_msg *)skb_transport_header(skb2);
|
mld = (struct mld_msg *)skb_transport_header(skb2);
|
||||||
|
|
|
@ -22,11 +22,9 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||||
include/linux/libata.h | 9 +++++++++
|
include/linux/libata.h | 9 +++++++++
|
||||||
3 files changed, 66 insertions(+)
|
3 files changed, 66 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
|
|
||||||
index cd4cccb..7a085ec 100644
|
|
||||||
--- a/drivers/ata/Kconfig
|
--- a/drivers/ata/Kconfig
|
||||||
+++ b/drivers/ata/Kconfig
|
+++ b/drivers/ata/Kconfig
|
||||||
@@ -46,6 +46,22 @@ config ATA_VERBOSE_ERROR
|
@@ -45,6 +45,22 @@ config ATA_VERBOSE_ERROR
|
||||||
|
|
||||||
If unsure, say Y.
|
If unsure, say Y.
|
||||||
|
|
||||||
|
@ -49,11 +47,9 @@ index cd4cccb..7a085ec 100644
|
||||||
config ATA_ACPI
|
config ATA_ACPI
|
||||||
bool "ATA ACPI Support"
|
bool "ATA ACPI Support"
|
||||||
depends on ACPI && PCI
|
depends on ACPI && PCI
|
||||||
diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
|
|
||||||
index 5c84fb5..eb49e02 100644
|
|
||||||
--- a/drivers/ata/libata-core.c
|
--- a/drivers/ata/libata-core.c
|
||||||
+++ b/drivers/ata/libata-core.c
|
+++ b/drivers/ata/libata-core.c
|
||||||
@@ -725,6 +725,19 @@ u64 ata_tf_read_block(struct ata_taskfile *tf, struct ata_device *dev)
|
@@ -724,6 +724,19 @@ u64 ata_tf_read_block(struct ata_taskfil
|
||||||
return block;
|
return block;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -73,7 +69,7 @@ index 5c84fb5..eb49e02 100644
|
||||||
/**
|
/**
|
||||||
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
||||||
* @tf: Target ATA taskfile
|
* @tf: Target ATA taskfile
|
||||||
@@ -4761,6 +4774,9 @@ static struct ata_queued_cmd *ata_qc_new(struct ata_port *ap)
|
@@ -4819,6 +4832,9 @@ static struct ata_queued_cmd *ata_qc_new
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -83,7 +79,7 @@ index 5c84fb5..eb49e02 100644
|
||||||
|
|
||||||
return qc;
|
return qc;
|
||||||
}
|
}
|
||||||
@@ -5671,6 +5687,9 @@ struct ata_port *ata_port_alloc(struct ata_host *host)
|
@@ -5744,6 +5760,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||||
ap->stats.unhandled_irq = 1;
|
ap->stats.unhandled_irq = 1;
|
||||||
ap->stats.idle_irq = 1;
|
ap->stats.idle_irq = 1;
|
||||||
#endif
|
#endif
|
||||||
|
@ -93,7 +89,7 @@ index 5c84fb5..eb49e02 100644
|
||||||
ata_sff_port_init(ap);
|
ata_sff_port_init(ap);
|
||||||
|
|
||||||
return ap;
|
return ap;
|
||||||
@@ -5692,6 +5711,12 @@ static void ata_host_release(struct device *gendev, void *res)
|
@@ -5765,6 +5784,12 @@ static void ata_host_release(struct devi
|
||||||
|
|
||||||
kfree(ap->pmp_link);
|
kfree(ap->pmp_link);
|
||||||
kfree(ap->slave_link);
|
kfree(ap->slave_link);
|
||||||
|
@ -106,7 +102,7 @@ index 5c84fb5..eb49e02 100644
|
||||||
kfree(ap);
|
kfree(ap);
|
||||||
host->ports[i] = NULL;
|
host->ports[i] = NULL;
|
||||||
}
|
}
|
||||||
@@ -6138,7 +6163,23 @@ int ata_host_register(struct ata_host *host, struct scsi_host_template *sht)
|
@@ -6211,7 +6236,23 @@ int ata_host_register(struct ata_host *h
|
||||||
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
||||||
host->ports[i]->local_port_no = i + 1;
|
host->ports[i]->local_port_no = i + 1;
|
||||||
}
|
}
|
||||||
|
@ -114,11 +110,11 @@ index 5c84fb5..eb49e02 100644
|
||||||
+ for (i = 0; i < host->n_ports; i++) {
|
+ for (i = 0; i < host->n_ports; i++) {
|
||||||
+ if (unlikely(!host->ports[i]->ledtrig))
|
+ if (unlikely(!host->ports[i]->ledtrig))
|
||||||
+ continue;
|
+ continue;
|
||||||
+
|
|
||||||
+ snprintf(host->ports[i]->ledtrig_name,
|
+ snprintf(host->ports[i]->ledtrig_name,
|
||||||
+ sizeof(host->ports[i]->ledtrig_name), "ata%u",
|
+ sizeof(host->ports[i]->ledtrig_name), "ata%u",
|
||||||
+ host->ports[i]->print_id);
|
+ host->ports[i]->print_id);
|
||||||
|
+
|
||||||
+ host->ports[i]->ledtrig->name = host->ports[i]->ledtrig_name;
|
+ host->ports[i]->ledtrig->name = host->ports[i]->ledtrig_name;
|
||||||
+
|
+
|
||||||
+ if (led_trigger_register(host->ports[i]->ledtrig)) {
|
+ if (led_trigger_register(host->ports[i]->ledtrig)) {
|
||||||
|
@ -130,8 +126,6 @@ index 5c84fb5..eb49e02 100644
|
||||||
/* Create associated sysfs transport objects */
|
/* Create associated sysfs transport objects */
|
||||||
for (i = 0; i < host->n_ports; i++) {
|
for (i = 0; i < host->n_ports; i++) {
|
||||||
rc = ata_tport_add(host->dev,host->ports[i]);
|
rc = ata_tport_add(host->dev,host->ports[i]);
|
||||||
diff --git a/include/linux/libata.h b/include/linux/libata.h
|
|
||||||
index 2d18241..4428e2b 100644
|
|
||||||
--- a/include/linux/libata.h
|
--- a/include/linux/libata.h
|
||||||
+++ b/include/linux/libata.h
|
+++ b/include/linux/libata.h
|
||||||
@@ -38,6 +38,9 @@
|
@@ -38,6 +38,9 @@
|
||||||
|
@ -157,6 +151,3 @@ index 2d18241..4428e2b 100644
|
||||||
/* owned by EH */
|
/* owned by EH */
|
||||||
u8 sector_buf[ATA_SECT_SIZE] ____cacheline_aligned;
|
u8 sector_buf[ATA_SECT_SIZE] ____cacheline_aligned;
|
||||||
};
|
};
|
||||||
--
|
|
||||||
2.1.3
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue