thc-ipv6: Allow overriding CFLAGS
thc-ipv6 did not allow an external environment to override CFLAGS, which would lead to our CFLAGS not being passed properly (relro, optimizations, etc...) Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
This commit is contained in:
parent
11356e4078
commit
9b2321f42d
1 changed files with 12 additions and 0 deletions
|
@ -0,0 +1,12 @@
|
|||
diff -urN thc-ipv6-2.7/Makefile thc-ipv6-2.7.new/Makefile
|
||||
--- thc-ipv6-2.7/Makefile 2014-12-27 05:05:30.000000000 -0800
|
||||
+++ thc-ipv6-2.7.new/Makefile 2017-02-04 20:55:51.679898101 -0800
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
CC=gcc
|
||||
#CFLAGS=-g
|
||||
-CFLAGS=-O2
|
||||
+CFLAGS?=-O2
|
||||
CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
|
||||
LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
|
||||
PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6 thcsyn6 redirsniff6 flood_redir6 four2six dump_dhcp6 fuzz_dhcps6 flood_rs6 fuzz_dhcpc6
|
Loading…
Reference in a new issue