update openswan to 2.4.5 final
SVN-Revision: 3635
This commit is contained in:
parent
ece065ce03
commit
99239efe1b
2 changed files with 2 additions and 25 deletions
|
@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
|
||||||
include ../../rules.mk
|
include ../../rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openswan
|
PKG_NAME:=openswan
|
||||||
PKG_VERSION:=2.4.5rc5
|
PKG_VERSION:=2.4.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=c2547f70b2d7c33deafb2b230305cef5
|
PKG_MD5SUM:=a9a8e88313faceebfc5ceb1a9da9a3c4
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://www.openswan.org/download
|
PKG_SOURCE_URL:=http://www.openswan.org/download
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
|
@ -1,23 +0,0 @@
|
||||||
diff -Nur openswan-2.4.4/linux/net/ipsec/pfkey_v2.c openswan-2.4.4.patched/linux/net/ipsec/pfkey_v2.c
|
|
||||||
--- openswan-2.4.4/linux/net/ipsec/pfkey_v2.c 2005-09-14 18:40:45.000000000 +0200
|
|
||||||
+++ openswan-2.4.4.patched/linux/net/ipsec/pfkey_v2.c 2005-12-25 04:35:57.674968000 +0100
|
|
||||||
@@ -820,7 +820,9 @@
|
|
||||||
return 0; /* -EINVAL; */
|
|
||||||
}
|
|
||||||
|
|
||||||
+#ifdef NET_26
|
|
||||||
write_lock_bh(&pfkey_sock_lock);
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
KLIPS_PRINT(debug_pfkey,
|
|
||||||
"klips_debug:pfkey_release: "
|
|
||||||
@@ -851,7 +853,9 @@
|
|
||||||
"klips_debug:pfkey_release: "
|
|
||||||
"succeeded.\n");
|
|
||||||
|
|
||||||
+#ifdef NET_26
|
|
||||||
write_unlock_bh(&pfkey_sock_lock);
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
}
|
|
Loading…
Reference in a new issue