update to 2.6.28.5
SVN-Revision: 14512
This commit is contained in:
parent
7ef75e79ce
commit
97dde3b72d
12 changed files with 40 additions and 77 deletions
|
@ -31,9 +31,6 @@ endif
|
|||
ifeq ($(LINUX_VERSION),2.6.27.15)
|
||||
LINUX_KERNEL_MD5SUM:=0756284efb091dccd012eec61def2004
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.28.4)
|
||||
LINUX_KERNEL_MD5SUM:=8228bb7804d6d0099eadfabf701c295b
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.28.5)
|
||||
LINUX_KERNEL_MD5SUM:=677e020f785f57ac48576eacb565a489
|
||||
endif
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -4,10 +4,8 @@ Port of the SPI-GPIO driver from 2.6.29-rc4.
|
|||
|
||||
|
||||
|
||||
Index: linux-2.6.28.2/drivers/spi/spi_gpio.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/drivers/spi/spi_gpio.c 2009-02-10 17:56:59.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/drivers/spi/spi_gpio.c
|
||||
@@ -0,0 +1,360 @@
|
||||
+/*
|
||||
+ * spi_gpio.c - SPI master driver using generic bitbanged GPIO
|
||||
|
@ -369,10 +367,8 @@ Index: linux-2.6.28.2/drivers/spi/spi_gpio.c
|
|||
+MODULE_DESCRIPTION("SPI master driver using generic bitbanged GPIO ");
|
||||
+MODULE_AUTHOR("David Brownell");
|
||||
+MODULE_LICENSE("GPL");
|
||||
Index: linux-2.6.28.2/include/linux/spi/spi_gpio.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/include/linux/spi/spi_gpio.h 2009-02-10 17:56:49.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/include/linux/spi/spi_gpio.h
|
||||
@@ -0,0 +1,60 @@
|
||||
+#ifndef __LINUX_SPI_GPIO_H
|
||||
+#define __LINUX_SPI_GPIO_H
|
||||
|
@ -434,10 +430,8 @@ Index: linux-2.6.28.2/include/linux/spi/spi_gpio.h
|
|||
+};
|
||||
+
|
||||
+#endif /* __LINUX_SPI_GPIO_H */
|
||||
Index: linux-2.6.28.2/drivers/spi/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/Kconfig 2009-02-10 17:57:10.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/Kconfig 2009-02-10 18:08:31.000000000 +0100
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -100,6 +100,22 @@ config SPI_BUTTERFLY
|
||||
inexpensive battery powered microcontroller evaluation board.
|
||||
This same cable can be used to flash new firmware.
|
||||
|
@ -461,10 +455,8 @@ Index: linux-2.6.28.2/drivers/spi/Kconfig
|
|||
config SPI_IMX
|
||||
tristate "Freescale iMX SPI controller"
|
||||
depends on ARCH_IMX && EXPERIMENTAL
|
||||
Index: linux-2.6.28.2/drivers/spi/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/Makefile 2009-02-10 17:58:46.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/Makefile 2009-02-10 18:08:31.000000000 +0100
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
|
||||
obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
|
||||
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
|
||||
|
|
|
@ -4,10 +4,8 @@ Fix spi-gpio for hotplug.
|
|||
|
||||
|
||||
|
||||
Index: linux-2.6.28.2/drivers/spi/spi_gpio.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/spi_gpio.c 2009-02-11 17:58:42.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/spi_gpio.c 2009-02-11 18:48:23.000000000 +0100
|
||||
--- a/drivers/spi/spi_gpio.c
|
||||
+++ b/drivers/spi/spi_gpio.c
|
||||
@@ -213,7 +213,7 @@ static void spi_gpio_cleanup(struct spi_
|
||||
spi_bitbang_cleanup(spi);
|
||||
}
|
||||
|
|
|
@ -4,10 +4,8 @@ Optionally omit the CS signal, if there's only one device on the bus.
|
|||
|
||||
|
||||
|
||||
Index: linux-2.6.28.2/drivers/spi/spi_gpio.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/spi_gpio.c 2009-02-11 18:48:23.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/spi_gpio.c 2009-02-11 18:48:50.000000000 +0100
|
||||
--- a/drivers/spi/spi_gpio.c
|
||||
+++ b/drivers/spi/spi_gpio.c
|
||||
@@ -178,8 +178,10 @@ static void spi_gpio_chipselect(struct s
|
||||
if (is_active)
|
||||
setsck(spi, spi->mode & SPI_CPOL);
|
||||
|
@ -54,10 +52,8 @@ Index: linux-2.6.28.2/drivers/spi/spi_gpio.c
|
|||
spi_bitbang_cleanup(spi);
|
||||
}
|
||||
|
||||
Index: linux-2.6.28.2/include/linux/spi/spi_gpio.h
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/include/linux/spi/spi_gpio.h 2009-02-11 18:48:23.000000000 +0100
|
||||
+++ linux-2.6.28.2/include/linux/spi/spi_gpio.h 2009-02-11 18:58:31.000000000 +0100
|
||||
--- a/include/linux/spi/spi_gpio.h
|
||||
+++ b/include/linux/spi/spi_gpio.h
|
||||
@@ -25,10 +25,16 @@
|
||||
* ...
|
||||
* };
|
||||
|
|
|
@ -6,10 +6,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
|
|||
|
||||
|
||||
|
||||
Index: linux-2.6.28.2/include/linux/spi/spi_gpio_old.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/include/linux/spi/spi_gpio_old.h 2009-02-10 17:59:21.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/include/linux/spi/spi_gpio_old.h
|
||||
@@ -0,0 +1,73 @@
|
||||
+/*
|
||||
+ * spi_gpio interface to platform code
|
||||
|
@ -84,10 +82,8 @@ Index: linux-2.6.28.2/include/linux/spi/spi_gpio_old.h
|
|||
+int spi_gpio_next_id(void);
|
||||
+
|
||||
+#endif /* _LINUX_SPI_SPI_GPIO */
|
||||
Index: linux-2.6.28.2/drivers/spi/spi_gpio_old.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/drivers/spi/spi_gpio_old.c 2009-02-10 17:59:21.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/drivers/spi/spi_gpio_old.c
|
||||
@@ -0,0 +1,251 @@
|
||||
+/*
|
||||
+ * Bitbanging SPI bus driver using GPIO API
|
||||
|
@ -340,10 +336,8 @@ Index: linux-2.6.28.2/drivers/spi/spi_gpio_old.c
|
|||
+MODULE_AUTHOR("Michael Buesch");
|
||||
+MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
|
||||
+MODULE_LICENSE("GPL v2");
|
||||
Index: linux-2.6.28.2/drivers/spi/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/Kconfig 2009-02-10 17:58:37.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/Kconfig 2009-02-10 17:59:21.000000000 +0100
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -116,6 +116,15 @@ config SPI_GPIO
|
||||
GPIO operations, you should be able to leverage that for better
|
||||
speed with a custom version of this driver; see the source code.
|
||||
|
@ -360,10 +354,8 @@ Index: linux-2.6.28.2/drivers/spi/Kconfig
|
|||
config SPI_IMX
|
||||
tristate "Freescale iMX SPI controller"
|
||||
depends on ARCH_IMX && EXPERIMENTAL
|
||||
Index: linux-2.6.28.2/drivers/spi/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/spi/Makefile 2009-02-10 17:59:04.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/spi/Makefile 2009-02-10 17:59:51.000000000 +0100
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -17,6 +17,7 @@ obj-$(CONFIG_SPI_BITBANG) += spi_bitban
|
||||
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
|
||||
obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: linux-2.6.28.2/drivers/mmc/host/gpiommc.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/drivers/mmc/host/gpiommc.c 2009-02-10 17:16:16.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/drivers/mmc/host/gpiommc.c
|
||||
@@ -0,0 +1,608 @@
|
||||
+/*
|
||||
+ * Driver an MMC/SD card on a bitbanging GPIO SPI bus.
|
||||
|
@ -611,10 +609,8 @@ Index: linux-2.6.28.2/drivers/mmc/host/gpiommc.c
|
|||
+ platform_driver_unregister(&gpiommc_plat_driver);
|
||||
+}
|
||||
+module_exit(gpiommc_modexit);
|
||||
Index: linux-2.6.28.2/drivers/mmc/host/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/mmc/host/Kconfig 2009-02-10 17:16:15.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/mmc/host/Kconfig 2009-02-10 17:16:16.000000000 +0100
|
||||
--- a/drivers/mmc/host/Kconfig
|
||||
+++ b/drivers/mmc/host/Kconfig
|
||||
@@ -192,3 +192,28 @@ config MMC_TMIO
|
||||
help
|
||||
This provides support for the SD/MMC cell found in TC6393XB,
|
||||
|
@ -644,20 +640,16 @@ Index: linux-2.6.28.2/drivers/mmc/host/Kconfig
|
|||
+ help
|
||||
+ This option automatically enables configfs support for gpiommc
|
||||
+ if configfs is available.
|
||||
Index: linux-2.6.28.2/drivers/mmc/host/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/drivers/mmc/host/Makefile 2009-02-10 17:16:15.000000000 +0100
|
||||
+++ linux-2.6.28.2/drivers/mmc/host/Makefile 2009-02-10 17:16:16.000000000 +0100
|
||||
--- a/drivers/mmc/host/Makefile
|
||||
+++ b/drivers/mmc/host/Makefile
|
||||
@@ -22,4 +22,5 @@ obj-$(CONFIG_MMC_SPI) += mmc_spi.o
|
||||
obj-$(CONFIG_MMC_S3C) += s3cmci.o
|
||||
obj-$(CONFIG_MMC_SDRICOH_CS) += sdricoh_cs.o
|
||||
obj-$(CONFIG_MMC_TMIO) += tmio_mmc.o
|
||||
+obj-$(CONFIG_GPIOMMC) += gpiommc.o
|
||||
|
||||
Index: linux-2.6.28.2/include/linux/mmc/gpiommc.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/include/linux/mmc/gpiommc.h 2009-02-10 17:16:16.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/include/linux/mmc/gpiommc.h
|
||||
@@ -0,0 +1,71 @@
|
||||
+/*
|
||||
+ * Device driver for MMC/SD cards driven over a GPIO bus.
|
||||
|
@ -730,10 +722,8 @@ Index: linux-2.6.28.2/include/linux/mmc/gpiommc.h
|
|||
+int gpiommc_next_id(void);
|
||||
+
|
||||
+#endif /* LINUX_GPIOMMC_H_ */
|
||||
Index: linux-2.6.28.2/Documentation/gpiommc.txt
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.28.2/Documentation/gpiommc.txt 2009-02-10 17:16:16.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/Documentation/gpiommc.txt
|
||||
@@ -0,0 +1,97 @@
|
||||
+GPIOMMC - Driver for an MMC/SD card on a bitbanging GPIO SPI bus
|
||||
+================================================================
|
||||
|
@ -832,10 +822,8 @@ Index: linux-2.6.28.2/Documentation/gpiommc.txt
|
|||
+(/config/gpiommc/my_mmc in this example).
|
||||
+There's no need to first unregister the device before removing it. That will
|
||||
+be done automatically.
|
||||
Index: linux-2.6.28.2/MAINTAINERS
|
||||
===================================================================
|
||||
--- linux-2.6.28.2.orig/MAINTAINERS 2009-02-10 17:16:15.000000000 +0100
|
||||
+++ linux-2.6.28.2/MAINTAINERS 2009-02-10 17:16:16.000000000 +0100
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -1911,6 +1911,11 @@ W: http://moinejf.free.fr
|
||||
L: video4linux-list@redhat.com
|
||||
S: Maintained
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
|
|||
FEATURES:=squashfs
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=orion
|
|||
BOARDNAME:=Marvell Orion
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=ppc44x
|
|||
BOARDNAME:=AMCC/IBM PPC44x
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=s3c24xx
|
|||
BOARDNAME:=s3c24xx
|
||||
FEATURES:=jffs2
|
||||
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=sibyte
|
|||
BOARDNAME:=Broadcom/SiByte SB-1
|
||||
FEATURES:=broken
|
||||
|
||||
LINUX_VERSION:=2.6.28.4
|
||||
LINUX_VERSION:=2.6.28.5
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
Loading…
Reference in a new issue