Fixup PCI compilation
SVN-Revision: 4697
This commit is contained in:
parent
900afdb448
commit
9671ee59e9
1 changed files with 54 additions and 46 deletions
|
@ -8032,26 +8032,26 @@ diff -urN linux.old/arch/mips/mm/tlbex.c linux.dev/arch/mips/mm/tlbex.c
|
||||||
tlbw(p);
|
tlbw(p);
|
||||||
break;
|
break;
|
||||||
|
|
||||||
diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup-bcm96348.c
|
diff -urN linux-2.6.17/arch/mips/pci/fixup-bcm96348.c linux-2.6.17-brcm63xx/arch/mips/pci/fixup-bcm96348.c
|
||||||
--- linux.old/arch/mips/pci/fixup-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
|
--- linux-2.6.17/arch/mips/pci/fixup-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ linux.dev/arch/mips/pci/fixup-bcm96348.c 2006-08-25 00:39:38.000000000 +0200
|
+++ linux-2.6.17-brcm63xx/arch/mips/pci/fixup-bcm96348.c 2006-08-29 10:25:22.000000000 +0200
|
||||||
@@ -0,0 +1,85 @@
|
@@ -0,0 +1,93 @@
|
||||||
+/*
|
+/*
|
||||||
+<:copyright-gpl
|
+<:copyright-gpl
|
||||||
+ Copyright 2002 Broadcom Corp. All Rights Reserved.
|
+ Copyright 2002 Broadcom Corp. All Rights Reserved.
|
||||||
+
|
+
|
||||||
+ This program is free software; you can distribute it and/or modify it
|
+ This program is free software; you can distribute it and/or modify it
|
||||||
+ under the terms of the GNU General Public License (Version 2) as
|
+ under the terms of the GNU General Public License (Version 2) as
|
||||||
+ published by the Free Software Foundation.
|
+ published by the Free Software Foundation.
|
||||||
+
|
+
|
||||||
+ This program is distributed in the hope it will be useful, but WITHOUT
|
+ This program is distributed in the hope it will be useful, but WITHOUT
|
||||||
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||||
+ FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
+ FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
||||||
+ for more details.
|
+ for more details.
|
||||||
+
|
+
|
||||||
+ You should have received a copy of the GNU General Public License along
|
+ You should have received a copy of the GNU General Public License along
|
||||||
+ with this program; if not, write to the Free Software Foundation, Inc.,
|
+ with this program; if not, write to the Free Software Foundation, Inc.,
|
||||||
+ 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
|
+ 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
|
||||||
+:>
|
+:>
|
||||||
+*/
|
+*/
|
||||||
+#include <linux/init.h>
|
+#include <linux/init.h>
|
||||||
|
@ -8091,10 +8091,10 @@ diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup
|
||||||
+ // Memory Window 1. Mask determines which bits are decoded.
|
+ // Memory Window 1. Mask determines which bits are decoded.
|
||||||
+ mpi->l2pmrange1 = ~(size-1);
|
+ mpi->l2pmrange1 = ~(size-1);
|
||||||
+ // UBUS to PCI Memory base address. This is akin to the ChipSelect base
|
+ // UBUS to PCI Memory base address. This is akin to the ChipSelect base
|
||||||
+ // register.
|
+ // register.
|
||||||
+ mpi->l2pmbase1 = memaddr & BCM_PCI_ADDR_MASK;
|
+ mpi->l2pmbase1 = memaddr & BCM_PCI_ADDR_MASK;
|
||||||
+ // UBUS to PCI Remap Address. Replaces the masked address bits in the
|
+ // UBUS to PCI Remap Address. Replaces the masked address bits in the
|
||||||
+ // range register with this setting.
|
+ // range register with this setting.
|
||||||
+ // Also, enable direct I/O and direct Memory accesses
|
+ // Also, enable direct I/O and direct Memory accesses
|
||||||
+ mpi->l2pmremap1 = (memaddr | MEM_WINDOW_EN);
|
+ mpi->l2pmremap1 = (memaddr | MEM_WINDOW_EN);
|
||||||
+ break;
|
+ break;
|
||||||
|
@ -8102,7 +8102,7 @@ diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup
|
||||||
+ case 1:
|
+ case 1:
|
||||||
+ // Memory Window 2
|
+ // Memory Window 2
|
||||||
+ mpi->l2pmrange2 = ~(size-1);
|
+ mpi->l2pmrange2 = ~(size-1);
|
||||||
+ // UBUS to PCI Memory base address.
|
+ // UBUS to PCI Memory base address.
|
||||||
+ mpi->l2pmbase2 = memaddr & BCM_PCI_ADDR_MASK;
|
+ mpi->l2pmbase2 = memaddr & BCM_PCI_ADDR_MASK;
|
||||||
+ // UBUS to PCI Remap Address
|
+ // UBUS to PCI Remap Address
|
||||||
+ mpi->l2pmremap2 = (memaddr | MEM_WINDOW_EN);
|
+ mpi->l2pmremap2 = (memaddr | MEM_WINDOW_EN);
|
||||||
|
@ -8117,10 +8117,18 @@ diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup
|
||||||
+ }
|
+ }
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+struct pci_fixup pcibios_fixups[] = {
|
+int pcibios_plat_dev_init(struct pci_dev *dev)
|
||||||
|
+{
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_BROADCOM, PCI_ANY_ID,
|
||||||
|
+ bcm96348_fixup);
|
||||||
|
+
|
||||||
|
+/*struct pci_fixup pcibios_fixups[] = {
|
||||||
+ { PCI_FIXUP_FINAL, PCI_ANY_ID, PCI_ANY_ID, bcm96348_fixup },
|
+ { PCI_FIXUP_FINAL, PCI_ANY_ID, PCI_ANY_ID, bcm96348_fixup },
|
||||||
+ {0}
|
+ {0}
|
||||||
+};
|
+};*/
|
||||||
diff -urN linux.old/arch/mips/pci/Makefile linux.dev/arch/mips/pci/Makefile
|
diff -urN linux.old/arch/mips/pci/Makefile linux.dev/arch/mips/pci/Makefile
|
||||||
--- linux.old/arch/mips/pci/Makefile 2006-08-25 00:43:29.000000000 +0200
|
--- linux.old/arch/mips/pci/Makefile 2006-08-25 00:43:29.000000000 +0200
|
||||||
+++ linux.dev/arch/mips/pci/Makefile 2006-08-25 00:39:38.000000000 +0200
|
+++ linux.dev/arch/mips/pci/Makefile 2006-08-25 00:39:38.000000000 +0200
|
||||||
|
@ -8412,26 +8420,26 @@ diff -urN linux.old/arch/mips/pci/ops-bcm96348.c linux.dev/arch/mips/pci/ops-bcm
|
||||||
+ .read = bcm96348_pcibios_read,
|
+ .read = bcm96348_pcibios_read,
|
||||||
+ .write = bcm96348_pcibios_write
|
+ .write = bcm96348_pcibios_write
|
||||||
+};
|
+};
|
||||||
diff -urN linux.old/arch/mips/pci/pci-bcm96348.c linux.dev/arch/mips/pci/pci-bcm96348.c
|
diff -urN linux-2.6.17/arch/mips/pci/pci-bcm96348.c linux-2.6.17-brcm63xx/arch/mips/pci/pci-bcm96348.c
|
||||||
--- linux.old/arch/mips/pci/pci-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
|
--- linux-2.6.17/arch/mips/pci/pci-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ linux.dev/arch/mips/pci/pci-bcm96348.c 2006-08-25 00:39:38.000000000 +0200
|
+++ linux-2.6.17-brcm63xx/arch/mips/pci/pci-bcm96348.c 2006-08-29 10:25:13.000000000 +0200
|
||||||
@@ -0,0 +1,54 @@
|
@@ -0,0 +1,54 @@
|
||||||
+/*
|
+/*
|
||||||
+<:copyright-gpl
|
+<:copyright-gpl
|
||||||
+ Copyright 2002 Broadcom Corp. All Rights Reserved.
|
+ Copyright 2002 Broadcom Corp. All Rights Reserved.
|
||||||
+
|
+
|
||||||
+ This program is free software; you can distribute it and/or modify it
|
+ This program is free software; you can distribute it and/or modify it
|
||||||
+ under the terms of the GNU General Public License (Version 2) as
|
+ under the terms of the GNU General Public License (Version 2) as
|
||||||
+ published by the Free Software Foundation.
|
+ published by the Free Software Foundation.
|
||||||
+
|
+
|
||||||
+ This program is distributed in the hope it will be useful, but WITHOUT
|
+ This program is distributed in the hope it will be useful, but WITHOUT
|
||||||
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||||
+ FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
+ FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
||||||
+ for more details.
|
+ for more details.
|
||||||
+
|
+
|
||||||
+ You should have received a copy of the GNU General Public License along
|
+ You should have received a copy of the GNU General Public License along
|
||||||
+ with this program; if not, write to the Free Software Foundation, Inc.,
|
+ with this program; if not, write to the Free Software Foundation, Inc.,
|
||||||
+ 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
|
+ 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
|
||||||
+:>
|
+:>
|
||||||
+*/
|
+*/
|
||||||
+#include <linux/types.h>
|
+#include <linux/types.h>
|
||||||
|
@ -8439,7 +8447,7 @@ diff -urN linux.old/arch/mips/pci/pci-bcm96348.c linux.dev/arch/mips/pci/pci-bcm
|
||||||
+#include <linux/kernel.h>
|
+#include <linux/kernel.h>
|
||||||
+#include <linux/init.h>
|
+#include <linux/init.h>
|
||||||
+
|
+
|
||||||
+#include <asm/pci_channel.h>
|
+//#include <asm/pci_channel.h>
|
||||||
+#include <bcmpci.h>
|
+#include <bcmpci.h>
|
||||||
+
|
+
|
||||||
+static struct resource bcm_pci_io_resource = {
|
+static struct resource bcm_pci_io_resource = {
|
||||||
|
@ -8459,9 +8467,9 @@ diff -urN linux.old/arch/mips/pci/pci-bcm96348.c linux.dev/arch/mips/pci/pci-bcm
|
||||||
+extern struct pci_ops bcm96348_pci_ops;
|
+extern struct pci_ops bcm96348_pci_ops;
|
||||||
+
|
+
|
||||||
+struct pci_controller bcm96348_controller = {
|
+struct pci_controller bcm96348_controller = {
|
||||||
+ .pci_ops = &bcm96348_pci_ops,
|
+ .pci_ops = &bcm96348_pci_ops,
|
||||||
+ .io_resource = &bcm_pci_io_resource,
|
+ .io_resource = &bcm_pci_io_resource,
|
||||||
+ .mem_resource = &bcm_pci_mem_resource,
|
+ .mem_resource = &bcm_pci_mem_resource,
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
+static void bcm96348_pci_init(void)
|
+static void bcm96348_pci_init(void)
|
||||||
|
|
Loading…
Reference in a new issue