madwifi: fix x86_64 compilation

SVN-Revision: 12574
This commit is contained in:
Felix Fietkau 2008-09-12 19:55:38 +00:00
parent 52bb4fac97
commit 9029e3d9ef

View file

@ -0,0 +1,16 @@
--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,6 +36,13 @@
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)