opkg: reenable global upgrade, refresh patches
SVN-Revision: 23174
This commit is contained in:
parent
a2328ecf96
commit
8e9dfc063f
4 changed files with 6 additions and 47 deletions
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
PKG_NAME:=opkg
|
||||
PKG_REV:=563
|
||||
PKG_VERSION:=$(PKG_REV)
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
|
|
|
@ -6,7 +6,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
|||
|
||||
--- a/libopkg/opkg_conf.c
|
||||
+++ b/libopkg/opkg_conf.c
|
||||
@@ -62,6 +62,7 @@ opkg_option_t options[] = {
|
||||
@@ -63,6 +63,7 @@ opkg_option_t options[] = {
|
||||
{ "download_only", OPKG_OPT_TYPE_BOOL, &_conf.download_only },
|
||||
{ "nodeps", OPKG_OPT_TYPE_BOOL, &_conf.nodeps },
|
||||
{ "offline_root", OPKG_OPT_TYPE_STRING, &_conf.offline_root },
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
|||
{ "query-all", OPKG_OPT_TYPE_BOOL, &_conf.query_all },
|
||||
--- a/libopkg/opkg_conf.h
|
||||
+++ b/libopkg/opkg_conf.h
|
||||
@@ -76,6 +76,7 @@ struct opkg_conf
|
||||
@@ -78,6 +78,7 @@ struct opkg_conf
|
||||
int check_signature;
|
||||
int nodeps; /* do not follow dependencies */
|
||||
char *offline_root;
|
||||
|
@ -34,7 +34,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
|||
|
||||
#include "pkg.h"
|
||||
#include "pkg_hash.h"
|
||||
@@ -189,13 +190,24 @@ static int
|
||||
@@ -192,13 +193,24 @@ static int
|
||||
verify_pkg_installable(pkg_t *pkg)
|
||||
{
|
||||
unsigned long kbs_available, pkg_size_kbs;
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
--- a/libopkg/opkg_cmd.c
|
||||
+++ b/libopkg/opkg_cmd.c
|
||||
@@ -508,18 +508,6 @@ opkg_upgrade_cmd(int argc, char **argv)
|
||||
err = -1;
|
||||
}
|
||||
}
|
||||
- } else {
|
||||
- pkg_vec_t *installed = pkg_vec_alloc();
|
||||
-
|
||||
- pkg_info_preinstall_check();
|
||||
-
|
||||
- pkg_hash_fetch_all_installed(installed);
|
||||
- for (i = 0; i < installed->len; i++) {
|
||||
- pkg = installed->pkgs[i];
|
||||
- if (opkg_upgrade_pkg(pkg))
|
||||
- err = -1;
|
||||
- }
|
||||
- pkg_vec_free(installed);
|
||||
}
|
||||
|
||||
if (opkg_configure_packages(NULL))
|
||||
@@ -1182,7 +1170,7 @@ opkg_print_architecture_cmd(int argc, ch
|
||||
array for easier maintenance */
|
||||
static opkg_cmd_t cmds[] = {
|
||||
{"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
||||
- {"upgrade", 0, (opkg_cmd_fun_t)opkg_upgrade_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
||||
+ {"upgrade", 1, (opkg_cmd_fun_t)opkg_upgrade_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
||||
{"list", 0, (opkg_cmd_fun_t)opkg_list_cmd, PFM_SOURCE},
|
||||
{"list_installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
|
||||
{"list-installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
|
||||
--- a/src/opkg-cl.c
|
||||
+++ b/src/opkg-cl.c
|
||||
@@ -217,7 +217,7 @@ usage()
|
||||
|
||||
printf("\nPackage Manipulation:\n");
|
||||
printf("\tupdate Update list of available packages\n");
|
||||
- printf("\tupgrade Upgrade installed packages\n");
|
||||
+ printf("\tupgrade <pkgs> Upgrade packages\n");
|
||||
printf("\tinstall <pkgs> Install package(s)\n");
|
||||
printf("\tconfigure <pkgs> Configure unpacked package(s)\n");
|
||||
printf("\tremove <pkgs|regexp> Remove package(s)\n");
|
|
@ -1,6 +1,6 @@
|
|||
--- a/libopkg/opkg_install.c
|
||||
+++ b/libopkg/opkg_install.c
|
||||
@@ -271,6 +271,7 @@ unpack_pkg_control_files(pkg_t *pkg)
|
||||
@@ -274,6 +274,7 @@ unpack_pkg_control_files(pkg_t *pkg)
|
||||
while (1) {
|
||||
char *cf_name;
|
||||
char *cf_name_in_dest;
|
||||
|
@ -8,7 +8,7 @@
|
|||
|
||||
cf_name = file_read_line_alloc(conffiles_file);
|
||||
if (cf_name == NULL) {
|
||||
@@ -279,6 +280,12 @@ unpack_pkg_control_files(pkg_t *pkg)
|
||||
@@ -282,6 +283,12 @@ unpack_pkg_control_files(pkg_t *pkg)
|
||||
if (cf_name[0] == '\0') {
|
||||
continue;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue