kernel: update linux 3.8 to 3.8.11
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36507
This commit is contained in:
parent
db02b0e4ee
commit
8a9fe26f20
32 changed files with 37 additions and 108 deletions
|
@ -11,8 +11,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.7.10)
|
||||
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.8.10)
|
||||
LINUX_KERNEL_MD5SUM:=3d5fb6d9add9cce7725bbe9b139c8d6e
|
||||
ifeq ($(LINUX_VERSION),3.8.11)
|
||||
LINUX_KERNEL_MD5SUM:=3c4f4fc96bf702d1e9dfbf4d4b4cde9d
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.9)
|
||||
LINUX_KERNEL_MD5SUM:=4348c9b6b2eb3144d601e87c19d5d909
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
SUBTARGETS:=router_le router_be rb1xx
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -191,7 +191,7 @@
|
|||
/*
|
||||
--- a/net/ipv4/tcp_input.c
|
||||
+++ b/net/ipv4/tcp_input.c
|
||||
@@ -3868,13 +3868,14 @@ static bool tcp_parse_aligned_timestamp(
|
||||
@@ -3896,13 +3896,14 @@ static bool tcp_parse_aligned_timestamp(
|
||||
{
|
||||
const __be32 *ptr = (const __be32 *)(th + 1);
|
||||
|
||||
|
@ -279,7 +279,7 @@
|
|||
#include <asm/uaccess.h>
|
||||
|
||||
#include <linux/proc_fs.h>
|
||||
@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
|
||||
@@ -764,10 +765,10 @@ static void tcp_v6_send_response(struct
|
||||
topt = (__be32 *)(t1 + 1);
|
||||
|
||||
if (ts) {
|
||||
|
|
|
@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
|
|||
FEATURES:=squashfs jffs2 targz ext2 usb
|
||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs jffs2
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
|||
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||
FEATURES:=squashfs usb pcmcia
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
|
|||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
|
|||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -49,7 +49,7 @@
|
|||
|
||||
int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
|
||||
unsigned char banned_flags)
|
||||
@@ -4941,6 +4940,9 @@ int __init addrconf_init(void)
|
||||
@@ -4968,6 +4967,9 @@ int __init addrconf_init(void)
|
||||
|
||||
ipv6_addr_label_rtnl_register();
|
||||
|
||||
|
@ -59,7 +59,7 @@
|
|||
return 0;
|
||||
errout:
|
||||
rtnl_af_unregister(&inet6_ops);
|
||||
@@ -4959,6 +4961,9 @@ void addrconf_cleanup(void)
|
||||
@@ -4986,6 +4988,9 @@ void addrconf_cleanup(void)
|
||||
struct net_device *dev;
|
||||
int i;
|
||||
|
||||
|
|
|
@ -79,7 +79,7 @@
|
|||
help
|
||||
--- a/net/core/dev.c
|
||||
+++ b/net/core/dev.c
|
||||
@@ -2360,9 +2360,19 @@ int dev_hard_start_xmit(struct sk_buff *
|
||||
@@ -2364,9 +2364,19 @@ int dev_hard_start_xmit(struct sk_buff *
|
||||
if (!list_empty(&ptype_all))
|
||||
dev_queue_xmit_nit(skb, dev);
|
||||
|
||||
|
@ -102,7 +102,7 @@
|
|||
if (rc == NETDEV_TX_OK)
|
||||
txq_trans_update(txq);
|
||||
return rc;
|
||||
@@ -2385,9 +2395,19 @@ gso:
|
||||
@@ -2389,9 +2399,19 @@ gso:
|
||||
if (!list_empty(&ptype_all))
|
||||
dev_queue_xmit_nit(nskb, dev);
|
||||
|
||||
|
|
|
@ -173,7 +173,7 @@
|
|||
goto err;
|
||||
--- a/net/core/dev.c
|
||||
+++ b/net/core/dev.c
|
||||
@@ -4584,9 +4584,11 @@ static int __net_init dev_proc_net_init(
|
||||
@@ -4588,9 +4588,11 @@ static int __net_init dev_proc_net_init(
|
||||
|
||||
if (!proc_net_fops_create(net, "dev", S_IRUGO, &dev_seq_fops))
|
||||
goto out;
|
||||
|
@ -187,7 +187,7 @@
|
|||
goto out_softnet;
|
||||
|
||||
if (wext_proc_init(net))
|
||||
@@ -4595,9 +4597,11 @@ static int __net_init dev_proc_net_init(
|
||||
@@ -4599,9 +4601,11 @@ static int __net_init dev_proc_net_init(
|
||||
out:
|
||||
return rc;
|
||||
out_ptype:
|
||||
|
@ -201,7 +201,7 @@
|
|||
out_dev:
|
||||
proc_net_remove(net, "dev");
|
||||
goto out;
|
||||
@@ -4607,8 +4611,10 @@ static void __net_exit dev_proc_net_exit
|
||||
@@ -4611,8 +4615,10 @@ static void __net_exit dev_proc_net_exit
|
||||
{
|
||||
wext_proc_exit(net);
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
|
|||
FEATURES:=squashfs jffs2
|
||||
SUBTARGETS=xway ase falcon
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
||||
FEATURES:=targz ext4
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
|||
FEATURES:=squashfs targz
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic p1020
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
|
|||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1,71 +0,0 @@
|
|||
From: Dmitri Epshtein <dima@marvell.com>
|
||||
|
||||
In order for the driver to behave properly in a SMP context, the same
|
||||
transmit queue should be used by the kernel in dev_queue_xmit() and in
|
||||
the driver's mvneta_tx() function. To achieve that, the driver now
|
||||
implements the ->ndo_select_txq() operation.
|
||||
|
||||
For now, it always returns the same transmit queue, txq_def, until the
|
||||
driver is expanded to properly take advantage of the multiqueue
|
||||
capabilities of the hardware.
|
||||
|
||||
Without this patch, the network driver crashes the kernel almost
|
||||
immediately on Armada XP platforms, if the network load is at least a
|
||||
little bit parallel (i.e several threads).
|
||||
|
||||
[Thomas Petazzoni: reword commit message]
|
||||
Signed-off-by: Dmitri Epshtein <dima@marvell.com>
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
This is 3.8-rc material.
|
||||
---
|
||||
drivers/net/ethernet/marvell/mvneta.c | 17 +++++++++++++++--
|
||||
1 file changed, 15 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/drivers/net/ethernet/marvell/mvneta.c
|
||||
+++ b/drivers/net/ethernet/marvell/mvneta.c
|
||||
@@ -1310,6 +1310,17 @@ static u32 mvneta_skb_tx_csum(struct mvn
|
||||
return MVNETA_TX_L4_CSUM_NOT;
|
||||
}
|
||||
|
||||
+static u16 mvneta_tx_policy(struct mvneta_port *pp, struct sk_buff *skb)
|
||||
+{
|
||||
+ return (u16)txq_def;
|
||||
+}
|
||||
+
|
||||
+static u16 mvneta_select_txq(struct net_device *dev, struct sk_buff *skb)
|
||||
+{
|
||||
+ struct mvneta_port *pp = netdev_priv(dev);
|
||||
+ return mvneta_tx_policy(pp, skb);
|
||||
+}
|
||||
+
|
||||
/* Returns rx queue pointer (find last set bit) according to causeRxTx
|
||||
* value
|
||||
*/
|
||||
@@ -1476,7 +1487,8 @@ error:
|
||||
static int mvneta_tx(struct sk_buff *skb, struct net_device *dev)
|
||||
{
|
||||
struct mvneta_port *pp = netdev_priv(dev);
|
||||
- struct mvneta_tx_queue *txq = &pp->txqs[txq_def];
|
||||
+ u16 txq_id = mvneta_tx_policy(pp, skb);
|
||||
+ struct mvneta_tx_queue *txq = &pp->txqs[txq_id];
|
||||
struct mvneta_tx_desc *tx_desc;
|
||||
struct netdev_queue *nq;
|
||||
int frags = 0;
|
||||
@@ -1486,7 +1498,7 @@ static int mvneta_tx(struct sk_buff *skb
|
||||
goto out;
|
||||
|
||||
frags = skb_shinfo(skb)->nr_frags + 1;
|
||||
- nq = netdev_get_tx_queue(dev, txq_def);
|
||||
+ nq = netdev_get_tx_queue(dev, txq_id);
|
||||
|
||||
/* Get a descriptor for the first part of the packet */
|
||||
tx_desc = mvneta_txq_next_desc_get(txq);
|
||||
@@ -2550,6 +2562,7 @@ static const struct net_device_ops mvnet
|
||||
.ndo_change_mtu = mvneta_change_mtu,
|
||||
.ndo_tx_timeout = mvneta_tx_timeout,
|
||||
.ndo_get_stats64 = mvneta_get_stats64,
|
||||
+ .ndo_select_queue = mvneta_select_txq,
|
||||
};
|
||||
|
||||
const struct ethtool_ops mvneta_eth_tool_ops = {
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
||||
FEATURES:=squashfs gpio
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci targz broken
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
|||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
|
||||
kmod-ledtrig-netdev \
|
||||
kmod-cpu-msr hwclock wpad
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
CS5535_MASK:=0x0b000042
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
BOARDNAME:=Generic
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
define Target/Description
|
||||
Build firmware images for x86 based boards
|
||||
|
|
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-cpu-msr \
|
||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||
hwclock wpad flashrom tc
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
CS5535_MASK:=0x0E000048
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
|||
FEATURES:=jffs2 targz ubifs audio broken
|
||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||
|
||||
LINUX_VERSION:=3.8.10
|
||||
LINUX_VERSION:=3.8.11
|
||||
|
||||
DEVICE_TYPE=other
|
||||
|
||||
|
|
Loading…
Reference in a new issue