mips: do not use the prefetch instruction on R4K (MIPS32_R1), the ISA does not implement it
SVN-Revision: 16771
This commit is contained in:
parent
3e7d58574f
commit
877015bee9
3 changed files with 22 additions and 2 deletions
|
@ -20,7 +20,7 @@
|
||||||
config MIPS_COBALT
|
config MIPS_COBALT
|
||||||
bool "Cobalt Server"
|
bool "Cobalt Server"
|
||||||
select CEVT_R4K
|
select CEVT_R4K
|
||||||
@@ -632,6 +645,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
|
@@ -633,6 +646,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@
|
||||||
source "arch/mips/jazz/Kconfig"
|
source "arch/mips/jazz/Kconfig"
|
||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -290,6 +290,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
|
@@ -283,6 +283,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
|
||||||
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
|
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
|
||||||
|
|
||||||
#
|
#
|
||||||
|
|
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/arch/mips/Kconfig
|
||||||
|
+++ b/arch/mips/Kconfig
|
||||||
|
@@ -991,7 +991,6 @@ config CPU_MIPS32_R1
|
||||||
|
bool "MIPS32 Release 1"
|
||||||
|
depends on SYS_HAS_CPU_MIPS32_R1
|
||||||
|
select CPU_HAS_LLSC
|
||||||
|
- select CPU_HAS_PREFETCH
|
||||||
|
select CPU_SUPPORTS_32BIT_KERNEL
|
||||||
|
select CPU_SUPPORTS_HIGHMEM
|
||||||
|
help
|
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/arch/mips/Kconfig
|
||||||
|
+++ b/arch/mips/Kconfig
|
||||||
|
@@ -1036,7 +1036,6 @@ config CPU_MIPS32_R1
|
||||||
|
bool "MIPS32 Release 1"
|
||||||
|
depends on SYS_HAS_CPU_MIPS32_R1
|
||||||
|
select CPU_HAS_LLSC
|
||||||
|
- select CPU_HAS_PREFETCH
|
||||||
|
select CPU_SUPPORTS_32BIT_KERNEL
|
||||||
|
select CPU_SUPPORTS_HIGHMEM
|
||||||
|
help
|
Loading…
Reference in a new issue