flex: fix build error due to undefined library symbols
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39888
This commit is contained in:
parent
73d9ad0c95
commit
8087fa9e04
2 changed files with 19 additions and 1 deletions
|
@ -41,7 +41,7 @@ tools-$(BUILD_PPL_CLOOG) += ppl cloog
|
|||
|
||||
# builddir dependencies
|
||||
$(curdir)/bison/compile := $(curdir)/flex/install
|
||||
$(curdir)/flex/compile := $(curdir)/m4/install
|
||||
$(curdir)/flex/compile := $(curdir)/automake/install
|
||||
$(curdir)/pkg-config/compile := $(curdir)/sed/install
|
||||
$(curdir)/libtool/compile := $(curdir)/sed/install
|
||||
$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
|
||||
|
|
18
tools/flex/patches/100-remove_no_undefined.patch
Normal file
18
tools/flex/patches/100-remove_no_undefined.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
|
||||
libmain.c \
|
||||
libyywrap.c
|
||||
|
||||
-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
|
||||
+libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
|
||||
|
||||
libfl_pic_la_SOURCES = \
|
||||
libmain.c \
|
||||
libyywrap.c
|
||||
|
||||
-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
|
||||
+libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
|
||||
|
||||
noinst_HEADERS = \
|
||||
flexdef.h \
|
Loading…
Reference in a new issue