eglibc: add a fake libintl.h for cross-rpcgen and cross-zic to fix build on mac os x
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 34026
This commit is contained in:
parent
54f799dd58
commit
7efe435f49
3 changed files with 29 additions and 0 deletions
|
@ -60,6 +60,7 @@ EGLIBC_CONFIGURE:= \
|
|||
|
||||
export libc_cv_ssp=no
|
||||
export ac_cv_header_cpuid_h=yes
|
||||
export HOST_CFLAGS := $(HOST_CFLAGS) -idirafter $(CURDIR)/$(PATH_PREFIX)/include
|
||||
|
||||
define Host/SetToolchainInfo
|
||||
$(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
|
||||
|
|
6
toolchain/eglibc/include/libintl.h
Normal file
6
toolchain/eglibc/include/libintl.h
Normal file
|
@ -0,0 +1,6 @@
|
|||
#ifndef __FAKE_LIBINTL_H
|
||||
#define __FAKE_LIBINTL_H
|
||||
|
||||
#define _(X) (X)
|
||||
|
||||
#endif
|
22
toolchain/eglibc/patches/2.15/120-use_host_cflags.patch
Normal file
22
toolchain/eglibc/patches/2.15/120-use_host_cflags.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/libc/sunrpc/Makefile
|
||||
+++ b/libc/sunrpc/Makefile
|
||||
@@ -175,7 +175,7 @@ $(objpfx)rpcgen: $(addprefix $(objpfx),$
|
||||
$(+link)
|
||||
|
||||
$(addprefix $(objpfx)cross-,$(rpcgen-objs)): $(objpfx)cross-%.o: %.c
|
||||
- gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ \
|
||||
+ gcc $< -c -D_RPC_THREAD_SAFE_ -D_CROSS_RPCGEN_ $(HOST_CFLAGS) \
|
||||
$(OUTPUT_OPTION) $(compile-mkdep-flags)
|
||||
|
||||
$(objpfx)cross-rpcgen: $(addprefix $(objpfx)cross-,$(rpcgen-objs))
|
||||
--- a/libc/timezone/Makefile
|
||||
+++ b/libc/timezone/Makefile
|
||||
@@ -182,7 +182,7 @@ $(objpfx)zic: $(addprefix $(objpfx), $(z
|
||||
|
||||
$(addprefix $(objpfx)cross-,$(zic-objs)): $(objpfx)cross-%.o: %.c
|
||||
gcc $< -c $(OUTPUT_OPTION) $(CFLAGS-$*.c) $(CPPFLAGS-$*) \
|
||||
- -DCROSS_ZIC $(compile-mkdep-flags)
|
||||
+ -DCROSS_ZIC $(HOST_CFLAGS) $(compile-mkdep-flags)
|
||||
|
||||
$(objpfx)cross-zic: $(addprefix $(objpfx)cross-,$(zic-objs))
|
||||
gcc $(addprefix $(objpfx)cross-,$(zic-objs)) -o $@
|
Loading…
Reference in a new issue