fix fetchmail package, add svn:keywords prop to Makefile, standardize.
SVN-Revision: 3572
This commit is contained in:
parent
8186dc04e9
commit
7e36c32011
2 changed files with 49 additions and 20 deletions
|
@ -1,17 +1,18 @@
|
|||
# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fetchmail
|
||||
PKG_VERSION:=6.2.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
|
||||
|
||||
PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
|
@ -28,32 +29,39 @@ $(PKG_BUILD_DIR)/.configured:
|
|||
ac_cv_sizeof_int=4 \
|
||||
ac_cv_sizeof_long=4 \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--sbindir=/usr/sbin \
|
||||
--libexecdir=/usr/lib \
|
||||
--sysconfdir=/etc \
|
||||
--datadir=/usr/share \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--program-prefix="" \
|
||||
--enable-fallback=procmail \
|
||||
$(DISABLE_NLS) \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-fallback=procmail \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC)
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_FETCHMAIL):
|
||||
mkdir -p $(IDIR_FETCHMAIL)/usr/bin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_FETCHMAIL)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(IDIR_FETCHMAIL)/usr/bin/
|
||||
$(RSTRIP) $(IDIR_FETCHMAIL)
|
||||
$(IPKG_BUILD) $(IDIR_FETCHMAIL) $(PACKAGE_DIR)
|
||||
|
|
21
openwrt/package/fetchmail/patches/02-no_rej.patch
Normal file
21
openwrt/package/fetchmail/patches/02-no_rej.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff -ruN fetchmail-6.2.5-old/po/fr.po.rej fetchmail-6.2.5-new/po/fr.po.rej
|
||||
--- fetchmail-6.2.5-old/po/fr.po.rej 2003-07-17 03:23:26.000000000 +0200
|
||||
+++ fetchmail-6.2.5-new/po/fr.po.rej 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,17 +0,0 @@
|
||||
-***************
|
||||
-*** 2166,2172 ****
|
||||
- #: rcfile_y.y:433
|
||||
- #, fuzzy, c-format
|
||||
- msgid "File %s must be a regular file.\n"
|
||||
-- msgstr "Le fichier %s doit etre un lien symbolique.\n"
|
||||
-
|
||||
- #: rcfile_y.y:440
|
||||
- #, c-format
|
||||
---- 2166,2172 ----
|
||||
- #: rcfile_y.y:433
|
||||
- #, fuzzy, c-format
|
||||
- msgid "File %s must be a regular file.\n"
|
||||
-+ msgstr "Le fichier %s doit être un fichier normal.\n"
|
||||
-
|
||||
- #: rcfile_y.y:440
|
||||
- #, c-format
|
Loading…
Reference in a new issue