elfutils: bump to 0.162
Besides source.tgz, 001-elfutils-portability.patch (provided by upstream project) where updated. Other patches where updated to fix hulk warnings and minor conflicts. Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> SVN-Revision: 45984
This commit is contained in:
parent
9e2ec0a55c
commit
7ba6500d2c
9 changed files with 634 additions and 447 deletions
|
@ -7,12 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=elfutils
|
||||
PKG_VERSION:=0.161
|
||||
PKG_VERSION:=0.162
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=e1b9847c9a6a1ad340de8d47a863ec52
|
||||
PKG_MD5SUM:=9334cbcc0df7669b7bf07cf7fc3ad52c
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0+
|
||||
PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,6 +1,6 @@
|
|||
--- elfutils-0.160/lib/color.c.old 2014-11-06 03:46:43.584116134 -0200
|
||||
+++ elfutils-0.160/lib/color.c 2014-11-06 03:47:25.840116128 -0200
|
||||
@@ -131,8 +131,10 @@
|
||||
--- a/lib/color.c
|
||||
+++ b/lib/color.c
|
||||
@@ -131,8 +131,10 @@ valid arguments are:\n\
|
||||
- 'never', 'no', 'none'\n\
|
||||
- 'auto', 'tty', 'if-tty'\n"),
|
||||
program_invocation_short_name, arg);
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
--- elfutils-0.160/libelf/libelfP.h.old 2014-11-06 01:47:55.420116984 -0200
|
||||
+++ elfutils-0.160/libelf/libelfP.h 2014-11-06 01:48:33.368116980 -0200
|
||||
@@ -43,6 +43,9 @@
|
||||
--- a/libelf/libelfP.h
|
||||
+++ b/libelf/libelfP.h
|
||||
@@ -42,6 +42,9 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
|
||||
+#ifdef _ /* fix libintl-stub */
|
||||
|
@ -9,9 +10,8 @@
|
|||
/* gettext helper macros. */
|
||||
#define _(Str) dgettext ("elfutils", Str)
|
||||
|
||||
|
||||
--- elfutils-0.160/libdw/libdwP.h.old 2014-11-06 02:27:12.628116703 -0200
|
||||
+++ elfutils-0.160/libdw/libdwP.h 2014-11-06 02:27:39.816116700 -0200
|
||||
--- a/libdw/libdwP.h
|
||||
+++ b/libdw/libdwP.h
|
||||
@@ -36,7 +36,9 @@
|
||||
#include <libdw.h>
|
||||
#include <dwarf.h>
|
||||
|
@ -23,8 +23,8 @@
|
|||
/* gettext helper macros. */
|
||||
#define _(Str) dgettext ("elfutils", Str)
|
||||
|
||||
--- elfutils-0.160/libdwfl/libdwflP.h.old 2014-11-06 02:31:20.112116673 -0200
|
||||
+++ elfutils-0.160/libdwfl/libdwflP.h 2014-11-06 02:33:00.548116661 -0200
|
||||
--- a/libdwfl/libdwflP.h
|
||||
+++ b/libdwfl/libdwflP.h
|
||||
@@ -46,6 +46,9 @@
|
||||
|
||||
typedef struct Dwfl_Process Dwfl_Process;
|
||||
|
@ -35,8 +35,8 @@
|
|||
/* gettext helper macros. */
|
||||
#define _(Str) dgettext ("elfutils", Str)
|
||||
|
||||
--- elfutils-0.160/libasm/libasmP.h.old 2014-11-06 02:31:32.064116672 -0200
|
||||
+++ elfutils-0.160/libasm/libasmP.h 2014-11-06 02:33:08.656116660 -0200
|
||||
--- a/libasm/libasmP.h
|
||||
+++ b/libasm/libasmP.h
|
||||
@@ -33,6 +33,9 @@
|
||||
|
||||
#include <libasm.h>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- elfutils-0.160/libelf/elf_getarsym.c.org 2014-11-06 01:56:58.664116919 -0200
|
||||
+++ elfutils-0.160/libelf/elf_getarsym.c 2014-11-06 01:57:09.396116918 -0200
|
||||
@@ -166,7 +166,7 @@
|
||||
--- a/libelf/elf_getarsym.c
|
||||
+++ b/libelf/elf_getarsym.c
|
||||
@@ -169,7 +169,7 @@ elf_getarsym (elf, ptr)
|
||||
|
||||
/* We have an archive. The first word in there is the number of
|
||||
entries in the table. */
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- elfutils-0.160/Makefile.in.old 2014-11-06 03:56:04.828116067 -0200
|
||||
+++ elfutils-0.160/Makefile.in 2014-11-06 03:57:03.380116060 -0200
|
||||
@@ -359,8 +359,7 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -363,8 +363,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
# Add doc back when we have some real content.
|
||||
|
@ -10,9 +10,9 @@
|
|||
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
||||
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
--- elfutils-0.160/Makefile.am.old 2014-11-06 03:58:13.012116051 -0200
|
||||
+++ elfutils-0.160/Makefile.am 2014-11-06 03:58:25.948116050 -0200
|
||||
@@ -23,8 +23,7 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -23,8 +23,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
# Add doc back when we have some real content.
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- elfutils-0.161/libdw/Makefile.in.orig 2015-01-16 03:50:15.311237461 -0200
|
||||
+++ elfutils-0.161/libdw/Makefile.in 2015-01-16 03:55:35.082090075 -0200
|
||||
@@ -969,7 +969,7 @@
|
||||
--- a/libdw/Makefile.in
|
||||
+++ b/libdw/Makefile.in
|
||||
@@ -980,7 +980,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
|
||||
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
|
||||
-Wl,--version-script,$<,--no-undefined \
|
||||
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
- -ldl $(zip_LIBS)
|
||||
+ -ldl $(zip_LIBS) $(LIBS)
|
||||
- -ldl $(argp_LDADD) $(zip_LIBS)
|
||||
+ -ldl $(argp_LDADD) $(zip_LIBS) $(LIBS)
|
||||
@$(textrel_check)
|
||||
ln -fs $@ $@.$(VERSION)
|
||||
|
||||
|
|
|
@ -705,7 +705,7 @@
|
|||
for (subs = nodep->next; subs != NULL; subs = subs->next)
|
||||
--- a/libdwfl/dwfl_error.c
|
||||
+++ b/libdwfl/dwfl_error.c
|
||||
@@ -128,6 +128,7 @@ const char *
|
||||
@@ -141,6 +141,7 @@ const char *
|
||||
dwfl_errmsg (error)
|
||||
int error;
|
||||
{
|
||||
|
@ -713,7 +713,7 @@
|
|||
if (error == 0 || error == -1)
|
||||
{
|
||||
int last_error = global_error;
|
||||
@@ -142,7 +143,8 @@ dwfl_errmsg (error)
|
||||
@@ -155,7 +156,8 @@ dwfl_errmsg (error)
|
||||
switch (error &~ 0xffff)
|
||||
{
|
||||
case OTHER_ERROR (ERRNO):
|
||||
|
@ -755,7 +755,7 @@
|
|||
typedef struct Dwfl Dwfl;
|
||||
--- a/libdwfl/find-debuginfo.c
|
||||
+++ b/libdwfl/find-debuginfo.c
|
||||
@@ -338,7 +338,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
|
||||
@@ -360,7 +360,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
|
||||
/* If FILE_NAME is a symlink, the debug file might be associated
|
||||
with the symlink target name instead. */
|
||||
|
||||
|
@ -766,7 +766,7 @@
|
|||
debuglink_file, debuglink_crc,
|
||||
--- a/libdwfl/dwfl_build_id_find_elf.c
|
||||
+++ b/libdwfl/dwfl_build_id_find_elf.c
|
||||
@@ -80,7 +80,7 @@ __libdwfl_open_by_build_id (Dwfl_Module
|
||||
@@ -94,7 +94,7 @@ __libdwfl_open_by_build_id (Dwfl_Module
|
||||
{
|
||||
if (*file_name != NULL)
|
||||
free (*file_name);
|
||||
|
@ -777,7 +777,7 @@
|
|||
*file_name = name;
|
||||
--- a/libelf/elf_getarsym.c
|
||||
+++ b/libelf/elf_getarsym.c
|
||||
@@ -284,7 +284,7 @@ elf_getarsym (elf, ptr)
|
||||
@@ -301,7 +301,7 @@ elf_getarsym (elf, ptr)
|
||||
arsym[cnt].as_off = file_data->u32[cnt];
|
||||
|
||||
arsym[cnt].as_hash = _dl_elf_hash (str_data);
|
||||
|
|
|
@ -72,7 +72,7 @@
|
|||
struct parse_opt *opt = state->hook;
|
||||
--- a/libdwfl/Makefile.in
|
||||
+++ b/libdwfl/Makefile.in
|
||||
@@ -113,7 +113,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
|
||||
@@ -114,7 +114,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
|
||||
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
|
||||
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
|
||||
find-debuginfo.c dwfl_build_id_find_elf.c \
|
||||
|
@ -81,7 +81,7 @@
|
|||
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
|
||||
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
|
||||
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
|
||||
@@ -142,7 +142,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
|
||||
@@ -143,7 +143,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
|
||||
dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
|
||||
find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
|
||||
dwfl_build_id_find_debuginfo.$(OBJEXT) \
|
||||
|
@ -90,7 +90,7 @@
|
|||
dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
|
||||
cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
|
||||
dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
|
||||
@@ -402,7 +402,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
|
||||
@@ -413,7 +413,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
|
||||
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
|
||||
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
|
||||
find-debuginfo.c dwfl_build_id_find_elf.c \
|
||||
|
@ -99,7 +99,7 @@
|
|||
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
|
||||
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
|
||||
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
|
||||
@@ -540,7 +540,6 @@ distclean-compile:
|
||||
@@ -551,7 +551,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@
|
||||
|
|
Loading…
Reference in a new issue