elfutils: bump to 0.164
Patches are refreshed except for elfutils-portability, which is gone: https://lists.fedorahosted.org/pipermail/elfutils-devel/2015-October/005290.html Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> SVN-Revision: 47453
This commit is contained in:
parent
f38dbb89c2
commit
77c25c2dd1
8 changed files with 25 additions and 2084 deletions
|
@ -7,12 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=elfutils
|
||||
PKG_VERSION:=0.163
|
||||
PKG_VERSION:=0.164
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=77ce87f259987d2e54e4d87b86cbee41
|
||||
PKG_MD5SUM:=2e4536c1c48034f188a80789a59114d8
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0+
|
||||
PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,6 +1,6 @@
|
|||
--- a/libelf/elf_getarsym.c
|
||||
+++ b/libelf/elf_getarsym.c
|
||||
@@ -169,7 +169,7 @@ elf_getarsym (elf, ptr)
|
||||
@@ -167,7 +167,7 @@ elf_getarsym (Elf *elf, size_t *ptr)
|
||||
|
||||
/* We have an archive. The first word in there is the number of
|
||||
entries in the table. */
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/libelf/libelf.h
|
||||
+++ b/libelf/libelf.h
|
||||
@@ -34,6 +34,11 @@
|
||||
@@ -35,6 +35,11 @@
|
||||
/* Get the ELF types. */
|
||||
#include <elf.h>
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -374,8 +374,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
@@ -372,8 +372,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
# Add doc back when we have some real content.
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- a/libdw/Makefile.in
|
||||
+++ b/libdw/Makefile.in
|
||||
@@ -991,7 +991,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
|
||||
@@ -994,7 +994,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
|
||||
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
|
||||
-Wl,--version-script,$<,--no-undefined \
|
||||
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
- -ldl $(argp_LDADD) $(zip_LIBS)
|
||||
+ -ldl $(argp_LDADD) $(zip_LIBS) $(LIBS)
|
||||
@$(textrel_check)
|
||||
ln -fs $@ $@.$(VERSION)
|
||||
$(AM_V_at)ln -fs $@ $@.$(VERSION)
|
||||
|
||||
|
|
|
@ -311,7 +311,7 @@
|
|||
+#include <err.h>
|
||||
#include <unistd.h>
|
||||
#include <dwarf.h>
|
||||
#include <sys/resource.h>
|
||||
#ifdef __linux__
|
||||
--- a/tests/backtrace-data.c
|
||||
+++ b/tests/backtrace-data.c
|
||||
@@ -27,7 +27,7 @@
|
||||
|
@ -322,7 +322,7 @@
|
|||
+#include <err.h>
|
||||
#include <unistd.h>
|
||||
#include <dwarf.h>
|
||||
#include <sys/resource.h>
|
||||
#if defined(__x86_64__) && defined(__linux__)
|
||||
--- a/tests/buildid.c
|
||||
+++ b/tests/buildid.c
|
||||
@@ -23,7 +23,7 @@
|
||||
|
@ -457,8 +457,8 @@
|
|||
#include <stdio.h>
|
||||
--- a/tests/ecp.c
|
||||
+++ b/tests/ecp.c
|
||||
@@ -16,7 +16,7 @@
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
@@ -20,7 +20,7 @@
|
||||
#endif
|
||||
|
||||
#include <errno.h>
|
||||
-#include <error.h>
|
||||
|
@ -534,8 +534,8 @@
|
|||
#include "sha1.h"
|
||||
--- a/tests/rdwrmmap.c
|
||||
+++ b/tests/rdwrmmap.c
|
||||
@@ -15,7 +15,7 @@
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
@@ -19,7 +19,7 @@
|
||||
#endif
|
||||
|
||||
#include <errno.h>
|
||||
-#include <error.h>
|
||||
|
@ -583,9 +583,9 @@
|
|||
#define _LIBELF_H 1
|
||||
|
||||
+#include <fcntl.h>
|
||||
#include <stdint.h>
|
||||
#include <sys/types.h>
|
||||
|
||||
/* Get the ELF types. */
|
||||
--- a/libasm/asm_end.c
|
||||
+++ b/libasm/asm_end.c
|
||||
@@ -32,7 +32,7 @@
|
||||
|
@ -705,15 +705,15 @@
|
|||
for (subs = nodep->next; subs != NULL; subs = subs->next)
|
||||
--- a/libdwfl/dwfl_error.c
|
||||
+++ b/libdwfl/dwfl_error.c
|
||||
@@ -141,6 +141,7 @@ const char *
|
||||
dwfl_errmsg (error)
|
||||
int error;
|
||||
@@ -140,6 +140,7 @@ __libdwfl_seterrno (Dwfl_Error error)
|
||||
const char *
|
||||
dwfl_errmsg (int error)
|
||||
{
|
||||
+ static __thread char s[64] = "";
|
||||
if (error == 0 || error == -1)
|
||||
{
|
||||
int last_error = global_error;
|
||||
@@ -155,7 +156,8 @@ dwfl_errmsg (error)
|
||||
@@ -154,7 +155,8 @@ dwfl_errmsg (int error)
|
||||
switch (error &~ 0xffff)
|
||||
{
|
||||
case OTHER_ERROR (ERRNO):
|
||||
|
@ -755,7 +755,7 @@
|
|||
typedef struct Dwfl Dwfl;
|
||||
--- a/libdwfl/find-debuginfo.c
|
||||
+++ b/libdwfl/find-debuginfo.c
|
||||
@@ -361,7 +361,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
|
||||
@@ -372,7 +372,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
|
||||
/* If FILE_NAME is a symlink, the debug file might be associated
|
||||
with the symlink target name instead. */
|
||||
|
||||
|
@ -777,8 +777,8 @@
|
|||
*file_name = name;
|
||||
--- a/libelf/elf_getarsym.c
|
||||
+++ b/libelf/elf_getarsym.c
|
||||
@@ -301,7 +301,7 @@ elf_getarsym (elf, ptr)
|
||||
arsym[cnt].as_off = file_data->u32[cnt];
|
||||
@@ -297,7 +297,7 @@ elf_getarsym (Elf *elf, size_t *ptr)
|
||||
arsym[cnt].as_off = (*u32)[cnt];
|
||||
|
||||
arsym[cnt].as_hash = _dl_elf_hash (str_data);
|
||||
- str_data = rawmemchr (str_data, '\0') + 1;
|
||||
|
|
|
@ -72,7 +72,7 @@
|
|||
struct parse_opt *opt = state->hook;
|
||||
--- a/libdwfl/Makefile.in
|
||||
+++ b/libdwfl/Makefile.in
|
||||
@@ -123,7 +123,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
|
||||
@@ -121,7 +121,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
|
||||
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
|
||||
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
|
||||
find-debuginfo.c dwfl_build_id_find_elf.c \
|
||||
|
@ -81,7 +81,7 @@
|
|||
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
|
||||
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
|
||||
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
|
||||
@@ -152,7 +152,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
|
||||
@@ -150,7 +150,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
|
||||
dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
|
||||
find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
|
||||
dwfl_build_id_find_debuginfo.$(OBJEXT) \
|
||||
|
@ -90,7 +90,7 @@
|
|||
dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
|
||||
cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
|
||||
dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
|
||||
@@ -424,7 +424,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
|
||||
@@ -425,7 +425,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
|
||||
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
|
||||
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
|
||||
find-debuginfo.c dwfl_build_id_find_elf.c \
|
||||
|
@ -99,7 +99,7 @@
|
|||
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
|
||||
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
|
||||
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
|
||||
@@ -561,7 +561,6 @@ distclean-compile:
|
||||
@@ -562,7 +562,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@
|
||||
|
|
Loading…
Reference in a new issue