m4: update to 1.4.17
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38168
This commit is contained in:
parent
473b747b1a
commit
76974babaf
2 changed files with 14 additions and 12 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2008-2012 OpenWrt.org
|
# Copyright (C) 2008-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,12 +7,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=m4
|
PKG_NAME:=m4
|
||||||
PKG_VERSION:=1.4.16
|
PKG_VERSION:=1.4.17
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||||
PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
|
PKG_MD5SUM:=12a3c829301a4fd6586a57d3fcf196dc
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=xzcat
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
|
|
|
@ -1,15 +1,17 @@
|
||||||
--- a/lib/stdio.in.h
|
--- a/lib/stdio.in.h
|
||||||
+++ b/lib/stdio.in.h
|
+++ b/lib/stdio.in.h
|
||||||
@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
@@ -714,14 +714,6 @@ _GL_WARN_ON_USE (getline, "getline is un
|
||||||
"use gnulib module fflush for portable POSIX compliance");
|
# endif
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
-/* It is very rare that the developer ever has full control of stdin,
|
-/* It is very rare that the developer ever has full control of stdin,
|
||||||
- so any use of gets warrants an unconditional warning. Assume it is
|
- so any use of gets warrants an unconditional warning; besides, C11
|
||||||
- always declared, since it is required by C89. */
|
- removed it. */
|
||||||
-#undef gets
|
-#undef gets
|
||||||
|
-#if HAVE_RAW_DECL_GETS
|
||||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||||
|
-#endif
|
||||||
-
|
-
|
||||||
#if @GNULIB_FOPEN@
|
|
||||||
# if @REPLACE_FOPEN@
|
#if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
|
||||||
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
struct obstack;
|
||||||
|
|
Loading…
Reference in a new issue