bison: upgrade to version 2.7
SVN-Revision: 35827
This commit is contained in:
parent
829e0bc8b3
commit
71978cf105
4 changed files with 27 additions and 26 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2008-2012 OpenWrt.org
|
||||
# Copyright (C) 2008-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -7,12 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bison
|
||||
PKG_VERSION:=2.5
|
||||
PKG_VERSION:=2.7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
PKG_MD5SUM:=9dba20116b13fc61a0846b0058fbe004
|
||||
PKG_CAT:=bzcat
|
||||
PKG_MD5SUM:=234cdfac99257cf99ac4a03c898f37b9
|
||||
PKG_CAT:=xzcat
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
|
||||
|
|
|
@ -3,18 +3,18 @@
|
|||
@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
|
||||
|
||||
yacc:
|
||||
echo '#! /bin/sh' >$@
|
||||
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
chmod a+x $@
|
||||
$(AM_V_GEN)echo '#! /bin/sh' >$@
|
||||
+ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
$(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
$(AM_V_at)chmod a+x $@
|
||||
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -1609,6 +1609,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
@@ -1919,6 +1919,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
|
||||
yacc:
|
||||
echo '#! /bin/sh' >$@
|
||||
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
chmod a+x $@
|
||||
$(AM_V_GEN)echo '#! /bin/sh' >$@
|
||||
+ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
$(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
$(AM_V_at)chmod a+x $@
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -58,9 +58,9 @@ main (int argc, char *argv[])
|
||||
@@ -60,9 +60,9 @@ main (int argc, char *argv[])
|
||||
{
|
||||
program_name = argv[0];
|
||||
set_program_name (argv[0]);
|
||||
setlocale (LC_ALL, "");
|
||||
- (void) bindtextdomain (PACKAGE, LOCALEDIR);
|
||||
- (void) bindtextdomain ("bison-runtime", LOCALEDIR);
|
||||
|
@ -11,5 +11,5 @@
|
|||
+ bindtextdomain ("bison-runtime", LOCALEDIR);
|
||||
+ textdomain (PACKAGE);
|
||||
|
||||
uniqstrs_new ();
|
||||
muscle_init ();
|
||||
{
|
||||
char const *cp = getenv ("LC_CTYPE");
|
||||
|
|
|
@ -1,15 +1,16 @@
|
|||
--- a/lib/stdio.in.h
|
||||
+++ b/lib/stdio.in.h
|
||||
@@ -177,12 +177,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
||||
"use gnulib module fflush for portable POSIX compliance");
|
||||
@@ -704,13 +704,6 @@ _GL_WARN_ON_USE (getline, "getline is un
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-/* It is very rare that the developer ever has full control of stdin,
|
||||
- so any use of gets warrants an unconditional warning. Assume it is
|
||||
- always declared, since it is required by C89. */
|
||||
- so any use of gets warrants an unconditional warning; besides, C11
|
||||
- removed it. */
|
||||
-#undef gets
|
||||
-#if HAVE_RAW_DECL_GETS
|
||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
-
|
||||
#if @GNULIB_FOPEN@
|
||||
# if @REPLACE_FOPEN@
|
||||
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
||||
-#endif
|
||||
|
||||
|
||||
#if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
|
||||
|
|
Loading…
Reference in a new issue