kernel: update linux 3.18 to final release
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43569
This commit is contained in:
parent
58de4a4759
commit
712f6ec52a
5 changed files with 25 additions and 39 deletions
|
@ -7,14 +7,14 @@ LINUX_VERSION-3.8 = .13
|
||||||
LINUX_VERSION-3.10 = .58
|
LINUX_VERSION-3.10 = .58
|
||||||
LINUX_VERSION-3.13 = .7
|
LINUX_VERSION-3.13 = .7
|
||||||
LINUX_VERSION-3.14 = .26
|
LINUX_VERSION-3.14 = .26
|
||||||
LINUX_VERSION-3.18 = -rc7
|
LINUX_VERSION-3.18 =
|
||||||
|
|
||||||
LINUX_KERNEL_MD5SUM-3.3.8 = f1058f64eed085deb44f10cee8541d50
|
LINUX_KERNEL_MD5SUM-3.3.8 = f1058f64eed085deb44f10cee8541d50
|
||||||
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
|
LINUX_KERNEL_MD5SUM-3.8.13 = 2af19d06cd47ec459519159cdd10542d
|
||||||
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
|
LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
|
||||||
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
|
LINUX_KERNEL_MD5SUM-3.13.7 = 370adced5e5c1cb1d0d621c2dae2723f
|
||||||
LINUX_KERNEL_MD5SUM-3.14.26 = 9a91a9c507c9efb68c7075e151c30fa7
|
LINUX_KERNEL_MD5SUM-3.14.26 = 9a91a9c507c9efb68c7075e151c30fa7
|
||||||
LINUX_KERNEL_MD5SUM-3.18-rc7 = 36ac6232dfb74aebdfa30d7cbf154485
|
LINUX_KERNEL_MD5SUM-3.18 = 9e854df51ca3fef8bfe566dbd7b89241
|
||||||
|
|
||||||
ifdef KERNEL_PATCHVER
|
ifdef KERNEL_PATCHVER
|
||||||
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
|
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/arch/x86/boot/compressed/Makefile
|
|
||||||
+++ b/arch/x86/boot/compressed/Makefile
|
|
||||||
@@ -76,7 +76,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
|
|
||||||
suffix-$(CONFIG_KERNEL_LZO) := lzo
|
|
||||||
suffix-$(CONFIG_KERNEL_LZ4) := lz4
|
|
||||||
|
|
||||||
-RUN_SIZE = $(shell objdump -h vmlinux | \
|
|
||||||
+RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
|
|
||||||
perl $(srctree)/arch/x86/tools/calc_run_size.pl)
|
|
||||||
quiet_cmd_mkpiggy = MKPIGGY $@
|
|
||||||
cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
|
|
|
@ -219,26 +219,26 @@
|
||||||
{
|
{
|
||||||
UInt32 dicSize;
|
UInt32 dicSize;
|
||||||
Byte d;
|
Byte d;
|
||||||
@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
||||||
return SZ_OK;
|
return SZ_OK;
|
||||||
}
|
}
|
||||||
|
|
||||||
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
|
-{
|
||||||
|
- CLzmaProps propNew;
|
||||||
|
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||||
|
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||||
|
- p->prop = propNew;
|
||||||
|
- return SZ_OK;
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
{
|
{
|
||||||
CLzmaProps propNew;
|
CLzmaProps propNew;
|
||||||
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
|
||||||
@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
|
|
||||||
p->prop = propNew;
|
|
||||||
return SZ_OK;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
|
||||||
-{
|
|
||||||
- CLzmaProps propNew;
|
|
||||||
- SizeT dicBufSize;
|
- SizeT dicBufSize;
|
||||||
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||||
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||||
- dicBufSize = propNew.dicSize;
|
- dicBufSize = propNew.dicSize;
|
||||||
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
|
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
|
||||||
- {
|
- {
|
||||||
|
@ -251,12 +251,9 @@
|
||||||
- }
|
- }
|
||||||
- }
|
- }
|
||||||
- p->dicBufSize = dicBufSize;
|
- p->dicBufSize = dicBufSize;
|
||||||
- p->prop = propNew;
|
p->prop = propNew;
|
||||||
- return SZ_OK;
|
return SZ_OK;
|
||||||
-}
|
}
|
||||||
|
|
||||||
SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
|
|
||||||
const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
|
|
||||||
--- a/include/linux/lzma/LzmaEnc.h
|
--- a/include/linux/lzma/LzmaEnc.h
|
||||||
+++ b/include/linux/lzma/LzmaEnc.h
|
+++ b/include/linux/lzma/LzmaEnc.h
|
||||||
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
|
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
|
||||||
|
|
|
@ -76,11 +76,10 @@
|
||||||
|
|
||||||
counters = alloc_counters(table);
|
counters = alloc_counters(table);
|
||||||
if (IS_ERR(counters))
|
if (IS_ERR(counters))
|
||||||
@@ -965,6 +994,14 @@ copy_entries_to_user(unsigned int total_
|
@@ -966,6 +995,14 @@ copy_entries_to_user(unsigned int total_
|
||||||
ret = -EFAULT;
|
|
||||||
goto free_counters;
|
goto free_counters;
|
||||||
}
|
}
|
||||||
+
|
|
||||||
+ flags = e->ip.flags & IPT_F_MASK;
|
+ flags = e->ip.flags & IPT_F_MASK;
|
||||||
+ if (copy_to_user(userptr + off
|
+ if (copy_to_user(userptr + off
|
||||||
+ + offsetof(struct ipt_entry, ip.flags),
|
+ + offsetof(struct ipt_entry, ip.flags),
|
||||||
|
@ -88,6 +87,7 @@
|
||||||
+ ret = -EFAULT;
|
+ ret = -EFAULT;
|
||||||
+ goto free_counters;
|
+ goto free_counters;
|
||||||
+ }
|
+ }
|
||||||
|
+
|
||||||
for (i = sizeof(struct ipt_entry);
|
for (i = sizeof(struct ipt_entry);
|
||||||
i < e->target_offset;
|
i < e->target_offset;
|
||||||
|
i += m->u.match_size) {
|
||||||
|
|
Loading…
Reference in a new issue