Revert "kernel: remove all local symbols from kernel modules at link time to reduce their size" Use -x when stripping kernel modules instead
SVN-Revision: 26305
This commit is contained in:
parent
596d89b331
commit
6c7170b923
5 changed files with 3 additions and 25 deletions
2
rules.mk
2
rules.mk
|
@ -211,7 +211,7 @@ else
|
||||||
RSTRIP:= \
|
RSTRIP:= \
|
||||||
NM="$(TARGET_CROSS)nm" \
|
NM="$(TARGET_CROSS)nm" \
|
||||||
STRIP="$(STRIP)" \
|
STRIP="$(STRIP)" \
|
||||||
STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo" \
|
STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo -x" \
|
||||||
$(SCRIPT_DIR)/rstrip.sh
|
$(SCRIPT_DIR)/rstrip.sh
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -360,7 +360,7 @@
|
|
||||||
KBUILD_AFLAGS := -D__ASSEMBLY__
|
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
|
||||||
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
|
||||||
+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
|
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
||||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
|
|
@ -3,7 +3,7 @@
|
||||||
@@ -361,6 +361,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
@@ -361,6 +361,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
|
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||||
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -361,7 +361,7 @@
|
|
||||||
KBUILD_AFLAGS := -D__ASSEMBLY__
|
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
|
||||||
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
|
||||||
+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
|
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
||||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
|
|
@ -3,7 +3,7 @@
|
||||||
@@ -362,6 +362,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
@@ -362,6 +362,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||||
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
|
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||||
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
+KBUILD_LDFLAGS_MODULE_PREREQ :=
|
||||||
|
|
||||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||||
|
|
Loading…
Reference in a new issue