upgrade to 2.6.30-rc8
SVN-Revision: 16307
This commit is contained in:
parent
3d3d75a248
commit
6b2a7b73ca
24 changed files with 69 additions and 435 deletions
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1,229 +0,0 @@
|
|||
--- a/arch/avr32/boards/atngw100/setup.c
|
||||
+++ b/arch/avr32/boards/atngw100/setup.c
|
||||
@@ -118,7 +118,7 @@ static void __init set_hw_addr(struct pl
|
||||
|
||||
void __init setup_board(void)
|
||||
{
|
||||
- at32_map_usart(1, 0, 0); /* USART 1: /dev/ttyS0, DB9 */
|
||||
+ at32_map_usart(1, 0); /* USART 1: /dev/ttyS0, DB9 */
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
|
||||
--- a/arch/avr32/boards/atstk1000/atstk1002.c
|
||||
+++ b/arch/avr32/boards/atstk1000/atstk1002.c
|
||||
@@ -252,12 +252,12 @@ static void __init atstk1002_setup_extda
|
||||
void __init setup_board(void)
|
||||
{
|
||||
#ifdef CONFIG_BOARD_ATSTK100X_SW2_CUSTOM
|
||||
- at32_map_usart(0, 1, 0); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
+ at32_map_usart(0, 1); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
#else
|
||||
- at32_map_usart(1, 0, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
+ at32_map_usart(1, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
#endif
|
||||
/* USART 2/unused: expansion connector */
|
||||
- at32_map_usart(3, 2, 0); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
+ at32_map_usart(3, 2); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
--- a/arch/avr32/boards/atstk1000/atstk1003.c
|
||||
+++ b/arch/avr32/boards/atstk1000/atstk1003.c
|
||||
@@ -115,12 +115,12 @@ static void __init atstk1003_setup_extda
|
||||
void __init setup_board(void)
|
||||
{
|
||||
#ifdef CONFIG_BOARD_ATSTK100X_SW2_CUSTOM
|
||||
- at32_map_usart(0, 1, 0); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
+ at32_map_usart(0, 1); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
#else
|
||||
- at32_map_usart(1, 0, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
+ at32_map_usart(1, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
#endif
|
||||
/* USART 2/unused: expansion connector */
|
||||
- at32_map_usart(3, 2, 0); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
+ at32_map_usart(3, 2); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
--- a/arch/avr32/boards/atstk1000/atstk1004.c
|
||||
+++ b/arch/avr32/boards/atstk1000/atstk1004.c
|
||||
@@ -120,12 +120,12 @@ static void __init atstk1004_setup_extda
|
||||
void __init setup_board(void)
|
||||
{
|
||||
#ifdef CONFIG_BOARD_ATSTK100X_SW2_CUSTOM
|
||||
- at32_map_usart(0, 1, 0); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
+ at32_map_usart(0, 1); /* USART 0/B: /dev/ttyS1, IRDA */
|
||||
#else
|
||||
- at32_map_usart(1, 0, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
+ at32_map_usart(1, 0); /* USART 1/A: /dev/ttyS0, DB9 */
|
||||
#endif
|
||||
/* USART 2/unused: expansion connector */
|
||||
- at32_map_usart(3, 2, 0); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
+ at32_map_usart(3, 2); /* USART 3/C: /dev/ttyS2, DB9 */
|
||||
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
--- a/arch/avr32/boards/favr-32/setup.c
|
||||
+++ b/arch/avr32/boards/favr-32/setup.c
|
||||
@@ -250,7 +250,7 @@ static void __init favr32_setup_atmel_pw
|
||||
|
||||
void __init setup_board(void)
|
||||
{
|
||||
- at32_map_usart(3, 0, 0); /* USART 3 => /dev/ttyS0 */
|
||||
+ at32_map_usart(3, 0); /* USART 3 => /dev/ttyS0 */
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
|
||||
--- a/arch/avr32/boards/hammerhead/setup.c
|
||||
+++ b/arch/avr32/boards/hammerhead/setup.c
|
||||
@@ -165,7 +165,7 @@ static void __init set_hw_addr(struct pl
|
||||
|
||||
void __init setup_board(void)
|
||||
{
|
||||
- at32_map_usart(1, 0, 0); /* USART 1: /dev/ttyS0, DB9 */
|
||||
+ at32_map_usart(1, 0); /* USART 1: /dev/ttyS0, DB9 */
|
||||
at32_setup_serial_console(0);
|
||||
}
|
||||
|
||||
--- a/arch/avr32/boards/merisc/setup.c
|
||||
+++ b/arch/avr32/boards/merisc/setup.c
|
||||
@@ -231,9 +231,9 @@ static void detect_merisc_board_id(void)
|
||||
|
||||
void __init setup_board(void)
|
||||
{
|
||||
- at32_map_usart(0, 0, 0);
|
||||
- at32_map_usart(1, 1, 0);
|
||||
- at32_map_usart(3, 3, 0);
|
||||
+ at32_map_usart(0, 0);
|
||||
+ at32_map_usart(1, 1);
|
||||
+ at32_map_usart(3, 3);
|
||||
at32_setup_serial_console(1);
|
||||
}
|
||||
|
||||
@@ -248,7 +248,7 @@ static int __init merisc_init(void)
|
||||
at32_reserve_pin(GPIO_PIOE_BASE, ATMEL_EBI_PE_DATA_ALL | (1 << 26));
|
||||
|
||||
if (merisc_board_id >= 1)
|
||||
- at32_map_usart(2, 2, 0);
|
||||
+ at32_map_usart(2, 2);
|
||||
|
||||
at32_add_device_usart(0);
|
||||
at32_add_device_usart(1);
|
||||
--- a/arch/avr32/boards/mimc200/setup.c
|
||||
+++ b/arch/avr32/boards/mimc200/setup.c
|
||||
@@ -175,10 +175,10 @@ static void __init set_hw_addr(struct pl
|
||||
|
||||
void __init setup_board(void)
|
||||
{
|
||||
- at32_map_usart(0, 0, 0); /* USART 0: /dev/ttyS0 (TTL --> Altera) */
|
||||
- at32_map_usart(1, 1, 0); /* USART 1: /dev/ttyS1 (RS232) */
|
||||
- at32_map_usart(2, 2, 0); /* USART 2: /dev/ttyS2 (RS485) */
|
||||
- at32_map_usart(3, 3, 0); /* USART 3: /dev/ttyS3 (RS422 Multidrop) */
|
||||
+ at32_map_usart(0, 0); /* USART 0: /dev/ttyS0 (TTL --> Altera) */
|
||||
+ at32_map_usart(1, 1); /* USART 1: /dev/ttyS1 (RS232) */
|
||||
+ at32_map_usart(2, 2); /* USART 2: /dev/ttyS2 (RS485) */
|
||||
+ at32_map_usart(3, 3); /* USART 3: /dev/ttyS3 (RS422 Multidrop) */
|
||||
}
|
||||
|
||||
static struct i2c_gpio_platform_data i2c_gpio_data = {
|
||||
--- a/arch/avr32/mach-at32ap/at32ap700x.c
|
||||
+++ b/arch/avr32/mach-at32ap/at32ap700x.c
|
||||
@@ -966,68 +966,56 @@ static struct resource atmel_usart3_reso
|
||||
DEFINE_DEV_DATA(atmel_usart, 3);
|
||||
DEV_CLK(usart, atmel_usart3, pba, 6);
|
||||
|
||||
-static inline void configure_usart0_pins(int flags)
|
||||
+static inline void configure_usart0_pins(void)
|
||||
{
|
||||
u32 pin_mask = (1 << 8) | (1 << 9); /* RXD & TXD */
|
||||
- if (flags & ATMEL_USART_RTS) pin_mask |= (1 << 6);
|
||||
- if (flags & ATMEL_USART_CTS) pin_mask |= (1 << 7);
|
||||
- if (flags & ATMEL_USART_CLK) pin_mask |= (1 << 10);
|
||||
|
||||
select_peripheral(PIOA, pin_mask, PERIPH_B, AT32_GPIOF_PULLUP);
|
||||
}
|
||||
|
||||
-static inline void configure_usart1_pins(int flags)
|
||||
+static inline void configure_usart1_pins(void)
|
||||
{
|
||||
u32 pin_mask = (1 << 17) | (1 << 18); /* RXD & TXD */
|
||||
- if (flags & ATMEL_USART_RTS) pin_mask |= (1 << 19);
|
||||
- if (flags & ATMEL_USART_CTS) pin_mask |= (1 << 20);
|
||||
- if (flags & ATMEL_USART_CLK) pin_mask |= (1 << 16);
|
||||
|
||||
select_peripheral(PIOA, pin_mask, PERIPH_A, AT32_GPIOF_PULLUP);
|
||||
}
|
||||
|
||||
-static inline void configure_usart2_pins(int flags)
|
||||
+static inline void configure_usart2_pins(void)
|
||||
{
|
||||
u32 pin_mask = (1 << 26) | (1 << 27); /* RXD & TXD */
|
||||
- if (flags & ATMEL_USART_RTS) pin_mask |= (1 << 30);
|
||||
- if (flags & ATMEL_USART_CTS) pin_mask |= (1 << 29);
|
||||
- if (flags & ATMEL_USART_CLK) pin_mask |= (1 << 28);
|
||||
|
||||
select_peripheral(PIOB, pin_mask, PERIPH_B, AT32_GPIOF_PULLUP);
|
||||
}
|
||||
|
||||
-static inline void configure_usart3_pins(int flags)
|
||||
+static inline void configure_usart3_pins(void)
|
||||
{
|
||||
u32 pin_mask = (1 << 18) | (1 << 17); /* RXD & TXD */
|
||||
- if (flags & ATMEL_USART_RTS) pin_mask |= (1 << 16);
|
||||
- if (flags & ATMEL_USART_CTS) pin_mask |= (1 << 15);
|
||||
- if (flags & ATMEL_USART_CLK) pin_mask |= (1 << 19);
|
||||
|
||||
select_peripheral(PIOB, pin_mask, PERIPH_B, AT32_GPIOF_PULLUP);
|
||||
}
|
||||
|
||||
static struct platform_device *__initdata at32_usarts[4];
|
||||
|
||||
-void __init at32_map_usart(unsigned int hw_id, unsigned int line, int flags)
|
||||
+void __init at32_map_usart(unsigned int hw_id, unsigned int line)
|
||||
{
|
||||
struct platform_device *pdev;
|
||||
|
||||
switch (hw_id) {
|
||||
case 0:
|
||||
pdev = &atmel_usart0_device;
|
||||
- configure_usart0_pins(flags);
|
||||
+ configure_usart0_pins();
|
||||
break;
|
||||
case 1:
|
||||
pdev = &atmel_usart1_device;
|
||||
- configure_usart1_pins(flags);
|
||||
+ configure_usart1_pins();
|
||||
break;
|
||||
case 2:
|
||||
pdev = &atmel_usart2_device;
|
||||
- configure_usart2_pins(flags);
|
||||
+ configure_usart2_pins();
|
||||
break;
|
||||
case 3:
|
||||
pdev = &atmel_usart3_device;
|
||||
- configure_usart3_pins(flags);
|
||||
+ configure_usart3_pins();
|
||||
break;
|
||||
default:
|
||||
return;
|
||||
--- a/arch/avr32/mach-at32ap/include/mach/board.h
|
||||
+++ b/arch/avr32/mach-at32ap/include/mach/board.h
|
||||
@@ -26,17 +26,12 @@ static inline void __deprecated at32_add
|
||||
#define ATMEL_MAX_UART 4
|
||||
extern struct platform_device *atmel_default_console_device;
|
||||
|
||||
-/* Flags for selecting USART extra pins */
|
||||
-#define ATMEL_USART_RTS 0x01
|
||||
-#define ATMEL_USART_CTS 0x02
|
||||
-#define ATMEL_USART_CLK 0x03
|
||||
-
|
||||
struct atmel_uart_data {
|
||||
short use_dma_tx; /* use transmit DMA? */
|
||||
short use_dma_rx; /* use receive DMA? */
|
||||
void __iomem *regs; /* virtual base address, if any */
|
||||
};
|
||||
-void at32_map_usart(unsigned int hw_id, unsigned int line, int flags);
|
||||
+void at32_map_usart(unsigned int hw_id, unsigned int line);
|
||||
struct platform_device *at32_add_device_usart(unsigned int id);
|
||||
|
||||
struct eth_platform_data {
|
22
target/linux/avr32/patches/001-fix_usart_clash.patch
Normal file
22
target/linux/avr32/patches/001-fix_usart_clash.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
Fix clash in ATMEL_USART_ flags
|
||||
|
||||
At the moment ATMEL_USART_{RTS,CTS,CLK} have the values
|
||||
1, 2 and 3 respectively. Given these are used in bitmasks,
|
||||
trying to turn on the CLK line will in fact turn on the
|
||||
RTS and CTS lines as well.
|
||||
|
||||
Change the value of ATMEL_USART_CLK to 4.
|
||||
|
||||
Signed-off-by: Ben Nizette <bn@niasdigital.com>
|
||||
---
|
||||
--- a/arch/avr32/mach-at32ap/include/mach/board.h
|
||||
+++ b/arch/avr32/mach-at32ap/include/mach/board.h
|
||||
@@ -29,7 +29,7 @@ extern struct platform_device *atmel_def
|
||||
/* Flags for selecting USART extra pins */
|
||||
#define ATMEL_USART_RTS 0x01
|
||||
#define ATMEL_USART_CTS 0x02
|
||||
-#define ATMEL_USART_CLK 0x03
|
||||
+#define ATMEL_USART_CLK 0x04
|
||||
|
||||
struct atmel_uart_data {
|
||||
short use_dma_tx; /* use transmit DMA? */
|
|
@ -11,7 +11,7 @@ BOARD:=cobalt
|
|||
BOARDNAME:=Cobalt Microservers
|
||||
FEATURES:=tgz pci
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=cris
|
|||
BOARD:=etrax
|
||||
BOARDNAME:=Foxboard (ETRAX 100LX)
|
||||
FEATURES:=squashfs jffs2
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -189,8 +189,8 @@
|
|||
.globl __kuser_helper_start
|
||||
__kuser_helper_start:
|
||||
|
||||
@@ -821,7 +822,7 @@ __kuser_memory_barrier: @ 0xffff0fa0
|
||||
#endif
|
||||
@@ -818,7 +819,7 @@ __kuser_memory_barrier: @ 0xffff0fa0
|
||||
smp_dmb
|
||||
usr_ret lr
|
||||
|
||||
- .align 5
|
||||
|
@ -198,7 +198,7 @@
|
|||
|
||||
/*
|
||||
* Reference prototype:
|
||||
@@ -953,7 +954,7 @@ kuser_cmpxchg_fixup:
|
||||
@@ -950,7 +951,7 @@ kuser_cmpxchg_fixup:
|
||||
|
||||
#endif
|
||||
|
||||
|
@ -207,7 +207,7 @@
|
|||
|
||||
/*
|
||||
* Reference prototype:
|
||||
@@ -1035,7 +1036,7 @@ __kuser_helper_end:
|
||||
@@ -1032,7 +1033,7 @@ __kuser_helper_end:
|
||||
* of which is copied into r0 for the mode specific abort handler.
|
||||
*/
|
||||
.macro vector_stub, name, mode, correction=0
|
||||
|
@ -216,7 +216,7 @@
|
|||
|
||||
vector_\name:
|
||||
.if \correction
|
||||
@@ -1160,7 +1161,7 @@ __stubs_start:
|
||||
@@ -1157,7 +1158,7 @@ __stubs_start:
|
||||
.long __und_invalid @ e
|
||||
.long __und_invalid @ f
|
||||
|
||||
|
@ -225,7 +225,7 @@
|
|||
|
||||
/*=============================================================================
|
||||
* Undefined FIQs
|
||||
@@ -1190,7 +1191,7 @@ vector_addrexcptn:
|
||||
@@ -1187,7 +1188,7 @@ vector_addrexcptn:
|
||||
* We group all the following data together to optimise
|
||||
* for CPUs with separate I & D caches.
|
||||
*/
|
||||
|
@ -850,7 +850,7 @@
|
|||
+#endif /* __MACH_GMAC_H__ */
|
||||
--- a/arch/arm/mach-gemini/include/mach/hardware.h
|
||||
+++ b/arch/arm/mach-gemini/include/mach/hardware.h
|
||||
@@ -72,4 +72,12 @@
|
||||
@@ -71,4 +71,12 @@
|
||||
*/
|
||||
#define IO_ADDRESS(x) ((((x) & 0xFFF00000) >> 4) | ((x) & 0x000FFFFF) | 0xF0000000)
|
||||
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
--- a/drivers/net/r8169.c
|
||||
+++ b/drivers/net/r8169.c
|
||||
@@ -1890,7 +1890,7 @@ static const struct rtl_cfg_info {
|
||||
.hw_start = rtl_hw_start_8169,
|
||||
.region = 1,
|
||||
.align = 0,
|
||||
- .intr_event = SYSErr | LinkChg | RxOverflow |
|
||||
+ .intr_event = LinkChg | RxOverflow |
|
||||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||
.features = RTL_FEATURE_GMII
|
||||
@@ -1899,7 +1899,7 @@ static const struct rtl_cfg_info {
|
||||
.hw_start = rtl_hw_start_8168,
|
||||
.region = 2,
|
||||
.align = 8,
|
||||
- .intr_event = SYSErr | LinkChg | RxOverflow |
|
||||
+ .intr_event = LinkChg | RxOverflow |
|
||||
TxErr | TxOK | RxOK | RxErr,
|
||||
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
|
||||
.features = RTL_FEATURE_GMII | RTL_FEATURE_MSI
|
||||
@@ -1908,7 +1908,7 @@ static const struct rtl_cfg_info {
|
||||
.hw_start = rtl_hw_start_8101,
|
||||
.region = 2,
|
||||
.align = 8,
|
||||
- .intr_event = SYSErr | LinkChg | RxOverflow | PCSTimeout |
|
||||
+ .intr_event = LinkChg | RxOverflow | PCSTimeout |
|
||||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||
.features = RTL_FEATURE_MSI
|
||||
@@ -3582,10 +3582,12 @@ static irqreturn_t rtl8169_interrupt(int
|
||||
goto out;
|
||||
}
|
||||
|
||||
+#if 0
|
||||
if (unlikely(status & SYSErr)) {
|
||||
rtl8169_pcierr_interrupt(dev);
|
||||
goto out;
|
||||
}
|
||||
+#endif
|
||||
|
||||
if (status & LinkChg)
|
||||
rtl8169_check_link_status(dev, tp, ioaddr);
|
|
@ -1,8 +1,8 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -96,6 +96,10 @@ config ADM6996_PHY
|
||||
config MVSWITCH_PHY
|
||||
tristate "Driver for Marvell 88E6060 switches"
|
||||
@@ -100,6 +100,10 @@ config IP175C_PHY
|
||||
tristate "Driver for IC+ IP175C/IP178C switches"
|
||||
select SWCONFIG
|
||||
|
||||
+config AR8216_PHY
|
||||
+ tristate "Driver for Atheros AR8216 switches"
|
||||
|
@ -13,9 +13,9 @@
|
|||
depends on PHYLIB=y
|
||||
--- a/drivers/net/phy/Makefile
|
||||
+++ b/drivers/net/phy/Makefile
|
||||
@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
||||
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
||||
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
||||
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
||||
obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
||||
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
||||
|
|
|
@ -17,7 +17,7 @@
|
|||
port->bulk_in_size = buffer_size;
|
||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||
@@ -1311,3 +1312,5 @@ MODULE_LICENSE("GPL");
|
||||
@@ -1312,3 +1313,5 @@ MODULE_LICENSE("GPL");
|
||||
|
||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -812,7 +812,7 @@ static noinline int init_post(void)
|
||||
@@ -811,7 +811,7 @@ static noinline int init_post(void)
|
||||
numa_default_policy();
|
||||
|
||||
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
|
||||
|
|
|
@ -824,7 +824,7 @@
|
|||
+be done automatically.
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -2495,6 +2495,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
@@ -2504,6 +2504,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
S: Maintained
|
||||
F: drivers/media/video/gspca/
|
||||
|
||||
|
|
|
@ -1,112 +0,0 @@
|
|||
From: Nicolas Pitre <nico@cam.org>
|
||||
Date: Fri, 22 May 2009 20:53:40 +0000 (-0400)
|
||||
Subject: [ARM] add coherent DMA mask for mv643xx_eth
|
||||
X-Git-Url: http://git.marvell.com/?p=orion.git;a=commitdiff_plain;h=a49a018a6ea6d73742a81d673fe5ec4a7d2137b3
|
||||
|
||||
[ARM] add coherent DMA mask for mv643xx_eth
|
||||
|
||||
Since commit eb0519b5a1cf, mv643xx_eth is non functional on ARM because
|
||||
the platform device declaration does not include any coherent DMA mask
|
||||
and coherent memory allocations fail.
|
||||
|
||||
Signed-off-by: Nicolas Pitre <nico@marvell.com>
|
||||
---
|
||||
|
||||
--- a/arch/arm/mach-kirkwood/common.c
|
||||
+++ b/arch/arm/mach-kirkwood/common.c
|
||||
@@ -144,6 +144,9 @@ static struct platform_device kirkwood_g
|
||||
.id = 0,
|
||||
.num_resources = 1,
|
||||
.resource = kirkwood_ge00_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init kirkwood_ge00_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
@@ -202,6 +205,9 @@ static struct platform_device kirkwood_g
|
||||
.id = 1,
|
||||
.num_resources = 1,
|
||||
.resource = kirkwood_ge01_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init kirkwood_ge01_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
--- a/arch/arm/mach-loki/common.c
|
||||
+++ b/arch/arm/mach-loki/common.c
|
||||
@@ -82,6 +82,9 @@ static struct platform_device loki_ge0 =
|
||||
.id = 0,
|
||||
.num_resources = 1,
|
||||
.resource = loki_ge0_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init loki_ge0_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
@@ -136,6 +139,9 @@ static struct platform_device loki_ge1 =
|
||||
.id = 1,
|
||||
.num_resources = 1,
|
||||
.resource = loki_ge1_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init loki_ge1_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
--- a/arch/arm/mach-mv78xx0/common.c
|
||||
+++ b/arch/arm/mach-mv78xx0/common.c
|
||||
@@ -321,6 +321,9 @@ static struct platform_device mv78xx0_ge
|
||||
.id = 0,
|
||||
.num_resources = 1,
|
||||
.resource = mv78xx0_ge00_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init mv78xx0_ge00_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
@@ -375,6 +378,9 @@ static struct platform_device mv78xx0_ge
|
||||
.id = 1,
|
||||
.num_resources = 1,
|
||||
.resource = mv78xx0_ge01_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init mv78xx0_ge01_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
@@ -429,6 +435,9 @@ static struct platform_device mv78xx0_ge
|
||||
.id = 2,
|
||||
.num_resources = 1,
|
||||
.resource = mv78xx0_ge10_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init mv78xx0_ge10_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
@@ -496,6 +505,9 @@ static struct platform_device mv78xx0_ge
|
||||
.id = 3,
|
||||
.num_resources = 1,
|
||||
.resource = mv78xx0_ge11_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init mv78xx0_ge11_init(struct mv643xx_eth_platform_data *eth_data)
|
||||
--- a/arch/arm/mach-orion5x/common.c
|
||||
+++ b/arch/arm/mach-orion5x/common.c
|
||||
@@ -188,6 +188,9 @@ static struct platform_device orion5x_et
|
||||
.id = 0,
|
||||
.num_resources = 1,
|
||||
.resource = orion5x_eth_resources,
|
||||
+ .dev = {
|
||||
+ .coherent_dma_mask = 0xffffffff,
|
||||
+ },
|
||||
};
|
||||
|
||||
void __init orion5x_eth_init(struct mv643xx_eth_platform_data *eth_data)
|
|
@ -1,6 +1,6 @@
|
|||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -836,10 +836,7 @@ static noinline int init_post(void)
|
||||
@@ -835,10 +835,7 @@ static noinline int init_post(void)
|
||||
printk(KERN_WARNING "Failed to execute %s. Attempting "
|
||||
"defaults...\n", execute_command);
|
||||
}
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=kirkwood
|
|||
BOARDNAME:=Marvell Kirkwood
|
||||
FEATURES:=tgz usb
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -16,7 +16,7 @@ Signed-off-by: Rabeeh Khoury <rabeeh@marvell.com>
|
|||
|
||||
--- a/arch/arm/mach-kirkwood/common.c
|
||||
+++ b/arch/arm/mach-kirkwood/common.c
|
||||
@@ -788,6 +788,38 @@ static void __init kirkwood_l2_init(void
|
||||
@@ -786,6 +786,38 @@ static void __init kirkwood_l2_init(void
|
||||
#endif
|
||||
}
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
|
|||
FEATURES:=squashfs jffs2 pci
|
||||
CFLAGS:=-Os -pipe -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,8 +12,8 @@ Signed-off-by: David Daney <ddaney@caviumnetworks.com>
|
|||
|
||||
--- a/arch/mips/include/asm/compiler.h
|
||||
+++ b/arch/mips/include/asm/compiler.h
|
||||
@@ -16,4 +16,11 @@
|
||||
#define GCC_REG_ACCUM "accum"
|
||||
@@ -26,4 +26,11 @@ typedef u64 uintx_t;
|
||||
#endif
|
||||
#endif
|
||||
|
||||
+#if __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 4)
|
||||
|
@ -26,7 +26,7 @@ Signed-off-by: David Daney <ddaney@caviumnetworks.com>
|
|||
#endif /* _ASM_COMPILER_H */
|
||||
--- a/arch/mips/include/asm/delay.h
|
||||
+++ b/arch/mips/include/asm/delay.h
|
||||
@@ -83,10 +83,14 @@ static inline void __udelay(unsigned lon
|
||||
@@ -67,10 +67,14 @@ static inline unsigned long __usecs_to_l
|
||||
: "r" (usecs), "r" (lpj)
|
||||
: GCC_REG_ACCUM);
|
||||
else if (sizeof(long) == 8 && !R4000_WAR)
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci tgz
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Samsung S3C24xx
|
|||
FEATURES:=jffs2
|
||||
CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -ruN linux-2.6.29.orig/drivers/video/console/fbcon.c linux-2.6.29/drivers/video/console/fbcon.c
|
||||
--- linux-2.6.29.orig/drivers/video/console/fbcon.c 2009-05-14 22:21:12.000000000 +0200
|
||||
+++ linux-2.6.29/drivers/video/console/fbcon.c 2009-05-15 01:45:36.000000000 +0200
|
||||
@@ -562,7 +562,7 @@
|
||||
--- a/drivers/video/console/fbcon.c
|
||||
+++ b/drivers/video/console/fbcon.c
|
||||
@@ -562,7 +562,7 @@ static void fbcon_prepare_logo(struct vc
|
||||
/* Need to make room for the logo */
|
||||
struct fbcon_ops *ops = info->fbcon_par;
|
||||
int cnt, erase = vc->vc_video_erase_char, step;
|
||||
|
@ -10,7 +9,7 @@ diff -ruN linux-2.6.29.orig/drivers/video/console/fbcon.c linux-2.6.29/drivers/v
|
|||
int logo_height;
|
||||
|
||||
if (info->flags & FBINFO_MODULE) {
|
||||
@@ -581,37 +581,18 @@
|
||||
@@ -581,37 +581,18 @@ static void fbcon_prepare_logo(struct vc
|
||||
q = (unsigned short *) (vc->vc_origin +
|
||||
vc->vc_size_row * rows);
|
||||
step = logo_lines * cols;
|
||||
|
@ -60,7 +59,7 @@ diff -ruN linux-2.6.29.orig/drivers/video/console/fbcon.c linux-2.6.29/drivers/v
|
|||
scr_memsetw((unsigned short *) vc->vc_origin,
|
||||
erase,
|
||||
vc->vc_size_row * logo_lines);
|
||||
@@ -621,16 +602,6 @@
|
||||
@@ -621,16 +602,6 @@ static void fbcon_prepare_logo(struct vc
|
||||
update_screen(vc);
|
||||
}
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -ruN linux-2.6.29.orig/drivers/video/logo/Kconfig linux-2.6.29/drivers/video/logo/Kconfig
|
||||
--- linux-2.6.29.orig/drivers/video/logo/Kconfig 2009-05-14 22:21:12.000000000 +0200
|
||||
+++ linux-2.6.29/drivers/video/logo/Kconfig 2009-05-14 22:28:50.000000000 +0200
|
||||
@@ -82,4 +82,8 @@
|
||||
--- a/drivers/video/logo/Kconfig
|
||||
+++ b/drivers/video/logo/Kconfig
|
||||
@@ -82,4 +82,8 @@ config LOGO_M32R_CLUT224
|
||||
depends on M32R
|
||||
default y
|
||||
|
||||
|
@ -10,10 +9,9 @@ diff -ruN linux-2.6.29.orig/drivers/video/logo/Kconfig linux-2.6.29/drivers/vide
|
|||
+ default y
|
||||
+
|
||||
endif # LOGO
|
||||
diff -ruN linux-2.6.29.orig/drivers/video/logo/logo.c linux-2.6.29/drivers/video/logo/logo.c
|
||||
--- linux-2.6.29.orig/drivers/video/logo/logo.c 2009-05-14 22:21:12.000000000 +0200
|
||||
+++ linux-2.6.29/drivers/video/logo/logo.c 2009-05-14 22:37:05.000000000 +0200
|
||||
@@ -35,6 +35,7 @@
|
||||
--- a/drivers/video/logo/logo.c
|
||||
+++ b/drivers/video/logo/logo.c
|
||||
@@ -35,6 +35,7 @@ extern const struct linux_logo logo_supe
|
||||
extern const struct linux_logo logo_superh_vga16;
|
||||
extern const struct linux_logo logo_superh_clut224;
|
||||
extern const struct linux_logo logo_m32r_clut224;
|
||||
|
@ -21,7 +19,7 @@ diff -ruN linux-2.6.29.orig/drivers/video/logo/logo.c linux-2.6.29/drivers/video
|
|||
|
||||
static int nologo;
|
||||
module_param(nologo, bool, 0);
|
||||
@@ -115,6 +116,10 @@
|
||||
@@ -115,6 +116,10 @@ const struct linux_logo * __init_refok f
|
||||
/* M32R Linux logo */
|
||||
logo = &logo_m32r_clut224;
|
||||
#endif
|
||||
|
@ -32,9 +30,8 @@ diff -ruN linux-2.6.29.orig/drivers/video/logo/logo.c linux-2.6.29/drivers/video
|
|||
}
|
||||
return logo;
|
||||
}
|
||||
diff -ruN linux-2.6.29.orig/drivers/video/logo/logo_openwrt_clut224.ppm linux-2.6.29/drivers/video/logo/logo_openwrt_clut224.ppm
|
||||
--- linux-2.6.29.orig/drivers/video/logo/logo_openwrt_clut224.ppm 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ linux-2.6.29/drivers/video/logo/logo_openwrt_clut224.ppm 2009-05-15 09:54:13.000000000 +0200
|
||||
--- /dev/null
|
||||
+++ b/drivers/video/logo/logo_openwrt_clut224.ppm
|
||||
@@ -0,0 +1,38403 @@
|
||||
+P3
|
||||
+480 480
|
||||
|
@ -38439,10 +38436,9 @@ diff -ruN linux-2.6.29.orig/drivers/video/logo/logo_openwrt_clut224.ppm linux-2.
|
|||
+0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
|
||||
+0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
|
||||
+0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
|
||||
diff -ruN linux-2.6.29.orig/drivers/video/logo/Makefile linux-2.6.29/drivers/video/logo/Makefile
|
||||
--- linux-2.6.29.orig/drivers/video/logo/Makefile 2009-05-14 22:21:12.000000000 +0200
|
||||
+++ linux-2.6.29/drivers/video/logo/Makefile 2009-05-14 22:35:42.000000000 +0200
|
||||
@@ -15,6 +15,7 @@
|
||||
--- a/drivers/video/logo/Makefile
|
||||
+++ b/drivers/video/logo/Makefile
|
||||
@@ -15,6 +15,7 @@ obj-$(CONFIG_LOGO_SUPERH_MONO) += logo_
|
||||
obj-$(CONFIG_LOGO_SUPERH_VGA16) += logo_superh_vga16.o
|
||||
obj-$(CONFIG_LOGO_SUPERH_CLUT224) += logo_superh_clut224.o
|
||||
obj-$(CONFIG_LOGO_M32R_CLUT224) += logo_m32r_clut224.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/serial/samsung.c
|
||||
+++ b/drivers/serial/samsung.c
|
||||
@@ -882,7 +882,7 @@ static struct uart_ops s3c24xx_serial_op
|
||||
@@ -878,7 +878,7 @@ static struct uart_ops s3c24xx_serial_op
|
||||
|
||||
static struct uart_driver s3c24xx_uart_drv = {
|
||||
.owner = THIS_MODULE,
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
|
|||
FEATURES:=fpu
|
||||
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30-rc7
|
||||
LINUX_VERSION:=2.6.30-rc8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
Loading…
Reference in a new issue