replace led driver, and resync kernel config
SVN-Revision: 7744
This commit is contained in:
parent
bb2c2a81dd
commit
6a0c74d7b9
8 changed files with 628 additions and 85 deletions
|
@ -1,7 +1,6 @@
|
|||
CONFIG_32BIT=y
|
||||
# CONFIG_64BIT is not set
|
||||
# CONFIG_64BIT_PHYS_ADDR is not set
|
||||
CONFIG_ADM5120_GPIO=y
|
||||
CONFIG_ADM5120_HARDWARE_SWAB=y
|
||||
CONFIG_ADM5120_NR_UARTS=2
|
||||
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
|
||||
|
@ -95,6 +94,10 @@ CONFIG_JFFS2_FS_SECURITY=y
|
|||
CONFIG_JFFS2_FS_XATTR=y
|
||||
CONFIG_JFFS2_SUMMARY=y
|
||||
# CONFIG_JOLIET is not set
|
||||
CONFIG_LEDS_ADM5120=y
|
||||
CONFIG_LEDS_ADM5120_DIAG=y
|
||||
# CONFIG_LEDS_ADM5120_EXPERIMENTAL is not set
|
||||
CONFIG_LEDS_GPIO=y
|
||||
CONFIG_LEGACY_PTYS=y
|
||||
CONFIG_LEGACY_PTY_COUNT=256
|
||||
# CONFIG_MACH_DECSTATION is not set
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
/*
|
||||
* ADM5120 LED (GPIO) driver
|
||||
*
|
||||
* Copyright (C) Jeroen Vreeken (pe1rxq@amsat.org), 2005
|
||||
* Copyright (C) OpenWrt.org, Florian Fainelli <florian@openwrt.org>, 2007
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify
|
||||
* it under the terms of the GNU General Public License version 2 as
|
||||
* published by the Free Software Foundation.
|
||||
*/
|
||||
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/leds.h>
|
||||
|
||||
#define GPIO_IO ((unsigned long *)0xb20000b8)
|
||||
|
||||
static void adm5120_led_set(struct led_classdev *led_cdev, enum led_brightness brightness)
|
||||
{
|
||||
if (brightness)
|
||||
*GPIO_IO=(*GPIO_IO & 0x00ffffff) | (brightness << 24);
|
||||
else
|
||||
*GPIO_IO=(*GPIO_IO & 0x00ffffff) | (0 << 24);
|
||||
}
|
||||
|
||||
static struct led_classdev adm5120_gpio_led = {
|
||||
.name = "adm5120:led",
|
||||
.brightness_set = adm5120_led_set,
|
||||
};
|
||||
|
||||
static int __init adm5120_led_init(void)
|
||||
{
|
||||
int ret = led_classdev_register(NULL, &adm5120_gpio_led);
|
||||
|
||||
if (ret < 0)
|
||||
printk(KERN_WARNING "adm5120: unable to register LED device\n");
|
||||
|
||||
return ret;
|
||||
}
|
||||
|
||||
static void __exit adm5120_led_exit(void)
|
||||
{
|
||||
led_classdev_unregister(&adm5120_gpio_led);
|
||||
}
|
||||
|
||||
module_init(adm5120_led_init);
|
||||
module_exit(adm5120_led_exit);
|
||||
|
||||
MODULE_DESCRIPTION("ADM5120 LED driver");
|
||||
MODULE_AUTHOR("Jeroen Vreeken, OpenWrt.org");
|
||||
MODULE_LICENSE("GPL");
|
328
target/linux/adm5120-2.6/files/drivers/leds/leds-adm5120.c
Normal file
328
target/linux/adm5120-2.6/files/drivers/leds/leds-adm5120.c
Normal file
|
@ -0,0 +1,328 @@
|
|||
/*
|
||||
* $Id$
|
||||
*
|
||||
* ADM5120 GPIO LED devices
|
||||
*
|
||||
* Copyright (C) 2007 OpenWrt.org
|
||||
* Copyright (C) 2007 Gabor Juhos <juhosg@freemail.hu>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU General Public License
|
||||
* as published by the Free Software Foundation; either version 2
|
||||
* of the License, or (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
* but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the
|
||||
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
*/
|
||||
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/leds.h>
|
||||
#include <linux/err.h>
|
||||
|
||||
#include <linux/gpio_leds.h>
|
||||
|
||||
#include <asm/bootinfo.h>
|
||||
#include <asm/io.h>
|
||||
#include <asm/gpio.h>
|
||||
|
||||
#include <asm/mach-adm5120/adm5120_info.h>
|
||||
|
||||
#define NUM_LEDS_MAX 23
|
||||
|
||||
#define ADM5120_GPIO_xxxx 0x100 /* an unknown pin */
|
||||
|
||||
struct mach_data {
|
||||
unsigned long machtype;
|
||||
unsigned count;
|
||||
struct gpio_led_platform_data *data;
|
||||
};
|
||||
|
||||
struct adm5120_leddev {
|
||||
struct platform_device pdev;
|
||||
struct gpio_led_platform_data pdata;
|
||||
};
|
||||
|
||||
static int led_count = 0;
|
||||
static struct adm5120_leddev *led_devs[NUM_LEDS_MAX];
|
||||
|
||||
#define LED_ARRAY(n) \
|
||||
static struct gpio_led_platform_data \
|
||||
n ## _leds [] __initdata =
|
||||
|
||||
#define LED_DATA(n,t,g,off,on) { \
|
||||
.name = (n), \
|
||||
.trigger = (t), \
|
||||
.gpio = (g), \
|
||||
.value_off = (off), \
|
||||
.value_on = (on) \
|
||||
}
|
||||
|
||||
#define LED_STD(g,n,t) LED_DATA((n),(t),(g), 0, 1)
|
||||
#define LED_INV(g,n,t) LED_DATA((n),(t),(g), 1, 0)
|
||||
|
||||
/*
|
||||
* ZyXEL boards
|
||||
*/
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
LED_ARRAY(p334) { /* FIXME: untested */
|
||||
LED_INV(ADM5120_GPIO_xxxx, "power", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "lan1", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "lan2", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "lan3", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "lan4", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "wan", NULL ),
|
||||
};
|
||||
#endif
|
||||
|
||||
LED_ARRAY(p334wt) {
|
||||
LED_INV(ADM5120_GPIO_PIN2, "power", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P3L0, "lan1", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P2L0, "lan2", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P1L0, "lan3", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P0L0, "lan4", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P4L0, "wan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P4L2, "wlan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P2L2, "otist", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P1L2, "hidden", NULL ),
|
||||
};
|
||||
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
LED_ARRAY(p335) { /* FIXME: untested */
|
||||
LED_INV(ADM5120_GPIO_PIN2, "power", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P3L0, "lan1", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P2L0, "lan2", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P1L0, "lan3", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P0L0, "lan4", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P4L0, "wan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P4L2, "wlan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P2L2, "otist", NULL ),
|
||||
LED_INV(ADM5120_GPIO_xxxx, "usb", NULL ),
|
||||
};
|
||||
#endif
|
||||
|
||||
/*
|
||||
* Mikrotik boards
|
||||
*/
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
LED_ARRAY(rb100) { /* FIXME: untested */
|
||||
LED_STD(ADM5120_GPIO_PIN6, "power", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN3, "user", NULL ),
|
||||
};
|
||||
#endif
|
||||
|
||||
/*
|
||||
* Compex boards
|
||||
*/
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
LED_ARRAY(np27g) { /* FIXME: untested */
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan3", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan4", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "wan_cond", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "wlan", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "wan_act", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb2", NULL ),
|
||||
LED_INV(ADM5120_GPIO_PIN2, "power", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "diag", NULL ),
|
||||
};
|
||||
#endif
|
||||
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
LED_ARRAY(np28g) { /* FIXME: untested */
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "lan3", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "wan", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "wlan", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb3", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "usb4", NULL ),
|
||||
LED_INV(ADM5120_GPIO_PIN2, "power", NULL ),
|
||||
LED_STD(ADM5120_GPIO_xxxx, "diag", NULL ),
|
||||
};
|
||||
#endif
|
||||
|
||||
LED_ARRAY(wp54g) {
|
||||
LED_INV(ADM5120_GPIO_PIN2, "diag", NULL ),
|
||||
LED_INV(ADM5120_GPIO_PIN6, "wlan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_PIN7, "wan", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P0L0, "lan1", NULL ),
|
||||
LED_INV(ADM5120_GPIO_P1L0, "lan2", NULL ),
|
||||
};
|
||||
|
||||
LED_ARRAY(unknown) {
|
||||
#if defined(CONFIG_LEDS_ADM5120_DIAG)
|
||||
LED_STD(ADM5120_GPIO_PIN0, "gpio0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN1, "gpio1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN2, "gpio2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN3, "gpio3", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN4, "gpio4", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN5, "gpio5", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN6, "gpio6", NULL ),
|
||||
LED_STD(ADM5120_GPIO_PIN7, "gpio7", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P0L0, "port0led0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P0L1, "port0led1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P0L2, "port0led2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P1L0, "port1led0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P1L1, "port1led1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P1L2, "port1led2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P2L0, "port2led0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P2L1, "port2led1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P2L2, "port2led2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P3L0, "port3led0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P3L1, "port3led1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P3L2, "port3led2", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P4L0, "port4led0", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P4L1, "port4led1", NULL ),
|
||||
LED_STD(ADM5120_GPIO_P4L2, "port4led2", NULL ),
|
||||
#endif
|
||||
};
|
||||
|
||||
#define MACH_DATA(m, n) { \
|
||||
.machtype = (m), \
|
||||
.count = ARRAY_SIZE(n ## _leds), \
|
||||
.data = n ## _leds \
|
||||
}
|
||||
|
||||
static struct mach_data machines[] __initdata = {
|
||||
MACH_DATA(MACH_ADM5120_UNKNOWN, unknown),
|
||||
MACH_DATA(MACH_ADM5120_P334WT, p334wt),
|
||||
MACH_DATA(MACH_ADM5120_WP54AG, wp54g),
|
||||
MACH_DATA(MACH_ADM5120_WP54G, wp54g),
|
||||
MACH_DATA(MACH_ADM5120_WP54G_WRT, wp54g),
|
||||
MACH_DATA(MACH_ADM5120_WPP54AG, wp54g),
|
||||
MACH_DATA(MACH_ADM5120_WPP54G, wp54g),
|
||||
#if defined(CONFIG_LEDS_ADM5120_EXPERIMENTAL)
|
||||
MACH_DATA(MACH_ADM5120_P334, p334),
|
||||
MACH_DATA(MACH_ADM5120_P335, p335),
|
||||
MACH_DATA(MACH_ADM5120_RB_111, rb100),
|
||||
MACH_DATA(MACH_ADM5120_RB_112, rb100),
|
||||
MACH_DATA(MACH_ADM5120_NP27G, np27g),
|
||||
MACH_DATA(MACH_ADM5120_NP28G, np28g),
|
||||
MACH_DATA(MACH_ADM5120_NP28GHS, np28g),
|
||||
#endif
|
||||
};
|
||||
|
||||
static struct adm5120_leddev * __init
|
||||
create_leddev(struct gpio_led_platform_data *data)
|
||||
{
|
||||
struct adm5120_leddev *p;
|
||||
|
||||
p = kzalloc(sizeof(*p), GFP_KERNEL);
|
||||
if (p == NULL)
|
||||
return NULL;
|
||||
|
||||
memcpy(&p->pdata, data, sizeof(p->pdata));
|
||||
p->pdev.dev.platform_data = &p->pdata;
|
||||
|
||||
return p;
|
||||
}
|
||||
|
||||
static void
|
||||
destroy_leddev(struct adm5120_leddev *led)
|
||||
{
|
||||
if (led)
|
||||
kfree(led);
|
||||
}
|
||||
|
||||
static struct mach_data * __init
|
||||
adm5120_leds_findmach(unsigned long machtype)
|
||||
{
|
||||
struct mach_data *mach;
|
||||
int i;
|
||||
|
||||
mach = NULL;
|
||||
for (i=0; i<ARRAY_SIZE(machines); i++) {
|
||||
if (machines[i].machtype == machtype) {
|
||||
mach = &machines[i];
|
||||
break;
|
||||
}
|
||||
};
|
||||
|
||||
#if defined(CONFIG_LEDS_ADM5120_DIAG)
|
||||
if (mach == NULL)
|
||||
mach = machines;
|
||||
#endif
|
||||
|
||||
return mach;
|
||||
}
|
||||
|
||||
static int __init
|
||||
adm5120_leds_init(void)
|
||||
{
|
||||
struct mach_data *mach;
|
||||
int i, ret;
|
||||
|
||||
if (mips_machgroup != MACH_GROUP_ADM5120) {
|
||||
ret = -EINVAL;
|
||||
goto err;
|
||||
}
|
||||
|
||||
mach = adm5120_leds_findmach(mips_machtype);
|
||||
if (mach == NULL) {
|
||||
/* the board is not yet supported */
|
||||
ret = -EINVAL;
|
||||
goto err;
|
||||
}
|
||||
|
||||
for (i=0; i < mach->count; i++) {
|
||||
led_devs[i] = create_leddev(&mach->data[i]);
|
||||
if (led_devs[i] == NULL) {
|
||||
ret = -ENOMEM;
|
||||
goto err_destroy;
|
||||
}
|
||||
led_devs[i]->pdev.name = "gpio-led";
|
||||
led_devs[i]->pdev.id = i;
|
||||
}
|
||||
|
||||
for (i=0; i < mach->count; i++) {
|
||||
ret = platform_device_register(&led_devs[i]->pdev);
|
||||
if (ret)
|
||||
goto err_unregister;
|
||||
}
|
||||
|
||||
led_count = mach->count;
|
||||
return 0;
|
||||
|
||||
err_unregister:
|
||||
for (i--; i>=0; i--)
|
||||
platform_device_unregister(&led_devs[i]->pdev);
|
||||
|
||||
err_destroy:
|
||||
for (i=0; i<led_count; i++)
|
||||
destroy_leddev(led_devs[i]);
|
||||
err:
|
||||
return ret;
|
||||
}
|
||||
|
||||
static void __exit
|
||||
adm5120_leds_exit(void)
|
||||
{
|
||||
int i;
|
||||
|
||||
for (i=0; i < led_count; i++) {
|
||||
platform_device_unregister(&led_devs[i]->pdev);
|
||||
destroy_leddev(led_devs[i]);
|
||||
}
|
||||
}
|
||||
|
||||
module_init(adm5120_leds_init);
|
||||
module_exit(adm5120_leds_exit);
|
||||
|
||||
MODULE_AUTHOR("Gabor Juhos <juhosg@freemail.hu>");
|
||||
MODULE_DESCRIPTION(DRV_DESC);
|
||||
MODULE_LICENSE("GPL");
|
||||
|
209
target/linux/adm5120-2.6/files/drivers/leds/leds-gpio.c
Executable file
209
target/linux/adm5120-2.6/files/drivers/leds/leds-gpio.c
Executable file
|
@ -0,0 +1,209 @@
|
|||
/*
|
||||
* $Id$
|
||||
*
|
||||
* Driver for LEDs connected to GPIO lines
|
||||
*
|
||||
* Copyright (C) 2007 OpenWrt.org
|
||||
* Copyright (C) 2007 Gabor Juhos <juhosg@freemail.hu>
|
||||
*
|
||||
* This file was derived from:
|
||||
* /drivers/led/leds-s3c24xx.c
|
||||
* (c) 2006 Simtec Electronics, Ben Dooks <ben@simtec.co.uk>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU General Public License
|
||||
* as published by the Free Software Foundation; either version 2
|
||||
* of the License, or (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
* but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the
|
||||
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
*/
|
||||
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/init.h>
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/leds.h>
|
||||
#include <linux/err.h>
|
||||
|
||||
#include <linux/gpio_leds.h>
|
||||
|
||||
#include <asm/io.h>
|
||||
#include <asm/gpio.h>
|
||||
|
||||
#define DRV_NAME "gpio-led"
|
||||
#define DRV_DESC "GPIO LEDs driver"
|
||||
|
||||
struct gpio_led_device {
|
||||
struct led_classdev cdev;
|
||||
struct gpio_led_platform_data *pdata;
|
||||
};
|
||||
|
||||
static inline struct gpio_led_device *pdev_to_led(struct platform_device *dev)
|
||||
{
|
||||
return platform_get_drvdata(dev);
|
||||
}
|
||||
|
||||
static inline struct gpio_led_device *class_to_led(struct led_classdev *led_cdev)
|
||||
{
|
||||
return container_of(led_cdev, struct gpio_led_device, cdev);
|
||||
}
|
||||
|
||||
static void gpio_led_set(struct led_classdev *led_cdev,
|
||||
enum led_brightness brightness)
|
||||
{
|
||||
struct gpio_led_device *led;
|
||||
struct gpio_led_platform_data *pdata;
|
||||
|
||||
led = class_to_led(led_cdev);
|
||||
pdata = led->pdata;
|
||||
|
||||
switch (brightness) {
|
||||
case LED_OFF:
|
||||
gpio_direction_output(pdata->gpio, pdata->value_off);
|
||||
break;
|
||||
default:
|
||||
gpio_direction_output(pdata->gpio, pdata->value_on);
|
||||
break;
|
||||
}
|
||||
}
|
||||
|
||||
static int __devinit gpio_led_probe(struct platform_device *dev)
|
||||
{
|
||||
struct gpio_led_platform_data *pdata;
|
||||
struct gpio_led_device *led;
|
||||
int ret;
|
||||
|
||||
pdata = dev->dev.platform_data;
|
||||
if (pdata == NULL) {
|
||||
dev_err(&dev->dev, "no platform data, id=%d\n", dev->id);
|
||||
ret = -EINVAL;
|
||||
goto err;
|
||||
}
|
||||
|
||||
if (pdata->name == NULL) {
|
||||
dev_err(&dev->dev, "no led name specified\n");
|
||||
ret = -EINVAL;
|
||||
goto err;
|
||||
}
|
||||
|
||||
ret = gpio_request(pdata->gpio, pdata->name);
|
||||
if (ret) {
|
||||
dev_err(&dev->dev, "gpio_request failed\n");
|
||||
goto err;
|
||||
}
|
||||
|
||||
led = kzalloc(sizeof(*led), GFP_KERNEL);
|
||||
if (led == NULL) {
|
||||
dev_err(&dev->dev, "no memory for device");
|
||||
ret = -ENOMEM;
|
||||
goto err_free_gpio;
|
||||
}
|
||||
|
||||
platform_set_drvdata(dev, led);
|
||||
led->pdata = pdata;
|
||||
led->cdev.name = pdata->name;
|
||||
led->cdev.brightness_set = gpio_led_set;
|
||||
#ifdef CONFIG_LEDS_TRIGGERS
|
||||
led->cdev.default_trigger = pdata->trigger;
|
||||
#endif
|
||||
|
||||
ret = led_classdev_register(&dev->dev, &led->cdev);
|
||||
if (ret < 0) {
|
||||
dev_err(&dev->dev, "led_classdev_register failed");
|
||||
goto err_free_led;
|
||||
}
|
||||
|
||||
return 0;
|
||||
|
||||
err_free_led:
|
||||
kfree(led);
|
||||
err_free_gpio:
|
||||
gpio_free(pdata->gpio);
|
||||
err:
|
||||
return ret;
|
||||
}
|
||||
|
||||
static int __devexit gpio_led_remove(struct platform_device *dev)
|
||||
{
|
||||
struct gpio_led_device *led;
|
||||
struct gpio_led_platform_data *pdata;
|
||||
|
||||
pdata = dev->dev.platform_data;
|
||||
|
||||
led = pdev_to_led(dev);
|
||||
led_classdev_unregister(&led->cdev);
|
||||
kfree(led);
|
||||
|
||||
gpio_free(pdata->gpio);
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
#ifdef CONFIG_PM
|
||||
static int gpio_led_suspend(struct platform_device *dev,
|
||||
pm_message_t state)
|
||||
{
|
||||
struct gpio_led_device *led;
|
||||
|
||||
led = pdev_to_led(dev);
|
||||
led_classdev_suspend(&led->cdev);
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
static int gpio_led_resume(struct platform_device *dev)
|
||||
{
|
||||
struct gpio_led_device *led;
|
||||
|
||||
led = pdev_to_led(dev);
|
||||
led_classdev_resume(&led->cdev);
|
||||
|
||||
return 0;
|
||||
}
|
||||
#endif /* CONFIG_PM */
|
||||
|
||||
static struct platform_driver gpio_led_driver = {
|
||||
.probe = gpio_led_probe,
|
||||
.remove = __devexit_p(gpio_led_remove),
|
||||
#ifdef CONFIG_PM
|
||||
.suspend = gpio_led_suspend,
|
||||
.resume = gpio_led_resume,
|
||||
#endif
|
||||
.driver = {
|
||||
.name = DRV_NAME,
|
||||
.owner = THIS_MODULE,
|
||||
},
|
||||
};
|
||||
|
||||
static int __init gpio_led_init(void)
|
||||
{
|
||||
int ret;
|
||||
|
||||
ret = platform_driver_register(&gpio_led_driver);
|
||||
if (ret)
|
||||
printk(KERN_ALERT DRV_DESC " register failed\n");
|
||||
else
|
||||
printk(KERN_INFO DRV_DESC " registered\n");
|
||||
|
||||
return ret;
|
||||
}
|
||||
|
||||
static void __exit gpio_led_exit(void)
|
||||
{
|
||||
platform_driver_unregister(&gpio_led_driver);
|
||||
}
|
||||
|
||||
module_init(gpio_led_init);
|
||||
module_exit(gpio_led_exit);
|
||||
|
||||
MODULE_AUTHOR("Gabor Juhos <juhosg@freemail.hu>");
|
||||
MODULE_DESCRIPTION(DRV_DESC);
|
||||
MODULE_LICENSE("GPL");
|
37
target/linux/adm5120-2.6/files/include/linux/gpio_leds.h
Normal file
37
target/linux/adm5120-2.6/files/include/linux/gpio_leds.h
Normal file
|
@ -0,0 +1,37 @@
|
|||
/*
|
||||
* $Id$
|
||||
*
|
||||
* GPIO LEDs platform data structure
|
||||
*
|
||||
* Copyright (C) 2007 OpenWrt.org
|
||||
* Copyright (C) 2007 Gabor Juhos <juhosg@freemail.hu>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU General Public License
|
||||
* as published by the Free Software Foundation; either version 2
|
||||
* of the License, or (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
* but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the
|
||||
* Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
*/
|
||||
|
||||
#ifndef _GPIO_LEDS_H_
|
||||
#define _GPIO_LEDS_H_
|
||||
|
||||
struct gpio_led_platform_data {
|
||||
char *name;
|
||||
char *trigger;
|
||||
unsigned gpio; /* GPIO line number */
|
||||
int value_off; /* value to turn LED OFF */
|
||||
int value_on; /* value to turn LED ON */
|
||||
};
|
||||
|
||||
#endif /* _GPIO_LEDS_H__ */
|
|
@ -1,27 +0,0 @@
|
|||
Index: linux-2.6.21.1/drivers/char/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.21.1.orig/drivers/char/Kconfig
|
||||
+++ linux-2.6.21.1/drivers/char/Kconfig
|
||||
@@ -1056,7 +1056,9 @@ config MMTIMER
|
||||
The mmtimer device allows direct userspace access to the
|
||||
Altix system timer.
|
||||
|
||||
-source "drivers/char/tpm/Kconfig"
|
||||
+config ADM5120_GPIO
|
||||
+ tristate "ADM5120 GPIO"
|
||||
+ depends on MIPS_ADM5120
|
||||
|
||||
config TELCLOCK
|
||||
tristate "Telecom clock driver for ATCA SBC"
|
||||
Index: linux-2.6.21.1/drivers/char/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.21.1.orig/drivers/char/Makefile
|
||||
+++ linux-2.6.21.1/drivers/char/Makefile
|
||||
@@ -93,6 +93,7 @@ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio
|
||||
obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
|
||||
obj-$(CONFIG_TANBAC_TB0219) += tb0219.o
|
||||
obj-$(CONFIG_TELCLOCK) += tlclk.o
|
||||
+obj-$(CONFIG_ADM5120_GPIO) += adm5120_gpio.o
|
||||
|
||||
obj-$(CONFIG_WATCHDOG) += watchdog/
|
||||
obj-$(CONFIG_MWAVE) += mwave/
|
45
target/linux/adm5120-2.6/patches/006-adm5120_leds.patch
Normal file
45
target/linux/adm5120-2.6/patches/006-adm5120_leds.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
Index: linux-2.6.21.1/drivers/leds/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.21.1.orig/drivers/leds/Kconfig
|
||||
+++ linux-2.6.21.1/drivers/leds/Kconfig
|
||||
@@ -19,6 +19,27 @@ config LEDS_CLASS
|
||||
|
||||
comment "LED drivers"
|
||||
|
||||
+config LEDS_GPIO
|
||||
+ tristate "LED support for LEDS on GPIO lines"
|
||||
+ depends on LEDS_CLASS && GENERIC_GPIO
|
||||
+ help
|
||||
+ This option enables support for LEDs connected to GPIO lines
|
||||
+
|
||||
+config LEDS_ADM5120
|
||||
+ tristate "LED Support for ADM5120 GPIO LEDs"
|
||||
+ depends on LEDS_GPIO && MIPS_ADM5120
|
||||
+ help
|
||||
+ This option enables support for LEDs connected to GPIO lines
|
||||
+ on ADM5120 SoC based platforms.
|
||||
+
|
||||
+config LEDS_ADM5120_EXPERIMENTAL
|
||||
+ bool "Enable ADM5120 LEDs experimental code"
|
||||
+ depends on LEDS_ADM5120
|
||||
+
|
||||
+config LEDS_ADM5120_DIAG
|
||||
+ bool "Enable ADM5120 LEDs diagnostic mode"
|
||||
+ depends on LEDS_ADM5120
|
||||
+
|
||||
config LEDS_CORGI
|
||||
tristate "LED Support for the Sharp SL-C7x0 series"
|
||||
depends on LEDS_CLASS && PXA_SHARP_C7xx
|
||||
Index: linux-2.6.21.1/drivers/leds/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.21.1.orig/drivers/leds/Makefile
|
||||
+++ linux-2.6.21.1/drivers/leds/Makefile
|
||||
@@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
|
||||
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
|
||||
|
||||
# LED Platform Drivers
|
||||
+obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
|
||||
+obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
|
||||
obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
|
||||
obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
|
||||
obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o
|
|
@ -1,10 +1,8 @@
|
|||
CONFIG_32BIT=y
|
||||
# CONFIG_64BIT is not set
|
||||
# CONFIG_64BIT_PHYS_ADDR is not set
|
||||
CONFIG_ADM5120_GPIO=y
|
||||
CONFIG_ADM5120_HARDWARE_SWAB=y
|
||||
CONFIG_ADM5120_NR_UARTS=2
|
||||
# CONFIG_ATM_DRIVERS is not set
|
||||
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
|
||||
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
|
||||
CONFIG_BASE_SMALL=0
|
||||
|
@ -62,9 +60,9 @@ CONFIG_GENERIC_FIND_NEXT_BIT=y
|
|||
CONFIG_GENERIC_GPIO=y
|
||||
# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
|
||||
# CONFIG_GEN_RTC is not set
|
||||
CONFIG_HID=m
|
||||
CONFIG_HAS_IOMEM=y
|
||||
CONFIG_HAS_IOPORT=y
|
||||
CONFIG_HID=m
|
||||
CONFIG_HWMON=y
|
||||
# CONFIG_HWMON_DEBUG_CHIP is not set
|
||||
CONFIG_HW_HAS_PCI=y
|
||||
|
@ -96,9 +94,12 @@ CONFIG_JFFS2_FS_SECURITY=y
|
|||
CONFIG_JFFS2_FS_XATTR=y
|
||||
CONFIG_JFFS2_SUMMARY=y
|
||||
# CONFIG_JOLIET is not set
|
||||
CONFIG_LEDS_ADM5120=y
|
||||
CONFIG_LEDS_ADM5120_DIAG=y
|
||||
# CONFIG_LEDS_ADM5120_EXPERIMENTAL is not set
|
||||
CONFIG_LEDS_GPIO=y
|
||||
CONFIG_LEGACY_PTYS=y
|
||||
CONFIG_LEGACY_PTY_COUNT=256
|
||||
# CONFIG_MACH_ALCHEMY is not set
|
||||
# CONFIG_MACH_DECSTATION is not set
|
||||
# CONFIG_MACH_JAZZ is not set
|
||||
# CONFIG_MACH_VR41XX is not set
|
||||
|
@ -193,7 +194,6 @@ CONFIG_NET_KEY=y
|
|||
# CONFIG_NET_PKTGEN is not set
|
||||
CONFIG_NET_SCH_FIFO=y
|
||||
# CONFIG_NET_VENDOR_3COM is not set
|
||||
# CONFIG_NETDEV_1000 is not set
|
||||
# CONFIG_PAGE_SIZE_16KB is not set
|
||||
CONFIG_PAGE_SIZE_4KB=y
|
||||
# CONFIG_PAGE_SIZE_64KB is not set
|
||||
|
|
Loading…
Reference in a new issue