xtables-addons: update to 2.11
- fix compilation w. Kernel 4.6 due to hash->shash crypto API - remove a patch integrated upstream - remove unrecognized configure option removed upstream in 2010 commit 40d0345f1ed02de183b13a6ce38847bc1f4ac48e Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
This commit is contained in:
parent
20c608db0a
commit
652ac2c6fd
3 changed files with 8 additions and 60 deletions
|
@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=xtables-addons
|
PKG_NAME:=xtables-addons
|
||||||
PKG_VERSION:=2.10
|
PKG_VERSION:=2.11
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=727bf0dd4a3d9c65724267bd0d5d80b0
|
PKG_MD5SUM:=9f3123295db81a9d1bc08dabf075d0d6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@SF/xtables-addons
|
PKG_SOURCE_URL:=@SF/xtables-addons
|
||||||
|
@ -39,7 +39,6 @@ endef
|
||||||
|
|
||||||
CONFIGURE_ARGS+= \
|
CONFIGURE_ARGS+= \
|
||||||
--with-kbuild="$(LINUX_DIR)" \
|
--with-kbuild="$(LINUX_DIR)" \
|
||||||
--with-xtables="$(STAGING_DIR)/usr" \
|
|
||||||
--with-xtlibdir="/usr/lib/iptables" \
|
--with-xtlibdir="/usr/lib/iptables" \
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
|
|
@ -1,51 +0,0 @@
|
||||||
From f07a0a5cb8b3c5e1aee8b30c7fa21ccfbf24a95a Mon Sep 17 00:00:00 2001
|
|
||||||
Message-Id: <f07a0a5cb8b3c5e1aee8b30c7fa21ccfbf24a95a.1459880505.git.mschiffer@universe-factory.net>
|
|
||||||
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
||||||
Date: Fri, 1 Apr 2016 22:24:00 +0200
|
|
||||||
Subject: [PATCH] build: fix configure compatiblity with POSIX shells
|
|
||||||
|
|
||||||
The kernel version detection code uses some bashisms, which makes the build
|
|
||||||
fail on Debian systems where /bin/sh links to dash. Replace with POSIX-
|
|
||||||
conforming commands at the cost of requiring awk.
|
|
||||||
---
|
|
||||||
configure.ac | 24 +++++++++---------------
|
|
||||||
1 file changed, 9 insertions(+), 15 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 82a1355..5a5ea57 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -44,21 +44,15 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
|
|
||||||
|
|
||||||
if test -n "$kbuilddir"; then
|
|
||||||
AC_MSG_CHECKING([kernel version that we will build against])
|
|
||||||
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
|
||||||
- kmajor="${krel%%[[^0-9]]*}";
|
|
||||||
- kmajor="$(($kmajor+0))";
|
|
||||||
- krel="${krel:${#kmajor}}";
|
|
||||||
- krel="${krel#.}";
|
|
||||||
- kminor="${krel%%[[^0-9]]*}";
|
|
||||||
- kminor="$(($kminor+0))";
|
|
||||||
- krel="${krel:${#kminor}}";
|
|
||||||
- krel="${krel#.}";
|
|
||||||
- kmicro="${krel%%[[^0-9]]*}";
|
|
||||||
- kmicro="$(($kmicro+0))";
|
|
||||||
- krel="${krel:${#kmicro}}";
|
|
||||||
- krel="${krel#.}";
|
|
||||||
- kstable="${krel%%[[^0-9]]*}";
|
|
||||||
- kstable="$(($kstable+0))";
|
|
||||||
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
|
|
||||||
+ save_IFS=$IFS;
|
|
||||||
+ IFS='.';
|
|
||||||
+ set x $krel;
|
|
||||||
+ IFS=$save_IFS;
|
|
||||||
+ kmajor="$(($2+0))";
|
|
||||||
+ kminor="$(($3+0))";
|
|
||||||
+ kmicro="$(($4+0))";
|
|
||||||
+ kstable="$(($5+0))";
|
|
||||||
if test -z "$kmajor" -o -z "$kminor" -o -z "$kmicro"; then
|
|
||||||
echo "WARNING: Version detection did not succeed. Continue at own luck.";
|
|
||||||
else
|
|
||||||
--
|
|
||||||
2.8.0
|
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
|
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
||||||
|
|
||||||
if test -n "$kbuilddir"; then
|
if test -n "$kbuilddir"; then
|
||||||
AC_MSG_CHECKING([kernel version that we will build against])
|
AC_MSG_CHECKING([kernel version that we will build against])
|
||||||
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
|
||||||
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
|
||||||
save_IFS=$IFS;
|
save_IFS="$IFS"
|
||||||
IFS='.';
|
IFS='.'
|
||||||
set x $krel;
|
set x $krel
|
||||||
|
|
Loading…
Reference in a new issue