qca-nss-gmac: delete package
nss-gmac has been replaced by its upstream counterpart "stmmac", to which we added the SoC glue layer required for it to run on IPQ806x. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45832
This commit is contained in:
parent
d2a2eb7e48
commit
6301009ae3
2 changed files with 0 additions and 65 deletions
|
@ -1,50 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (c) 2015 The Linux Foundation. All rights reserved.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
|
||||||
|
|
||||||
PKG_NAME:=qca-nss-gmac
|
|
||||||
PKG_VERSION:=20150408
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=git://codeaurora.org/quic/qsdk/oss/lklm/nss-gmac
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=3dcb945b467f8f6b3c81338e63c917f768deb11e
|
|
||||||
|
|
||||||
PKG_LICENSE:=ISC
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define KernelPackage/qca-nss-gmac
|
|
||||||
SECTION:=kernel
|
|
||||||
CATEGORY:=Kernel modules
|
|
||||||
SUBMENU:=Network Devices
|
|
||||||
DEPENDS:=@TARGET_ipq806x
|
|
||||||
TITLE:=Kernel driver for NSS gmac
|
|
||||||
FILES:=$(PKG_BUILD_DIR)/ipq806x/qca-nss-gmac.ko
|
|
||||||
AUTOLOAD:=$(call AutoProbe,qca-nss-gmac)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/qca-nss-gmac/Description
|
|
||||||
This package contains a NSS driver for QCA chipset
|
|
||||||
endef
|
|
||||||
|
|
||||||
EXTRA_CFLAGS+= \
|
|
||||||
-DCONFIG_NSS_DEBUG_LEVEL=4 \
|
|
||||||
-I$(PKG_BUILD_DIR)/nss_hal/include \
|
|
||||||
-I$(PKG_BUILD_DIR)/nss_hal/$(BOARD)
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C "$(LINUX_DIR)" \
|
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
|
||||||
ARCH="$(LINUX_KARCH)" \
|
|
||||||
SUBDIRS="$(PKG_BUILD_DIR)" \
|
|
||||||
EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
|
|
||||||
modules
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call KernelPackage,qca-nss-gmac))
|
|
|
@ -1,15 +0,0 @@
|
||||||
diff --git a/ipq806x/nss_gmac_tx_rx_offload.c b/ipq806x/nss_gmac_tx_rx_offload.c
|
|
||||||
index bc684a5..383403b 100644
|
|
||||||
--- a/ipq806x/nss_gmac_tx_rx_offload.c
|
|
||||||
+++ b/ipq806x/nss_gmac_tx_rx_offload.c
|
|
||||||
@@ -896,8 +896,8 @@ int nss_gmac_open(struct net_device *netdev)
|
|
||||||
nss_gmac_rx_refill(gmacdev);
|
|
||||||
|
|
||||||
/* Register IRQ */
|
|
||||||
- err = request_irq(netdev->irq, nss_gmac_handle_irq,
|
|
||||||
- IRQF_DISABLED, "nss-gmac", gmacdev);
|
|
||||||
+ err = request_irq(netdev->irq, nss_gmac_handle_irq, 0,
|
|
||||||
+ "nss-gmac", gmacdev);
|
|
||||||
if (err) {
|
|
||||||
netdev_dbg(netdev, "Mac %d IRQ %d request failed\n",
|
|
||||||
gmacdev->macid, netdev->irq);
|
|
Loading…
Reference in a new issue