Fix the platform device registration; resync kernel config
SVN-Revision: 9266
This commit is contained in:
parent
7745eb277d
commit
61c5597d73
4 changed files with 3 additions and 16 deletions
|
@ -47,7 +47,6 @@ CONFIG_DEVPORT=y
|
||||||
# CONFIG_DM9000 is not set
|
# CONFIG_DM9000 is not set
|
||||||
CONFIG_DMA_NEED_PCI_MAP_STATE=y
|
CONFIG_DMA_NEED_PCI_MAP_STATE=y
|
||||||
CONFIG_DMA_NONCOHERENT=y
|
CONFIG_DMA_NONCOHERENT=y
|
||||||
# CONFIG_DS1682 is not set
|
|
||||||
CONFIG_DUMMY=m
|
CONFIG_DUMMY=m
|
||||||
CONFIG_ELF_CORE=y
|
CONFIG_ELF_CORE=y
|
||||||
# CONFIG_FIXED_PHY is not set
|
# CONFIG_FIXED_PHY is not set
|
||||||
|
@ -70,7 +69,6 @@ CONFIG_I2C_ALGOPCA=m
|
||||||
CONFIG_I2C_ALGOPCF=m
|
CONFIG_I2C_ALGOPCF=m
|
||||||
CONFIG_I2C_BOARDINFO=y
|
CONFIG_I2C_BOARDINFO=y
|
||||||
CONFIG_I2C_CHARDEV=m
|
CONFIG_I2C_CHARDEV=m
|
||||||
# CONFIG_I2C_TAOS_EVM is not set
|
|
||||||
# CONFIG_IDE is not set
|
# CONFIG_IDE is not set
|
||||||
CONFIG_INITRAMFS_SOURCE=""
|
CONFIG_INITRAMFS_SOURCE=""
|
||||||
CONFIG_LEDS_GPIO=y
|
CONFIG_LEDS_GPIO=y
|
||||||
|
@ -181,7 +179,6 @@ CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
|
||||||
CONFIG_SCSI_CONSTANTS=y
|
CONFIG_SCSI_CONSTANTS=y
|
||||||
# CONFIG_SCSI_PROC_FS is not set
|
# CONFIG_SCSI_PROC_FS is not set
|
||||||
CONFIG_SCSI_WAIT_SCAN=m
|
CONFIG_SCSI_WAIT_SCAN=m
|
||||||
# CONFIG_SENSORS_TSL2550 is not set
|
|
||||||
CONFIG_SERIAL_8250_AU1X00=y
|
CONFIG_SERIAL_8250_AU1X00=y
|
||||||
# CONFIG_SERIAL_8250_EXTENDED is not set
|
# CONFIG_SERIAL_8250_EXTENDED is not set
|
||||||
CONFIG_SERIAL_8250_NR_UARTS=4
|
CONFIG_SERIAL_8250_NR_UARTS=4
|
||||||
|
|
|
@ -70,5 +70,5 @@ static int __init mtx1_register_devices(void)
|
||||||
return platform_add_devices(mtx1_devs, ARRAY_SIZE(mtx1_devs));
|
return platform_add_devices(mtx1_devs, ARRAY_SIZE(mtx1_devs));
|
||||||
}
|
}
|
||||||
|
|
||||||
arch_initcall(mtx1_register_devices);
|
module_init(mtx1_register_devices);
|
||||||
|
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
diff --git a/arch/mips/au1000/mtx-1/Makefile b/arch/mips/au1000/mtx-1/Makefile
|
|
||||||
index 764bf9f..4d1b8d2 100644
|
|
||||||
--- a/arch/mips/au1000/mtx-1/Makefile
|
|
||||||
+++ b/arch/mips/au1000/mtx-1/Makefile
|
|
||||||
@@ -7,4 +7,4 @@
|
|
||||||
# Makefile for 4G Systems MTX-1 board.
|
|
||||||
#
|
|
||||||
|
|
||||||
-lib-y := init.o board_setup.o irqmap.o
|
|
||||||
+lib-y := init.o board_setup.o irqmap.o platform.o
|
|
|
@ -15,8 +15,8 @@ diff -urN linux-2.6.16.7/arch/mips/au1000/mtx-1/Makefile linux-2.6.16.7.new/arch
|
||||||
@@ -8,3 +8,4 @@
|
@@ -8,3 +8,4 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
lib-y := init.o board_setup.o irqmap.o platform.o
|
lib-y := init.o board_setup.o irqmap.o
|
||||||
+obj-y := mtx-1_sysbtn.o
|
+obj-y := mtx-1_sysbtn.o platform.o
|
||||||
diff -urN linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c
|
diff -urN linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c
|
||||||
--- linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c 1970-01-01 01:00:00.000000000 +0100
|
--- linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c 2006-04-23 14:01:17.000000000 +0200
|
+++ linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c 2006-04-23 14:01:17.000000000 +0200
|
||||||
|
|
Loading…
Reference in a new issue