fix procmail compile, thx Michael
SVN-Revision: 3454
This commit is contained in:
parent
070ceb2145
commit
60214c1cb4
2 changed files with 52 additions and 3 deletions
|
@ -18,11 +18,9 @@ include $(TOPDIR)/package/rules.mk
|
|||
$(eval $(call PKG_template,PROCMAIL,procmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/ init \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src -f ../Makefile.openwrt \
|
||||
CC=$(TARGET_CC)
|
||||
|
||||
echo yes | $(MAKE) -C $(PKG_BUILD_DIR)/src/ procmail formail \
|
||||
CC=$(TARGET_CC)
|
||||
touch $@
|
||||
|
||||
$(IPKG_PROCMAIL):
|
||||
|
|
51
openwrt/package/procmail/patches/promail_openwrt.patch
Normal file
51
openwrt/package/procmail/patches/promail_openwrt.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
This patch is required to make procmail cross compile - it tries to run some automatic tests which
|
||||
obviously do not work in a cross compiled environment.
|
||||
|
||||
|
||||
diff -Naur procmail-3.22_orig/autoconf.h procmail-3.22/autoconf.h
|
||||
--- procmail-3.22_orig/autoconf.h 1970-01-01 10:00:00.000000000 +1000
|
||||
+++ procmail-3.22/autoconf.h 2006-03-23 12:15:36.000000000 +1100
|
||||
@@ -0,0 +1,21 @@
|
||||
+/* This file was automagically generated by autoconf */
|
||||
+
|
||||
+/* 5 moves in 64 steps of size 16384 when reallocing */
|
||||
+#define NOpw_class
|
||||
+#define NOstrlcat
|
||||
+#define NOsetrgid
|
||||
+#define MAX_argc 7588
|
||||
+/* Your system's strstr() is 1.12 times FASTER than my C-routine */
|
||||
+#define UDP_protocolno 17
|
||||
+#define BIFF_serviceport "512"
|
||||
+#define IP_localhost {127,0,0,1}
|
||||
+#define MAILSPOOLDIR "/var/spool/mail/"
|
||||
+#define SENDMAIL "/usr/sbin/sendmail"
|
||||
+#define CF_no_procmail_yet
|
||||
+#define buggy_SENDMAIL
|
||||
+#define defPATH "PATH=$HOME/bin:/bin:/usr/bin:/usr/local/bin:/usr/bin/X11"
|
||||
+#define defSPATH "PATH=/bin:/usr/bin:/usr/local/bin:/usr/bin/X11"
|
||||
+#define PM_VERSION "3.22"
|
||||
+/* Hotwire LOCKINGTEST=100 */
|
||||
+/* Procmail will lock via: dotlocking, fcntl() */
|
||||
+/* autoconf completed */
|
||||
diff -Naur procmail-3.22_orig/Makefile.openwrt procmail-3.22/Makefile.openwrt
|
||||
--- procmail-3.22_orig/Makefile.openwrt 1970-01-01 10:00:00.000000000 +1000
|
||||
+++ procmail-3.22/Makefile.openwrt 2006-03-23 12:15:36.000000000 +1100
|
||||
@@ -0,0 +1,18 @@
|
||||
+PM_OBJ=cstdio.o common.o exopen.o goodies.o locking.o \
|
||||
+ mailfold.o foldinfo.o misc.o pipes.o regexp.o robust.o \
|
||||
+ sublib.o acommon.o mcommon.o lastdirsep.o authenticate.o \
|
||||
+ lmtp.o memblk.o variables.o from.o comsat.o
|
||||
+
|
||||
+FM_OBJ=common.o fields.o formisc.o sublib.o ecommon.o \
|
||||
+ acommon.o
|
||||
+
|
||||
+LDFLAGS = -lm -lnsl -ldl -lc
|
||||
+CFLAGS = -Os -DPROCMAIL
|
||||
+
|
||||
+all: procmail formail
|
||||
+
|
||||
+procmail: procmail.o $(PM_OBJ)
|
||||
+ $(CC) $(CFLAGS) $@.o $(PM_OBJ) -o $@ $(LDFLAGS)
|
||||
+
|
||||
+formail: formail.o $(FM_OBJ)
|
||||
+ $(CC) $(CFLAGS) $@.o $(FM_OBJ) -o $@ $(LDFLAGS)
|
Loading…
Reference in a new issue