oprofile: update to 0.9.9, fix compile error
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41035
This commit is contained in:
parent
b1c3bf7cf0
commit
5d680ffda8
4 changed files with 33 additions and 76 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=oprofile
|
||||
PKG_VERSION:=0.9.7
|
||||
PKG_VERSION:=0.9.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/oprofile/
|
||||
PKG_MD5SUM:=8b5d1d9b65f84420bcc3234777ad3be3
|
||||
PKG_MD5SUM:=00aec1287da2dfffda17a9b1c0a01868
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/utils/opcontrol
|
||||
+++ b/utils/opcontrol
|
||||
@@ -248,7 +248,7 @@ load_module_26()
|
||||
@@ -249,7 +249,7 @@ load_module_26()
|
||||
{
|
||||
grep oprofilefs /proc/filesystems >/dev/null
|
||||
if test "$?" -ne 0; then
|
||||
|
@ -9,12 +9,3 @@
|
|||
if test "$?" != "0"; then
|
||||
# couldn't load the module
|
||||
return
|
||||
@@ -278,7 +278,7 @@ load_module_24()
|
||||
{
|
||||
grep oprof /proc/devices >/dev/null
|
||||
if test "$?" -ne 0; then
|
||||
- modprobe oprofile
|
||||
+ insmod oprofile
|
||||
if test "$?" != "0"; then
|
||||
# couldn't load a module
|
||||
return
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
--- a/daemon/Makefile.am
|
||||
+++ b/daemon/Makefile.am
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = liblegacy .
|
||||
+SUBDIRS = .
|
||||
|
||||
oprofiled_SOURCES = \
|
||||
init.c \
|
||||
@@ -49,7 +49,6 @@ AM_CFLAGS = @OP_CFLAGS@ -fno-omit-frame-
|
||||
bin_PROGRAMS = oprofiled
|
||||
|
||||
oprofiled_LDADD = \
|
||||
- liblegacy/liblegacy.a \
|
||||
../libabi/libabi.a \
|
||||
../libdb/libodb.a \
|
||||
../libop/libop.a \
|
||||
--- a/daemon/Makefile.in
|
||||
+++ b/daemon/Makefile.in
|
||||
@@ -70,7 +70,7 @@ am_oprofiled_OBJECTS = init.$(OBJEXT) op
|
||||
opd_extended.$(OBJEXT) opd_ibs.$(OBJEXT) \
|
||||
opd_ibs_trans.$(OBJEXT)
|
||||
oprofiled_OBJECTS = $(am_oprofiled_OBJECTS)
|
||||
-oprofiled_DEPENDENCIES = liblegacy/liblegacy.a ../libabi/libabi.a \
|
||||
+oprofiled_DEPENDENCIES = ../libabi/libabi.a \
|
||||
../libdb/libodb.a ../libop/libop.a ../libutil/libutil.a
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
@@ -285,7 +285,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
topdir = @topdir@
|
||||
-SUBDIRS = liblegacy .
|
||||
+SUBDIRS = .
|
||||
oprofiled_SOURCES = \
|
||||
init.c \
|
||||
oprofiled.c \
|
||||
@@ -331,7 +331,6 @@ AM_CPPFLAGS = \
|
||||
# -fno-omit-frame-pointer needed for daemon build: see ChangeLog-2004 02-23
|
||||
AM_CFLAGS = @OP_CFLAGS@ -fno-omit-frame-pointer
|
||||
oprofiled_LDADD = \
|
||||
- liblegacy/liblegacy.a \
|
||||
../libabi/libabi.a \
|
||||
../libdb/libodb.a \
|
||||
../libop/libop.a \
|
||||
--- a/daemon/oprofiled.c
|
||||
+++ b/daemon/oprofiled.c
|
||||
@@ -77,7 +77,6 @@ static char * events;
|
||||
static char * ext_feature;
|
||||
static int showvers;
|
||||
static struct oprofiled_ops * opd_ops;
|
||||
-extern struct oprofiled_ops opd_24_ops;
|
||||
extern struct oprofiled_ops opd_26_ops;
|
||||
|
||||
#define OPD_IMAGE_FILTER_HASH_SIZE 32
|
||||
@@ -477,9 +476,6 @@ static void opd_options(int argc, char c
|
||||
static struct oprofiled_ops * get_ops(void)
|
||||
{
|
||||
switch (op_get_interface()) {
|
||||
- case OP_INTERFACE_24:
|
||||
- printf("Using 2.4 OProfile kernel interface.\n");
|
||||
- return &opd_24_ops;
|
||||
case OP_INTERFACE_26:
|
||||
printf("Using 2.6+ OProfile kernel interface.\n");
|
||||
return &opd_26_ops;
|
30
package/devel/oprofile/patches/110-fix_compile_error.patch
Normal file
30
package/devel/oprofile/patches/110-fix_compile_error.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- a/libop/op_cpu_type.c
|
||||
+++ b/libop/op_cpu_type.c
|
||||
@@ -250,6 +250,7 @@ static void release_at_hw_platform(void)
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef PPC64
|
||||
static op_cpu _try_ppc64_arch_generic_cpu(void)
|
||||
{
|
||||
const char * platform, * base_platform;
|
||||
@@ -312,6 +313,7 @@ static op_cpu _get_ppc64_cpu_type(void)
|
||||
cpu_type = op_get_cpu_number(cpu_type_str);
|
||||
return cpu_type;
|
||||
}
|
||||
+#endif
|
||||
|
||||
static op_cpu _get_arm_cpu_type(void)
|
||||
{
|
||||
@@ -592,9 +594,11 @@ static op_cpu __get_cpu_type_alt_method(
|
||||
fnmatch("i?86", uname_info.machine, 0) == 0) {
|
||||
return _get_x86_64_cpu_type();
|
||||
}
|
||||
+#ifdef PPC64
|
||||
if (strncmp(uname_info.machine, "ppc64", 5) == 0) {
|
||||
return _get_ppc64_cpu_type();
|
||||
}
|
||||
+#endif
|
||||
if (strncmp(uname_info.machine, "arm", 3) == 0) {
|
||||
return _get_arm_cpu_type();
|
||||
}
|
Loading…
Reference in a new issue