reorder, rename and refresh patches

SVN-Revision: 34169
This commit is contained in:
Imre Kaloz 2012-11-12 09:18:00 +00:00
parent 77504ac06f
commit 5cddb170cd
22 changed files with 25 additions and 36 deletions

View file

@ -1,6 +1,6 @@
--- a/arch/arm/mach-cns3xxx/core.c
+++ b/arch/arm/mach-cns3xxx/core.c
@@ -31,17 +31,7 @@ static struct map_desc cns3xxx_io_desc[]
@@ -24,17 +24,7 @@ static struct map_desc cns3xxx_io_desc[]
{
.virtual = CNS3XXX_TC11MP_TWD_BASE_VIRT,
.pfn = __phys_to_pfn(CNS3XXX_TC11MP_TWD_BASE),

View file

@ -33,7 +33,7 @@
static struct map_desc cns3xxx_io_desc[] __initdata = {
{
.virtual = CNS3XXX_TC11MP_TWD_BASE_VIRT,
@@ -287,3 +294,33 @@ void __init cns3xxx_l2x0_init(void)
@@ -277,3 +284,33 @@ void __init cns3xxx_l2x0_init(void)
}
#endif /* CONFIG_CACHE_L2X0 */

View file

@ -1,6 +1,6 @@
--- a/arch/arm/mach-cns3xxx/core.c
+++ b/arch/arm/mach-cns3xxx/core.c
@@ -59,6 +59,16 @@ static struct map_desc cns3xxx_io_desc[]
@@ -58,6 +58,16 @@ static struct map_desc cns3xxx_io_desc[]
.pfn = __phys_to_pfn(CNS3XXX_PM_BASE),
.length = SZ_4K,
.type = MT_DEVICE,

View file

@ -1,6 +1,6 @@
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -374,6 +374,7 @@ config ARCH_CNS3XXX
@@ -373,6 +373,7 @@ config ARCH_CNS3XXX
select MIGHT_HAVE_PCI
select PCI_DOMAINS if PCI
select HAVE_SMP
@ -55,10 +55,10 @@
--- a/arch/arm/mach-cns3xxx/Makefile
+++ b/arch/arm/mach-cns3xxx/Makefile
@@ -2,6 +2,6 @@ obj-$(CONFIG_ARCH_CNS3XXX) += core.o pm
@@ -1,6 +1,6 @@
obj-$(CONFIG_ARCH_CNS3XXX) += core.o pm.o devices.o
obj-$(CONFIG_PCI) += pcie.o
obj-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
obj-$(CONFIG_MACH_GW2388) += laguna.o
-obj-$(CONFIG_SMP) += platsmp.o headsmp.o
+obj-$(CONFIG_SMP) += platsmp.o headsmp.o cns3xxx_fiq.o
obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o

View file

@ -8,7 +8,7 @@
#include <asm/hardware/cache-l2x0.h>
#include <mach/cns3xxx.h>
#include "core.h"
@@ -63,6 +64,9 @@ static struct map_desc cns3xxx_io_desc[]
@@ -73,6 +74,9 @@ static struct map_desc cns3xxx_io_desc[]
void __init cns3xxx_map_io(void)
{

View file

@ -1,6 +1,6 @@
--- a/arch/arm/mach-cns3xxx/core.c
+++ b/arch/arm/mach-cns3xxx/core.c
@@ -70,6 +70,16 @@ static struct map_desc cns3xxx_io_desc[]
@@ -69,6 +69,16 @@ static struct map_desc cns3xxx_io_desc[]
.pfn = __phys_to_pfn(CNS3XXX_SSP_BASE),
.length = SZ_4K,
.type = MT_DEVICE,
@ -17,7 +17,7 @@
},
};
@@ -145,13 +155,13 @@ void __init cns3xxx_common_init(void)
@@ -83,13 +93,13 @@ void __init cns3xxx_map_io(void)
/* used by entry-macro.S */
void __init cns3xxx_init_irq(void)
{
@ -34,7 +34,7 @@
u32 clkctrl;
printk(KERN_INFO "powering system down...\n");
@@ -325,7 +335,7 @@ static void __init __cns3xxx_timer_init(
@@ -248,7 +258,7 @@ static void __init __cns3xxx_timer_init(
static void __init cns3xxx_timer_init(void)
{
@ -75,14 +75,3 @@
#define __mem_pci(a) (a)
#endif
--- a/drivers/spi/spi_cns3xxx.c
+++ b/drivers/spi/spi_cns3xxx.c
@@ -273,7 +273,7 @@ done:
static void __init cns3xxx_spi_initial(void)
{
- u32 __iomem *gpiob = __io(CNS3XXX_MISC_BASE_VIRT + 0x0018);
+ u32 __iomem *gpiob = (void __iomem *) (CNS3XXX_MISC_BASE_VIRT + 0x0018);
u32 gpiob_pins = __raw_readl(gpiob);
/* MMC/SD pins share with GPIOA */

View file

@ -1,9 +1,9 @@
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
@@ -218,11 +218,21 @@ static struct map_desc cns3420_io_desc[]
@@ -214,11 +214,21 @@ static struct map_desc cns3420_io_desc[]
static void __init cns3420_map_io(void)
{
cns3xxx_common_init();
cns3xxx_map_io();
+ cns3xxx_pcie_iotable_init();
iotable_init(cns3420_io_desc, ARRAY_SIZE(cns3420_io_desc));
@ -35,7 +35,7 @@
void __init cns3xxx_l2x0_init(void);
@@ -21,6 +23,7 @@ static inline void cns3xxx_l2x0_init(voi
void __init cns3xxx_common_init(void);
void __init cns3xxx_map_io(void);
void __init cns3xxx_init_irq(void);
+int __init cns3xxx_pcie_init(void);
void cns3xxx_power_off(void);

View file

@ -1,6 +1,6 @@
--- a/arch/arm/mach-cns3xxx/core.c
+++ b/arch/arm/mach-cns3xxx/core.c
@@ -115,12 +115,13 @@ static void cns3xxx_timer_set_mode(enum
@@ -125,12 +125,13 @@ static void cns3xxx_timer_set_mode(enum
switch (mode) {
case CLOCK_EVT_MODE_PERIODIC:
@ -15,7 +15,7 @@
ctrl |= (1 << 2) | (1 << 9);
break;
case CLOCK_EVT_MODE_UNUSED:
@@ -145,11 +146,11 @@ static int cns3xxx_timer_set_next_event(
@@ -155,11 +156,11 @@ static int cns3xxx_timer_set_next_event(
static struct clock_event_device cns3xxx_tmr1_clockevent = {
.name = "cns3xxx timer1",
@ -29,7 +29,7 @@
.cpumask = cpu_all_mask,
};
@@ -191,6 +192,35 @@ static struct irqaction cns3xxx_timer_ir
@@ -201,6 +202,35 @@ static struct irqaction cns3xxx_timer_ir
.handler = cns3xxx_timer_interrupt,
};
@ -65,7 +65,7 @@
/*
* Set up the clock source and clock events devices
*/
@@ -208,13 +238,12 @@ static void __init __cns3xxx_timer_init(
@@ -218,13 +248,12 @@ static void __init __cns3xxx_timer_init(
/* stop free running timer3 */
writel(0, cns3xxx_tmr1 + TIMER_FREERUN_CONTROL_OFFSET);
@ -82,7 +82,7 @@
/* mask irq, non-mask timer1 overflow */
irq_mask = readl(cns3xxx_tmr1 + TIMER1_2_INTERRUPT_MASK_OFFSET);
irq_mask &= ~(1 << 2);
@@ -226,23 +255,9 @@ static void __init __cns3xxx_timer_init(
@@ -236,23 +265,9 @@ static void __init __cns3xxx_timer_init(
val |= (1 << 9);
writel(val, cns3xxx_tmr1 + TIMER1_2_CONTROL_OFFSET);

View file

@ -6,9 +6,9 @@
{
- cns3xxx_map_io();
+ cns3xxx_common_init();
cns3xxx_pcie_iotable_init();
iotable_init(cns3420_io_desc, ARRAY_SIZE(cns3420_io_desc));
cns3420_early_serial_setup();
--- a/arch/arm/mach-cns3xxx/core.c
+++ b/arch/arm/mach-cns3xxx/core.c
@@ -21,6 +21,7 @@
@ -19,7 +19,7 @@
#include <mach/cns3xxx.h>
#include "core.h"
@@ -72,12 +73,73 @@ static struct map_desc cns3xxx_io_desc[]
@@ -82,12 +83,73 @@ static struct map_desc cns3xxx_io_desc[]
},
};
@ -96,15 +96,15 @@
/* used by entry-macro.S */
--- a/arch/arm/mach-cns3xxx/core.h
+++ b/arch/arm/mach-cns3xxx/core.h
@@ -19,7 +19,7 @@ void __init cns3xxx_l2x0_init(void);
@@ -21,7 +21,7 @@ void __init cns3xxx_l2x0_init(void);
static inline void cns3xxx_l2x0_init(void) {}
#endif /* CONFIG_CACHE_L2X0 */
-void __init cns3xxx_map_io(void);
+void __init cns3xxx_common_init(void);
void __init cns3xxx_init_irq(void);
int __init cns3xxx_pcie_init(void);
void cns3xxx_power_off(void);
void cns3xxx_restart(char, const char *);
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -366,6 +366,7 @@ config ARCH_CLPS711X

View file

@ -5,7 +5,7 @@
+obj-$(CONFIG_ARCH_CNS3XXX) += core.o gpio.o pm.o devices.o
obj-$(CONFIG_PCI) += pcie.o
obj-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
obj-$(CONFIG_MACH_GW2388) += laguna.o
obj-$(CONFIG_SMP) += platsmp.o headsmp.o cns3xxx_fiq.o
--- a/arch/arm/mach-cns3xxx/cns3420vb.c
+++ b/arch/arm/mach-cns3xxx/cns3420vb.c
@@ -198,6 +198,10 @@ static void __init cns3420_init(void)

View file

@ -16,11 +16,11 @@
--- a/arch/arm/mach-cns3xxx/Makefile
+++ b/arch/arm/mach-cns3xxx/Makefile
@@ -1,6 +1,7 @@
obj-$(CONFIG_ARCH_CNS3XXX) += core.o pm.o devices.o
obj-$(CONFIG_ARCH_CNS3XXX) += core.o gpio.o pm.o devices.o
obj-$(CONFIG_PCI) += pcie.o
obj-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
+obj-$(CONFIG_MACH_GW2388) += laguna.o
obj-$(CONFIG_SMP) += platsmp.o headsmp.o
obj-$(CONFIG_SMP) += platsmp.o headsmp.o cns3xxx_fiq.o
obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
obj-$(CONFIG_LOCAL_TIMERS) += localtimer.o
--- a/arch/arm/mach-cns3xxx/devices.c