fixes commit 18128, wrong patch :)
SVN-Revision: 18129
This commit is contained in:
parent
d95163658c
commit
5b2c123b60
2 changed files with 29 additions and 30 deletions
29
target/linux/ramips/patches-2.6.30/103-ethernet.patch
Normal file
29
target/linux/ramips/patches-2.6.30/103-ethernet.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
Index: linux-2.6.30.5/drivers/net/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Kconfig 2009-09-04 16:13:12.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Kconfig 2009-09-04 16:19:05.000000000 +0200
|
||||
@@ -612,6 +612,12 @@
|
||||
If you have an Alchemy Semi AU1X00 based system
|
||||
say Y. Otherwise, say N.
|
||||
|
||||
+config MIPS_RAMIPS_NET
|
||||
+ tristate "Ethernet driver for rt288x/rt305x"
|
||||
+ depends on MIPS_RALINK
|
||||
+ help
|
||||
+ This driver supports the etehrnet mac inside the ralink wisocs
|
||||
+
|
||||
config SGI_IOC3_ETH
|
||||
bool "SGI IOC3 Ethernet"
|
||||
depends on PCI && SGI_IP27
|
||||
Index: linux-2.6.30.5/drivers/net/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/net/Makefile 2009-09-04 16:13:08.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/net/Makefile 2009-09-04 16:16:34.000000000 +0200
|
||||
@@ -204,6 +204,7 @@
|
||||
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
|
||||
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
|
||||
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
|
||||
+obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
|
||||
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
|
||||
obj-$(CONFIG_DECLANCE) += declance.o
|
||||
obj-$(CONFIG_ATARILANCE) += atarilance.o
|
|
@ -1,30 +0,0 @@
|
|||
Index: linux-2.6.30.5/drivers/watchdog/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-04 15:19:34.000000000 +0200
|
||||
@@ -764,6 +764,13 @@
|
||||
help
|
||||
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
||||
|
||||
+config RAMIPS_WDT
|
||||
+ tristate "Ralink Watchdog Timer"
|
||||
+ depends on MIPS_RALINK
|
||||
+ help
|
||||
+ Hardware driver for the built-in watchdog timer on Ralink MIPS SoCs.
|
||||
+
|
||||
+
|
||||
# PARISC Architecture
|
||||
|
||||
# POWERPC Architecture
|
||||
Index: linux-2.6.30.5/drivers/watchdog/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
|
||||
+++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-04 15:19:34.000000000 +0200
|
||||
@@ -105,6 +105,7 @@
|
||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
||||
+obj-$(CONFIG_RAMIPS_WDT) += ramipswdt.o
|
||||
|
||||
# PARISC Architecture
|
||||
|
Loading…
Reference in a new issue