parent
6340d8c27d
commit
5a6e1f631a
2 changed files with 20 additions and 6 deletions
|
@ -3,9 +3,9 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=hostapd
|
PKG_NAME:=hostapd
|
||||||
PKG_VERSION:=0.5.1
|
PKG_VERSION:=0.5.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=3e38533604187e291f45a2f6873b71cc
|
PKG_MD5SUM:=b7f4739ca4758798f8dc3b1ea9fd00d0
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
|
Common subdirectories: hostapd-0.5.2/logwatch and hostapd-0.5.2.new/logwatch
|
||||||
--- hostapd-0.3.9-old/Makefile 2005-06-11 05:03:36.000000000 +0200
|
diff -u hostapd-0.5.2/Makefile hostapd-0.5.2.new/Makefile
|
||||||
+++ hostapd-0.3.9-new/Makefile 2005-08-14 08:09:52.000000000 +0200
|
--- hostapd-0.5.2/Makefile 2006-03-20 03:20:09.000000000 +0000
|
||||||
|
+++ hostapd-0.5.2.new/Makefile 2006-03-21 22:25:23.803473592 +0000
|
||||||
@@ -3,7 +3,7 @@
|
@@ -3,7 +3,7 @@
|
||||||
DIR_HOSTAP=.
|
DIR_HOSTAP=.
|
||||||
|
|
||||||
|
@ -10,7 +11,7 @@ diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
|
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
|
||||||
@@ -173,7 +173,7 @@
|
@@ -266,7 +266,7 @@
|
||||||
for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
|
for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
|
||||||
|
|
||||||
hostapd: $(OBJS)
|
hostapd: $(OBJS)
|
||||||
|
@ -19,3 +20,16 @@ diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
|
||||||
|
|
||||||
driver_conf.c: Makefile .config
|
driver_conf.c: Makefile .config
|
||||||
rm -f driver_conf.c
|
rm -f driver_conf.c
|
||||||
|
@@ -330,10 +330,10 @@
|
||||||
|
endif
|
||||||
|
|
||||||
|
nt_password_hash: $(NOBJS)
|
||||||
|
- $(CC) -o nt_password_hash $(NOBJS) $(LIBS_n)
|
||||||
|
+ $(CC) -o nt_password_hash $(NOBJS) $(LDFLAGS) $(LIBS_n)
|
||||||
|
|
||||||
|
hlr_auc_gw: $(HOBJS)
|
||||||
|
- $(CC) -o hlr_auc_gw $(HOBJS) $(LIBS_h)
|
||||||
|
+ $(CC) -o hlr_auc_gw $(HOBJS) $(LDFLAGS) $(LIBS_h)
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f core *~ *.o hostapd hostapd_cli nt_password_hash hlr_auc_gw
|
||||||
|
|
Loading…
Reference in a new issue