lua: switch to double precision for floats
SVN-Revision: 23284
This commit is contained in:
parent
be844a7783
commit
59cf671160
3 changed files with 23 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=lua
|
||||
PKG_VERSION:=5.1.4
|
||||
PKG_RELEASE:=6
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
|
||||
|
|
11
package/lua/patches-host/011-lnum-use-double.patch
Normal file
11
package/lua/patches-host/011-lnum-use-double.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/lnum_config.h
|
||||
+++ b/src/lnum_config.h
|
||||
@@ -11,7 +11,7 @@
|
||||
** Default number modes
|
||||
*/
|
||||
#if (!defined LNUM_DOUBLE) && (!defined LNUM_FLOAT) && (!defined LNUM_LDOUBLE)
|
||||
-# define LNUM_FLOAT
|
||||
+# define LNUM_DOUBLE
|
||||
#endif
|
||||
#if (!defined LNUM_INT16) && (!defined LNUM_INT32) && (!defined LNUM_INT64)
|
||||
# define LNUM_INT32
|
11
package/lua/patches/011-lnum-use-double.patch
Normal file
11
package/lua/patches/011-lnum-use-double.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/lnum_config.h
|
||||
+++ b/src/lnum_config.h
|
||||
@@ -11,7 +11,7 @@
|
||||
** Default number modes
|
||||
*/
|
||||
#if (!defined LNUM_DOUBLE) && (!defined LNUM_FLOAT) && (!defined LNUM_LDOUBLE)
|
||||
-# define LNUM_FLOAT
|
||||
+# define LNUM_DOUBLE
|
||||
#endif
|
||||
#if (!defined LNUM_INT16) && (!defined LNUM_INT32) && (!defined LNUM_INT64)
|
||||
# define LNUM_INT32
|
Loading…
Reference in a new issue