gdb: update to the latest version, fixes a build error with gcc 5.2
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46775
This commit is contained in:
parent
86ba95601a
commit
55a76c19b1
5 changed files with 7 additions and 93 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gdb
|
||||
PKG_VERSION:=7.8
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=7.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/gdb
|
||||
PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
|
||||
PKG_MD5SUM:=2a35bac41fa8e10bf04f3a0dd7f7f363
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -2,7 +2,7 @@ See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
|
|||
---
|
||||
--- a/gdb/common/signals.c
|
||||
+++ b/gdb/common/signals.c
|
||||
@@ -350,6 +350,11 @@ gdb_signal_from_host (int hostsig)
|
||||
@@ -344,6 +344,11 @@ gdb_signal_from_host (int hostsig)
|
||||
else if (64 <= hostsig && hostsig <= 127)
|
||||
return (enum gdb_signal)
|
||||
(hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64);
|
||||
|
|
|
@ -8,9 +8,9 @@
|
|||
#include "defs.h"
|
||||
#include "inferior.h"
|
||||
#include "infrun.h"
|
||||
@@ -81,6 +82,10 @@
|
||||
@@ -73,6 +74,10 @@
|
||||
#define SPUFS_MAGIC 0x23c9b64e
|
||||
#endif
|
||||
#endif /* HAVE_PERSONALITY */
|
||||
|
||||
+#ifndef __SIGRTMIN
|
||||
+#define __SIGRTMIN SIGRTMIN
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
This patch fixes a build error on arm:
|
||||
|
||||
arm-openwrt-linux-uclibcgnueabi-gcc -DHAVE_CONFIG_H -DPROFILE=1 -DWITH_PROFILE=-1 -DDEFAULT_INLINE=0 -DMODET -DNEED_UI_LOOP_HOOK -DSIM_TARGET_SWITCHES -I. -I. -I../common -I./../common -I../../include -I./../../include -I../../bfd -I./../../bfd -I../../opcodes -I./../../opcodes -Os -pipe -march=armv7-a -mtune=cortex-a8 -mfpu=vfpv3-d16 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -mfloat-abi=hard -static-libstdc++ -static-libgcc -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/target-arm_cortex-a8+vfpv3_uClibc-0.9.33.2_eabi/usr/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/target-arm_cortex-a8+vfpv3_uClibc-0.9.33.2_eabi/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/toolchain-arm_cortex-a8+vfpv3_gcc-4.8-linaro_uClibc-0.9.33.2_eabi/usr/lib -L/fun/Projects/OpenWrt/dev/openwrt-core-2/staging_dir/toolchain-arm_cortex-a8+vfpv3_gcc-4.8-linaro_uClibc-0.9.33.2_eabi/lib -o run \
|
||||
run.o libsim.a ../../bfd/libbfd.a ../../opcodes/libopcodes.a ../../libiberty/libiberty.a -lz -lnsl
|
||||
../../libiberty/libiberty.a(floatformat.o): In function `floatformat_to_double':
|
||||
floatformat.c:(.text+0x454): undefined reference to `ldexp'
|
||||
floatformat.c:(.text+0x4a4): undefined reference to `ldexp'
|
||||
../../libiberty/libiberty.a(floatformat.o): In function `floatformat_from_double':
|
||||
floatformat.c:(.text+0x5dc): undefined reference to `frexp'
|
||||
floatformat.c:(.text+0x644): undefined reference to `ldexp'
|
||||
collect2: error: ld returned 1 exit status
|
||||
|
||||
--- a/sim/arm/Makefile.in
|
||||
+++ b/sim/arm/Makefile.in
|
||||
@@ -18,6 +18,7 @@
|
||||
## COMMON_PRE_CONFIG_FRAG
|
||||
|
||||
SIM_EXTRA_CFLAGS = -DMODET -DNEED_UI_LOOP_HOOK -DSIM_TARGET_SWITCHES
|
||||
+SIM_EXTRA_LIBS = -lm
|
||||
|
||||
COPRO=@COPRO@
|
||||
|
|
@ -1,64 +0,0 @@
|
|||
diff -u -r -N gdb-7.3.1-org//gdb/amd64-linux-nat.c gdb-7.3.1-patched//gdb/amd64-linux-nat.c
|
||||
--- gdb-7.3.1-org//gdb/amd64-linux-nat.c 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.3.1-patched//gdb/amd64-linux-nat.c 2011-09-22 22:20:23.438841813 +0000
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "elf/common.h"
|
||||
#include <sys/uio.h>
|
||||
#include <sys/ptrace.h>
|
||||
-#include <sys/debugreg.h>
|
||||
+#include "debugreg.h"
|
||||
#include <sys/syscall.h>
|
||||
#include <sys/procfs.h>
|
||||
#include <asm/prctl.h>
|
||||
diff -u -r -N gdb-7.3.1-org//gdb/debugreg.h gdb-7.3.1-patched//gdb/debugreg.h
|
||||
--- gdb-7.3.1-org//gdb/debugreg.h 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.3.1-patched//gdb/debugreg.h 2011-09-22 22:20:01.381841813 +0000
|
||||
@@ -0,0 +1,48 @@
|
||||
+#ifndef SYS_DEBUGREG_H
|
||||
+#define SYS_DEBUGREG_H
|
||||
+
|
||||
+#include <stdint.h>
|
||||
+
|
||||
+#define DR_FIRSTADDR 0
|
||||
+#define DR_LASTADDR 3
|
||||
+
|
||||
+#define DR_STATUS 6
|
||||
+#define DR_CONTROL 7
|
||||
+
|
||||
+#define DR_TRAP0 (0x1)
|
||||
+#define DR_TRAP1 (0x2)
|
||||
+#define DR_TRAP2 (0x4)
|
||||
+#define DR_TRAP3 (0x8)
|
||||
+
|
||||
+#define DR_STEP (0x4000)
|
||||
+#define DR_SWITCH (0x8000)
|
||||
+
|
||||
+#define DR_CONTROL_SHIFT 16
|
||||
+#define DR_CONTROL_SIZE 4
|
||||
+
|
||||
+#define DR_RW_EXECUTE (0x0)
|
||||
+#define DR_RW_WRITE (0x1)
|
||||
+#define DR_RW_READ (0x3)
|
||||
+
|
||||
+#define DR_LEN_1 (0x0)
|
||||
+#define DR_LEN_2 (0x4)
|
||||
+#define DR_LEN_4 (0xC)
|
||||
+#define DR_LEN_8 (0x8)
|
||||
+
|
||||
+#define DR_LOCAL_ENABLE_SHIFT 0
|
||||
+#define DR_GLOBAL_ENABLE_SHIFT 1
|
||||
+#define DR_ENABLE_SIZE 2
|
||||
+
|
||||
+#define DR_LOCAL_ENABLE_MASK (0x55)
|
||||
+#define DR_GLOBAL_ENABLE_MASK (0xAA)
|
||||
+
|
||||
+
|
||||
+#if SIZE_MAX > 4294967295
|
||||
+# define DR_CONTROL_RESERVED (0xFFFFFFFF0000FC00UL)
|
||||
+#else
|
||||
+# define DR_CONTROL_RESERVED (0x00FC00U)
|
||||
+#endif
|
||||
+#define DR_LOCAL_SLOWDOWN (0x100)
|
||||
+#define DR_GLOBAL_SLOWDOWN (0x200)
|
||||
+
|
||||
+#endif
|
Loading…
Reference in a new issue