iproute2: update to 4.19.0
Update to the latest version of iproute2; see https://lwn.net/Articles/769354/ for a full overview of the changes in 4.19. Remove 190-add-cake-to-tc patch as CAKE qdisc is now supported in 4.19.0 Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
68b43270f9
commit
559635dbb6
5 changed files with 9 additions and 1671 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=iproute2
|
PKG_NAME:=iproute2
|
||||||
PKG_VERSION:=4.18.0
|
PKG_VERSION:=4.19.0
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||||
PKG_HASH:=a9e6c70c95f513871c5e1f4e452c04fcb3c4d8a05be651bd794cd994a52daa45
|
PKG_HASH:=d9ec5ca1f47d8a85416fa26e7dc1cbf5d067640eb60e90bdc1c7e5bdc6a29984
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=iptables
|
PKG_BUILD_DEPENDS:=iptables
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
--- a/tc/q_fifo.c
|
--- a/tc/q_fifo.c
|
||||||
+++ b/tc/q_fifo.c
|
+++ b/tc/q_fifo.c
|
||||||
@@ -97,5 +97,6 @@ struct qdisc_util pfifo_head_drop_qdisc_
|
@@ -99,5 +99,6 @@ struct qdisc_util pfifo_head_drop_qdisc_
|
||||||
extern int prio_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt);
|
|
||||||
struct qdisc_util pfifo_fast_qdisc_util = {
|
struct qdisc_util pfifo_fast_qdisc_util = {
|
||||||
.id = "pfifo_fast",
|
.id = "pfifo_fast",
|
||||||
+ .parse_qopt = fifo_parse_opt,
|
+ .parse_qopt = fifo_parse_opt,
|
||||||
|
|
|
@ -25,7 +25,7 @@
|
||||||
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
|
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
|
||||||
--- a/ip/ip.c
|
--- a/ip/ip.c
|
||||||
+++ b/ip/ip.c
|
+++ b/ip/ip.c
|
||||||
@@ -48,10 +48,16 @@ static void usage(void)
|
@@ -47,10 +47,16 @@ static void usage(void)
|
||||||
fprintf(stderr,
|
fprintf(stderr,
|
||||||
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
|
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
|
||||||
" ip [ -force ] -batch filename\n"
|
" ip [ -force ] -batch filename\n"
|
||||||
|
@ -42,7 +42,7 @@
|
||||||
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
|
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
|
||||||
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
|
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
|
||||||
" -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
|
" -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
|
||||||
@@ -73,32 +79,44 @@ static const struct cmd {
|
@@ -72,32 +78,44 @@ static const struct cmd {
|
||||||
int (*func)(int argc, char **argv);
|
int (*func)(int argc, char **argv);
|
||||||
} cmds[] = {
|
} cmds[] = {
|
||||||
{ "address", do_ipaddr },
|
{ "address", do_ipaddr },
|
||||||
|
@ -89,7 +89,7 @@
|
||||||
{ "help", do_help },
|
{ "help", do_help },
|
||||||
--- a/lib/utils.c
|
--- a/lib/utils.c
|
||||||
+++ b/lib/utils.c
|
+++ b/lib/utils.c
|
||||||
@@ -1010,6 +1010,7 @@ const char *rt_addr_n2a_r(int af, int le
|
@@ -1012,6 +1012,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||||
return inet_ntop(af, addr, buf, buflen);
|
return inet_ntop(af, addr, buf, buflen);
|
||||||
case AF_MPLS:
|
case AF_MPLS:
|
||||||
return mpls_ntop(af, addr, buf, buflen);
|
return mpls_ntop(af, addr, buf, buflen);
|
||||||
|
@ -97,7 +97,7 @@
|
||||||
case AF_IPX:
|
case AF_IPX:
|
||||||
return ipx_ntop(af, addr, buf, buflen);
|
return ipx_ntop(af, addr, buf, buflen);
|
||||||
case AF_DECnet:
|
case AF_DECnet:
|
||||||
@@ -1019,6 +1020,7 @@ const char *rt_addr_n2a_r(int af, int le
|
@@ -1021,6 +1022,7 @@ const char *rt_addr_n2a_r(int af, int le
|
||||||
memcpy(dna.a_addr, addr, 2);
|
memcpy(dna.a_addr, addr, 2);
|
||||||
return dnet_ntop(af, &dna, buf, buflen);
|
return dnet_ntop(af, &dna, buf, buflen);
|
||||||
}
|
}
|
||||||
|
|
|
@ -31,7 +31,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
|
||||||
if (!end || end == arg || *end || res > 255)
|
if (!end || end == arg || *end || res > 255)
|
||||||
--- a/include/uapi/linux/rtnetlink.h
|
--- a/include/uapi/linux/rtnetlink.h
|
||||||
+++ b/include/uapi/linux/rtnetlink.h
|
+++ b/include/uapi/linux/rtnetlink.h
|
||||||
@@ -221,6 +221,7 @@ enum {
|
@@ -228,6 +228,7 @@ enum {
|
||||||
RTN_THROW, /* Not in this table */
|
RTN_THROW, /* Not in this table */
|
||||||
RTN_NAT, /* Translate this address */
|
RTN_NAT, /* Translate this address */
|
||||||
RTN_XRESOLVE, /* Use external resolver */
|
RTN_XRESOLVE, /* Use external resolver */
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue