gcc: don't clobber stamp-bits with a symlink to itself
Several versions of gcc have an issue in libstdc++v3 where the build may clobber stamp-bits with a link to itself. This doesn't manifest itself on all systems. On several Ubuntu systems, this doesn't appear to be a problem, but it is an issue on Fedora 16 systems. To fix the issue, we'll simply filter out stamp-bits from the symlinks to be generated. Note: gcc 4.4.7 is unaffected by this issue, so no fix is necessary there. Signed-off-by: John Szakmeister <john@szakmeister.net> SVN-Revision: 43669
This commit is contained in:
parent
5b16fd1bf8
commit
548d9a008f
3 changed files with 35 additions and 0 deletions
|
@ -0,0 +1,11 @@
|
|||
--- a/libstdc++-v3/include/Makefile.in
|
||||
+++ b/libstdc++-v3/include/Makefile.in
|
||||
@@ -1326,7 +1326,7 @@
|
||||
@$(STAMP) stamp-bits
|
||||
|
||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
||||
- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
|
||||
+ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
|
||||
@$(STAMP) stamp-bits-sup
|
||||
|
||||
stamp-c_base: ${c_base_headers}
|
|
@ -0,0 +1,11 @@
|
|||
--- a/libstdc++-v3/include/Makefile.in
|
||||
+++ b/libstdc++-v3/include/Makefile.in
|
||||
@@ -1342,7 +1342,7 @@
|
||||
@$(STAMP) stamp-bits
|
||||
|
||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
||||
- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
|
||||
+ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
|
||||
@$(STAMP) stamp-bits-sup
|
||||
|
||||
stamp-c_base: ${c_base_headers}
|
|
@ -0,0 +1,13 @@
|
|||
Index: gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in
|
||||
===================================================================
|
||||
--- gcc-linaro-4.9-2014.10.orig/libstdc++-v3/include/Makefile.in 2013-11-16 12:44:48.000000000 -0500
|
||||
+++ gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in 2014-12-02 06:23:02.236660279 -0500
|
||||
@@ -1366,7 +1366,7 @@
|
||||
@$(STAMP) stamp-bits
|
||||
|
||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
||||
- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
|
||||
+ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
|
||||
@$(STAMP) stamp-bits-sup
|
||||
|
||||
stamp-c_base: ${c_base_headers}
|
Loading…
Reference in a new issue