gcc: update gcc 5 to version 5.3.0
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 48826
This commit is contained in:
parent
64fc5264cc
commit
5168d43b16
39 changed files with 30 additions and 65 deletions
|
@ -6,7 +6,7 @@ config GCC_VERSION
|
|||
string
|
||||
default "4.8-linaro" if GCC_VERSION_4_8_LINARO
|
||||
default "arc-2015.06" if GCC_VERSION_4_8_ARC
|
||||
default "5.2.0"
|
||||
default "5.3.0"
|
||||
|
||||
config GCC_VERSION_4_8
|
||||
bool
|
||||
|
|
|
@ -28,8 +28,8 @@ GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|||
PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
||||
ifeq ($(PKG_VERSION),5.2.0)
|
||||
PKG_MD5SUM:=a51bcfeb3da7dd4c623e27207ed43467
|
||||
ifeq ($(PKG_VERSION),5.3.0)
|
||||
PKG_MD5SUM:=c9616fd448f980259c31de613e575719
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
From: nsz <nsz@138bc75d-0d04-0410-961f-82ee72b054a4>
|
||||
Date: Mon, 23 Nov 2015 15:17:55 +0000
|
||||
Subject: [PATCH] [ARM] PR target/68059 libgcc should not use __write for
|
||||
printing fatal error
|
||||
|
||||
libgcc/
|
||||
PR target/68059
|
||||
* config/arm/linux-atomic-64bit.c (__write): Rename to...
|
||||
(write): ...this and fix the return type.
|
||||
|
||||
|
||||
|
||||
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@230762 138bc75d-0d04-0410-961f-82ee72b054a4
|
||||
---
|
||||
|
||||
--- a/libgcc/config/arm/linux-atomic-64bit.c
|
||||
+++ b/libgcc/config/arm/linux-atomic-64bit.c
|
||||
@@ -33,7 +33,7 @@ see the files COPYING3 and COPYING.RUNTI
|
||||
kernels; we check for that in an init section and bail out rather
|
||||
unceremoneously. */
|
||||
|
||||
-extern unsigned int __write (int fd, const void *buf, unsigned int count);
|
||||
+extern int write (int fd, const void *buf, unsigned int count);
|
||||
extern void abort (void);
|
||||
|
||||
/* Kernel helper for compare-and-exchange. */
|
||||
@@ -56,7 +56,7 @@ static void __check_for_sync8_kernelhelp
|
||||
for the user - I'm not sure I can rely on much else being
|
||||
available at this point, so do the same as generic-morestack.c
|
||||
write () and abort (). */
|
||||
- __write (2 /* stderr. */, err, sizeof (err));
|
||||
+ write (2 /* stderr. */, err, sizeof (err));
|
||||
abort ();
|
||||
}
|
||||
};
|
|
@ -217,7 +217,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
+Use musl C library
|
||||
--- a/gcc/configure
|
||||
+++ b/gcc/configure
|
||||
@@ -27742,6 +27742,9 @@ if test "${gcc_cv_libc_provides_ssp+set}
|
||||
@@ -27802,6 +27802,9 @@ if test "${gcc_cv_libc_provides_ssp+set}
|
||||
else
|
||||
gcc_cv_libc_provides_ssp=no
|
||||
case "$target" in
|
||||
|
@ -227,7 +227,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
*-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
|
||||
# glibc 2.4 and later provides __stack_chk_fail and
|
||||
# either __stack_chk_guard, or TLS access to stack guard canary.
|
||||
@@ -27774,6 +27777,7 @@ fi
|
||||
@@ -27834,6 +27837,7 @@ fi
|
||||
# <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
|
||||
# simply assert that glibc does provide this, which is true for all
|
||||
# realistically usable GNU/Hurd configurations.
|
||||
|
@ -235,7 +235,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
gcc_cv_libc_provides_ssp=yes;;
|
||||
*-*-darwin* | *-*-freebsd*)
|
||||
ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
|
||||
@@ -27870,6 +27874,9 @@ case "$target" in
|
||||
@@ -27930,6 +27934,9 @@ case "$target" in
|
||||
gcc_cv_target_dl_iterate_phdr=no
|
||||
fi
|
||||
;;
|
||||
|
@ -247,7 +247,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
||||
--- a/gcc/configure.ac
|
||||
+++ b/gcc/configure.ac
|
||||
@@ -5229,6 +5229,9 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
||||
@@ -5282,6 +5282,9 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
||||
gcc_cv_libc_provides_ssp,
|
||||
[gcc_cv_libc_provides_ssp=no
|
||||
case "$target" in
|
||||
|
@ -257,7 +257,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
*-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
|
||||
# glibc 2.4 and later provides __stack_chk_fail and
|
||||
# either __stack_chk_guard, or TLS access to stack guard canary.
|
||||
@@ -5255,6 +5258,7 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
||||
@@ -5308,6 +5311,7 @@ AC_CACHE_CHECK(__stack_chk_fail in targe
|
||||
# <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
|
||||
# simply assert that glibc does provide this, which is true for all
|
||||
# realistically usable GNU/Hurd configurations.
|
||||
|
@ -265,7 +265,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
gcc_cv_libc_provides_ssp=yes;;
|
||||
*-*-darwin* | *-*-freebsd*)
|
||||
AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
|
||||
@@ -5328,6 +5332,9 @@ case "$target" in
|
||||
@@ -5381,6 +5385,9 @@ case "$target" in
|
||||
gcc_cv_target_dl_iterate_phdr=no
|
||||
fi
|
||||
;;
|
||||
|
@ -286,7 +286,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222904 138bc75d-0d04-0410-961f-8
|
|||
-tno-android-cc -tno-android-ld}
|
||||
|
||||
@emph{H8/300 Options}
|
||||
@@ -15324,13 +15324,19 @@ These @samp{-m} options are defined for
|
||||
@@ -15325,13 +15325,19 @@ These @samp{-m} options are defined for
|
||||
@item -mglibc
|
||||
@opindex mglibc
|
||||
Use the GNU C library. This is the default except
|
|
@ -69,17 +69,17 @@ gcc/Changelog:
|
|||
|
||||
/* Pass -G xxx to the compiler. */
|
||||
#undef CC1_SPEC
|
||||
@@ -586,7 +589,8 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
@@ -574,7 +577,8 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
%{R*} \
|
||||
%(link_shlib) \
|
||||
%{!T*: %(link_start) } \
|
||||
-%(link_os)"
|
||||
+%(link_os)" \
|
||||
+"%{!mbss-plt: %{!msecure-plt: %(link_secure_plt_default)}}"
|
||||
|
||||
/* Override the default target of the linker. */
|
||||
#define LINK_TARGET_SPEC \
|
||||
- ENDIAN_SELECT("", " --oformat elf32-powerpcle", "")
|
||||
+ ENDIAN_SELECT("", " --oformat elf32-powerpcle", "") \
|
||||
+ "%{!mbss-plt: %{!msecure-plt: %(link_secure_plt_default)}}"
|
||||
|
||||
/* Any specific OS flags. */
|
||||
#define LINK_OS_SPEC "\
|
||||
@@ -762,17 +766,22 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
/* Shared libraries are not default. */
|
||||
#define LINK_SHLIB_SPEC "\
|
||||
@@ -757,17 +761,22 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
|
||||
#define LINK_START_LINUX_SPEC ""
|
||||
|
||||
|
@ -105,7 +105,7 @@ gcc/Changelog:
|
|||
|
||||
#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
@@ -895,6 +904,7 @@ ncrtn.o%s"
|
||||
@@ -889,6 +898,7 @@ ncrtn.o%s"
|
||||
{ "link_os_openbsd", LINK_OS_OPENBSD_SPEC }, \
|
||||
{ "link_os_default", LINK_OS_DEFAULT_SPEC }, \
|
||||
{ "cc1_secure_plt_default", CC1_SECURE_PLT_DEFAULT_SPEC }, \
|
||||
|
@ -113,7 +113,7 @@ gcc/Changelog:
|
|||
{ "cpp_os_ads", CPP_OS_ADS_SPEC }, \
|
||||
{ "cpp_os_yellowknife", CPP_OS_YELLOWKNIFE_SPEC }, \
|
||||
{ "cpp_os_mvme", CPP_OS_MVME_SPEC }, \
|
||||
@@ -949,3 +959,72 @@ ncrtn.o%s"
|
||||
@@ -943,3 +953,72 @@ ncrtn.o%s"
|
||||
/* This target uses the sysv4.opt file. */
|
||||
#define TARGET_USES_SYSV4_OPT 1
|
||||
|
||||
|
@ -188,7 +188,7 @@ gcc/Changelog:
|
|||
+#endif
|
||||
--- a/gcc/config/rs6000/sysv4le.h
|
||||
+++ b/gcc/config/rs6000/sysv4le.h
|
||||
@@ -35,3 +35,5 @@
|
||||
@@ -31,3 +31,5 @@
|
||||
/* Little-endian PowerPC64 Linux uses the ELF v2 ABI by default. */
|
||||
#define LINUX64_DEFAULT_ABI_ELFv2
|
||||
|
||||
|
@ -196,7 +196,7 @@ gcc/Changelog:
|
|||
+#define MUSL_DYNAMIC_LINKER_E ENDIAN_SELECT("","le","le")
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -2410,6 +2410,10 @@ powerpc*-*-linux*)
|
||||
@@ -2416,6 +2416,10 @@ powerpc*-*-linux*)
|
||||
powerpc*-*-linux*paired*)
|
||||
tm_file="${tm_file} rs6000/750cl.h" ;;
|
||||
esac
|
|
@ -37,7 +37,7 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@222329 138bc75d-0d04-0410-961f-8
|
|||
;;
|
||||
--- a/libgfortran/configure
|
||||
+++ b/libgfortran/configure
|
||||
@@ -26447,7 +26447,7 @@ $as_echo "#define SUPPORTS_WEAK 1" >>con
|
||||
@@ -26456,7 +26456,7 @@ $as_echo "#define SUPPORTS_WEAK 1" >>con
|
||||
|
||||
fi
|
||||
case "$host" in
|
|
@ -13,7 +13,7 @@
|
|||
#elif DEFAULT_LIBC == LIBC_GLIBC
|
||||
--- a/gcc/config/rs6000/sysv4.h
|
||||
+++ b/gcc/config/rs6000/sysv4.h
|
||||
@@ -770,7 +770,7 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
@@ -765,7 +765,7 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEF
|
||||
|
||||
#define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
|
||||
#define UCLIBC_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
|
|
@ -1,6 +1,6 @@
|
|||
--- a/gcc/config/rs6000/rs6000.c
|
||||
+++ b/gcc/config/rs6000/rs6000.c
|
||||
@@ -21453,7 +21453,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
@@ -21495,7 +21495,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||
/* Define cutoff for using out-of-line functions to save registers. */
|
||||
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
||||
{
|
|
@ -201,7 +201,7 @@
|
|||
@item -Wstack-protector
|
||||
@opindex Wstack-protector
|
||||
@opindex Wno-stack-protector
|
||||
@@ -7844,7 +7860,7 @@ so, the first branch is redirected to ei
|
||||
@@ -7845,7 +7861,7 @@ so, the first branch is redirected to ei
|
||||
second branch or a point immediately following it, depending on whether
|
||||
the condition is known to be true or false.
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- a/libstdc++-v3/include/Makefile.in
|
||||
+++ b/libstdc++-v3/include/Makefile.in
|
||||
@@ -1382,7 +1382,7 @@ stamp-bits: ${bits_headers}
|
||||
@@ -1420,7 +1420,7 @@ stamp-bits: ${bits_headers}
|
||||
@$(STAMP) stamp-bits
|
||||
|
||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
|
@ -64,7 +64,7 @@ Forward ported from attachment to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=4
|
|||
|
||||
@item Machine Dependent Options
|
||||
@xref{Submodel Options,,Hardware Models and Configurations}.
|
||||
@@ -11463,6 +11463,12 @@ be searched for header files only for th
|
||||
@@ -11464,6 +11464,12 @@ be searched for header files only for th
|
||||
"@var{file}"}; they are not searched for @code{#include <@var{file}>},
|
||||
otherwise just like @option{-I}.
|
||||
|
Loading…
Reference in a new issue