quilt: update to 0.60
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38170
This commit is contained in:
parent
948f060014
commit
5166bb0b1b
4 changed files with 12 additions and 38 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006 -2010 OpenWrt.org
|
# Copyright (C) 2006-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=quilt
|
PKG_NAME:=quilt
|
||||||
PKG_VERSION:=0.48
|
PKG_VERSION:=0.60
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
|
PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
|
||||||
PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
|
PKG_MD5SUM:=058a08a9b626bdec9ec8c519dc92158c
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -25,7 +25,7 @@ define Host/Configure
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Compile
|
define Host/Compile
|
||||||
$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all lib/backup-files
|
$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
|
|
|
@ -1,21 +1,21 @@
|
||||||
--- a/bin/quilt.in
|
--- a/bin/quilt.in
|
||||||
+++ b/bin/quilt.in
|
+++ b/bin/quilt.in
|
||||||
@@ -7,9 +7,15 @@
|
@@ -11,9 +11,15 @@
|
||||||
# See the COPYING and AUTHORS files for more details.
|
unset POSIXLY_CORRECT
|
||||||
|
|
||||||
export TEXTDOMAIN=quilt
|
export TEXTDOMAIN=quilt
|
||||||
-export TEXTDOMAINDIR=@LOCALEDIR@
|
-export TEXTDOMAINDIR=@LOCALEDIR@
|
||||||
|
|
||||||
-: ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
|
-: ${QUILT_DIR=@QUILT_DIR@}
|
||||||
+if test -n "$STAGING_DIR"; then
|
+if test -n "$STAGING_DIR"; then
|
||||||
+ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
|
+ export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
|
||||||
+ : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
|
+ : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
|
||||||
+else
|
+else
|
||||||
+ export TEXTDOMAINDIR=@LOCALEDIR@
|
+ export TEXTDOMAINDIR=@LOCALEDIR@
|
||||||
+ : ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
|
+ : ${QUILT_DIR=@QUILT_DIR@}
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
export QUILT_DIR QUILT_LIB
|
export QUILT_DIR
|
||||||
|
|
||||||
if [ -z "$QUILTRC" ]
|
if [ -z "$QUILTRC" ]
|
||||||
--- a/quilt/scripts/edmail.in
|
--- a/quilt/scripts/edmail.in
|
||||||
|
@ -44,20 +44,9 @@
|
||||||
|
|
||||||
if ! [ -r $QUILT_DIR/scripts/patchfns ]
|
if ! [ -r $QUILT_DIR/scripts/patchfns ]
|
||||||
then
|
then
|
||||||
--- a/quilt/scripts/parse-patch.in
|
|
||||||
+++ b/quilt/scripts/parse-patch.in
|
|
||||||
@@ -34,7 +34,7 @@ BEGIN {
|
|
||||||
}
|
|
||||||
|
|
||||||
setlocale(LC_MESSAGES, "");
|
|
||||||
-bindtextdomain("quilt", "@LOCALEDIR@");
|
|
||||||
+bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
|
|
||||||
textdomain("quilt");
|
|
||||||
|
|
||||||
sub _($) {
|
|
||||||
--- a/quilt/scripts/patchfns.in
|
--- a/quilt/scripts/patchfns.in
|
||||||
+++ b/quilt/scripts/patchfns.in
|
+++ b/quilt/scripts/patchfns.in
|
||||||
@@ -10,7 +10,11 @@
|
@@ -8,7 +8,11 @@
|
||||||
# See the COPYING and AUTHORS files for more details.
|
# See the COPYING and AUTHORS files for more details.
|
||||||
|
|
||||||
export TEXTDOMAIN=quilt
|
export TEXTDOMAIN=quilt
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
|
@@ -266,13 +266,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
|
||||||
lib/backup-files.o :: Makefile
|
@$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
|
||||||
|
|
||||||
configure : configure.ac aclocal.m4
|
configure : configure.ac aclocal.m4
|
||||||
- autoconf
|
- autoconf
|
||||||
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -274,7 +274,11 @@ fi
|
|
||||||
AC_MSG_CHECKING([the version of $PATCH])
|
|
||||||
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
|
|
||||||
set -- `$PATCH --version 2> /dev/null`
|
|
||||||
- patch_version=$2
|
|
||||||
+ if test x$1 = xGNU ; then
|
|
||||||
+ patch_version=$3
|
|
||||||
+ else
|
|
||||||
+ patch_version=$2
|
|
||||||
+ fi
|
|
||||||
AC_MSG_RESULT($patch_version)
|
|
||||||
saved_IFS=$IFS; IFS='.'
|
|
||||||
set -- $patch_version
|
|
Loading…
Reference in a new issue