add screen

SVN-Revision: 804
This commit is contained in:
Felix Fietkau 2005-05-05 09:41:38 +00:00
parent 8e4eb8b1d6
commit 483ce623eb
6 changed files with 590 additions and 0 deletions

View file

@ -16,6 +16,7 @@ source "package/monit/Config.in"
source "package/strace/Config.in"
source "package/lcd4linux/Config.in"
source "package/setserial/Config.in"
source "package/screen/Config.in"
comment "Networking"
source "package/tcpdump/Config.in"

View file

@ -55,6 +55,7 @@ package-$(BR2_PACKAGE_PPTP) += pptp
package-$(BR2_PACKAGE_PPTPD) += pptpd
package-$(BR2_PACKAGE_QUAGGA) += quagga
package-$(BR2_PACKAGE_RADVD) += radvd
package-$(BR2_PACKAGE_SCREEN) += screen
package-$(BR2_PACKAGE_SDK) += sdk
package-$(BR2_PACKAGE_SER) += ser
package-$(BR2_PACKAGE_SETSERIAL) += setserial

View file

@ -0,0 +1,6 @@
config BR2_PACKAGE_SCREEN
tristate "screen"
default m if CONFIG_DEVEL
help
Screen is a full-screen window manager that multiplexes a physical
terminal between several processes, typically interactive shells.

View file

@ -0,0 +1,78 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=screen
PKG_VERSION:=4.0.2
PKG_RELEASE:=1
PKG_MD5SUM:=ed68ea9b43d9fba0972cb017a24940a1
PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/screen
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
IPKG_SCREEN:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
IDIR_SCREEN:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)
INFO_SCREEN:=$(IPKG_STATE_DIR)/info/$(PKG_NAME).list
$(DL_DIR)/$(PKG_SOURCE):
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
$(PATCH) $(PKG_BUILD_DIR) ./patches
touch $(PKG_BUILD_DIR)/.prepared
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
);
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC)
$(IPKG_SCREEN): $(PKG_BUILD_DIR)/$(PKG_NAME)
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_SCREEN) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_SCREEN)/usr/sbin
cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_SCREEN)/usr/sbin/
$(STRIP) $(IDIR_SCREEN)/usr/sbin/*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(IDIR_SCREEN) $(PACKAGE_DIR)
$(INFO_SCREEN): $(IPKG_SCREEN)
$(IPKG) install $(IPKG_SCREEN)
source: $(DL_DIR)/$(PKG_SOURCE)
prepare: $(PKG_BUILD_DIR)/.prepared
compile: $(IPKG_SCREEN)
install: $(INFO_SCREEN)
clean:
rm -rf $(PKG_BUILD_DIR) $(IPKG_SCREEN)

View file

@ -0,0 +1,498 @@
Binary files screen-4.0.2.old/.configure.swp and screen-4.0.2.dev/.configure.swp differ
diff -urN screen-4.0.2.old/configure screen-4.0.2.dev/configure
--- screen-4.0.2.old/configure 2003-12-05 14:46:53.000000000 +0100
+++ screen-4.0.2.dev/configure 2005-05-05 12:13:03.000000000 +0200
@@ -124,7 +124,7 @@
fi
if test ! -f "$as_myself"; then
{ echo "$as_me: error: cannot find myself; rerun with an absolute path" >&2
- { (exit 1); exit 1; }; }
+ }
fi
case $CONFIG_SHELL in
'')
@@ -174,7 +174,7 @@
' >$as_me.lineno &&
chmod +x $as_me.lineno ||
{ echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2
- { (exit 1); exit 1; }; }
+ }
# Don't try to exec as it changes $[0], causing all sort of problems
# (the dirname of $[0] is not the place where we might find the
@@ -397,7 +397,7 @@
# Reject names that are not valid shell variable names.
expr "x$ac_feature" : ".*[^-_$as_cr_alnum]" >/dev/null &&
{ echo "$as_me: error: invalid feature name: $ac_feature" >&2
- { (exit 1); exit 1; }; }
+ }
ac_feature=`echo $ac_feature | sed 's/-/_/g'`
eval "enable_$ac_feature=no" ;;
@@ -406,7 +406,7 @@
# Reject names that are not valid shell variable names.
expr "x$ac_feature" : ".*[^-_$as_cr_alnum]" >/dev/null &&
{ echo "$as_me: error: invalid feature name: $ac_feature" >&2
- { (exit 1); exit 1; }; }
+ }
ac_feature=`echo $ac_feature | sed 's/-/_/g'`
case $ac_option in
*=*) ac_optarg=`echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"`;;
@@ -588,7 +588,7 @@
# Reject names that are not valid shell variable names.
expr "x$ac_package" : ".*[^-_$as_cr_alnum]" >/dev/null &&
{ echo "$as_me: error: invalid package name: $ac_package" >&2
- { (exit 1); exit 1; }; }
+ }
ac_package=`echo $ac_package| sed 's/-/_/g'`
case $ac_option in
*=*) ac_optarg=`echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"`;;
@@ -601,7 +601,7 @@
# Reject names that are not valid shell variable names.
expr "x$ac_package" : ".*[^-_$as_cr_alnum]" >/dev/null &&
{ echo "$as_me: error: invalid package name: $ac_package" >&2
- { (exit 1); exit 1; }; }
+ }
ac_package=`echo $ac_package | sed 's/-/_/g'`
eval "with_$ac_package=no" ;;
@@ -625,7 +625,7 @@
-*) { echo "$as_me: error: unrecognized option: $ac_option
Try \`$0 --help' for more information." >&2
- { (exit 1); exit 1; }; }
+ }
;;
*=*)
@@ -633,7 +633,7 @@
# Reject names that are not valid shell variable names.
expr "x$ac_envvar" : ".*[^_$as_cr_alnum]" >/dev/null &&
{ echo "$as_me: error: invalid variable name: $ac_envvar" >&2
- { (exit 1); exit 1; }; }
+ }
ac_optarg=`echo "$ac_optarg" | sed "s/'/'\\\\\\\\''/g"`
eval "$ac_envvar='$ac_optarg'"
export $ac_envvar ;;
@@ -652,7 +652,7 @@
if test -n "$ac_prev"; then
ac_option=--`echo $ac_prev | sed 's/_/-/g'`
{ echo "$as_me: error: missing argument to $ac_option" >&2
- { (exit 1); exit 1; }; }
+ }
fi
# Be sure to have absolute paths.
@@ -662,7 +662,7 @@
case $ac_val in
[\\/$]* | ?:[\\/]* | NONE | '' ) ;;
*) { echo "$as_me: error: expected an absolute directory name for --$ac_var: $ac_val" >&2
- { (exit 1); exit 1; }; };;
+ };;
esac
done
@@ -674,7 +674,7 @@
case $ac_val in
[\\/$]* | ?:[\\/]* ) ;;
*) { echo "$as_me: error: expected an absolute directory name for --$ac_var: $ac_val" >&2
- { (exit 1); exit 1; }; };;
+ };;
esac
done
@@ -728,15 +728,15 @@
if test ! -r $srcdir/$ac_unique_file; then
if test "$ac_srcdir_defaulted" = yes; then
{ echo "$as_me: error: cannot find sources ($ac_unique_file) in $ac_confdir or .." >&2
- { (exit 1); exit 1; }; }
+ }
else
{ echo "$as_me: error: cannot find sources ($ac_unique_file) in $srcdir" >&2
- { (exit 1); exit 1; }; }
+ }
fi
fi
(cd $srcdir && test -r ./$ac_unique_file) 2>/dev/null ||
{ echo "$as_me: error: sources are in $srcdir, but \`cd $srcdir' does not work" >&2
- { (exit 1); exit 1; }; }
+ }
srcdir=`echo "$srcdir" | sed 's%\([^\\/]\)[\\/]*$%\1%'`
ac_env_build_alias_set=${build_alias+set}
ac_env_build_alias_value=$build_alias
@@ -1243,7 +1243,7 @@
echo "$as_me: error: changes in the environment can compromise the build" >&2;}
{ { echo "$as_me:$LINENO: error: run \`make distclean' and/or \`rm $cache_file' and start over" >&5
echo "$as_me: error: run \`make distclean' and/or \`rm $cache_file' and start over" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
ac_ext=c
@@ -1734,7 +1734,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: no acceptable C compiler found in \$PATH
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
# Provide some information about the compiler.
echo "$as_me:$LINENO:" \
@@ -1856,7 +1856,7 @@
echo "$as_me: error: cannot run C compiled programs.
If you meant to cross compile, use \`--host'.
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
fi
fi
@@ -1898,7 +1898,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot compute suffix of executables: cannot compile and link
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f conftest$ac_cv_exeext
@@ -1950,7 +1950,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot compute suffix of object files: cannot compile
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f conftest.$ac_cv_objext conftest.$ac_ext
@@ -2514,7 +2514,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: C preprocessor \"$CPP\" fails sanity check
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
ac_ext=c
@@ -2704,7 +2704,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -2753,7 +2753,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -2790,7 +2790,7 @@
{ { echo "$as_me:$LINENO: error: Can't run the compiler - sorry" >&5
echo "$as_me: error: Can't run the compiler - sorry" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f core core.* *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
fi
@@ -2800,7 +2800,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -2830,7 +2830,7 @@
(exit $ac_status); }; }; then
{ { echo "$as_me:$LINENO: error: Your compiler does not set the exit status - sorry" >&5
echo "$as_me: error: Your compiler does not set the exit status - sorry" >&2;}
- { (exit 1); exit 1; }; }
+ }
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
@@ -2900,7 +2900,7 @@
if test -z "$ac_aux_dir"; then
{ { echo "$as_me:$LINENO: error: cannot find install-sh or install.sh in $srcdir $srcdir/.. $srcdir/../.." >&5
echo "$as_me: error: cannot find install-sh or install.sh in $srcdir $srcdir/.. $srcdir/../.." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
ac_config_guess="$SHELL $ac_aux_dir/config.guess"
ac_config_sub="$SHELL $ac_aux_dir/config.sub"
@@ -4149,7 +4149,7 @@
{ { echo "$as_me:$LINENO: error: !!! no select - no screen" >&5
echo "$as_me: error: !!! no select - no screen" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
@@ -4163,7 +4163,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -4272,7 +4272,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -4365,7 +4365,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -4460,7 +4460,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -4562,7 +4562,7 @@
else
{ { echo "$as_me:$LINENO: error: you have neither usable sockets nor usable pipes -> no screen" >&5
echo "$as_me: error: you have neither usable sockets nor usable pipes -> no screen" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
@@ -4573,7 +4573,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -4898,7 +4898,7 @@
{ { echo "$as_me:$LINENO: error: !!! no tgetent - no screen" >&5
echo "$as_me: error: !!! no tgetent - no screen" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
fi
@@ -4915,7 +4915,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -5359,7 +5356,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -6206,7 +6203,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -6482,7 +6479,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -7004,7 +7001,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -7056,7 +7053,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -7110,7 +7107,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -7951,7 +7948,7 @@
See \`config.log' for more details." >&5
echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ }
else
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
@@ -7982,7 +7979,7 @@
( exit $ac_status )
{ { echo "$as_me:$LINENO: error: Can't run the compiler - internal error. Sorry." >&5
echo "$as_me: error: Can't run the compiler - internal error. Sorry." >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
rm -f core core.* *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
fi
@@ -8251,7 +8248,7 @@
if test ! -f "$as_myself"; then
{ { echo "$as_me:$LINENO: error: cannot find myself; rerun with an absolute path" >&5
echo "$as_me: error: cannot find myself; rerun with an absolute path" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi
case $CONFIG_SHELL in
'')
@@ -8302,7 +8299,7 @@
chmod +x $as_me.lineno ||
{ { echo "$as_me:$LINENO: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&5
echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2;}
- { (exit 1); exit 1; }; }
+ }
# Don't try to exec as it changes $[0], causing all sort of problems
# (the dirname of $[0] is not the place where we might find the
@@ -8494,7 +8491,7 @@
Try \`$0 --help' for more information." >&5
echo "$as_me: error: ambiguous option: $1
Try \`$0 --help' for more information." >&2;}
- { (exit 1); exit 1; }; };;
+ };;
--help | --hel | -h )
echo "$ac_cs_usage"; exit 0 ;;
--debug | --d* | -d )
@@ -8516,7 +8513,7 @@
Try \`$0 --help' for more information." >&5
echo "$as_me: error: unrecognized option: $1
Try \`$0 --help' for more information." >&2;}
- { (exit 1); exit 1; }; } ;;
+ } ;;
*) ac_config_targets="$ac_config_targets $1" ;;
@@ -8555,7 +8552,7 @@
"config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
- { (exit 1); exit 1; }; };;
+ };;
esac
done
@@ -8750,7 +8747,7 @@
test ! -n "$as_dirs" || mkdir $as_dirs
fi || { { echo "$as_me:$LINENO: error: cannot create directory \"$ac_dir\"" >&5
echo "$as_me: error: cannot create directory \"$ac_dir\"" >&2;}
- { (exit 1); exit 1; }; }; }
+ }; }
ac_builddir=.
@@ -8816,7 +8813,7 @@
# Absolute (can't be DOS-style, as IFS=:)
test -f "$f" || { { echo "$as_me:$LINENO: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
- { (exit 1); exit 1; }; }
+ }
echo $f;;
*) # Relative
if test -f "$f"; then
@@ -8829,7 +8826,7 @@
# /dev/null tree
{ { echo "$as_me:$LINENO: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi;;
esac
done` || { (exit 1); exit 1; }
@@ -8907,7 +8904,7 @@
# Absolute (can't be DOS-style, as IFS=:)
test -f "$f" || { { echo "$as_me:$LINENO: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
- { (exit 1); exit 1; }; }
+ }
echo $f;;
*) # Relative
if test -f "$f"; then
@@ -8920,7 +8917,7 @@
# /dev/null tree
{ { echo "$as_me:$LINENO: error: cannot find input file: $f" >&5
echo "$as_me: error: cannot find input file: $f" >&2;}
- { (exit 1); exit 1; }; }
+ }
fi;;
esac
done` || { (exit 1); exit 1; }
@@ -9073,7 +9070,7 @@
test ! -n "$as_dirs" || mkdir $as_dirs
fi || { { echo "$as_me:$LINENO: error: cannot create directory \"$ac_dir\"" >&5
echo "$as_me: error: cannot create directory \"$ac_dir\"" >&2;}
- { (exit 1); exit 1; }; }; }
+ }; }
rm -f $ac_file
mv $tmp/config.h $ac_file
diff -urN screen-4.0.2.old/pty.c screen-4.0.2.dev/pty.c
--- screen-4.0.2.old/pty.c 2003-09-08 16:26:18.000000000 +0200
+++ screen-4.0.2.dev/pty.c 2005-05-05 12:32:20.000000000 +0200
@@ -34,9 +34,9 @@
#endif
/* for solaris 2.1, Unixware (SVR4.2) and possibly others */
-#ifdef HAVE_SVR4_PTYS
-# include <sys/stropts.h>
-#endif
+//#ifdef HAVE_SVR4_PTYS
+//# include <sys/stropts.h>
+//#endif
#if defined(sun) && defined(LOCKPTY) && !defined(TIOCEXCL)
# include <sys/ttold.h>

View file

@ -0,0 +1,6 @@
Package: screen
Priority: optional
Section: net
Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
Source: buildroot internal
Description: A 'window manager' for the terminal session