dropbear: compile with LTO enabled
Reduces size of the .ipk on MIPS from 87k to 84k Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
ef96d1e34a
commit
47b42137ce
2 changed files with 35 additions and 2 deletions
|
@ -86,8 +86,8 @@ CONFIGURE_ARGS += \
|
||||||
$(if $(CONFIG_DROPBEAR_ZLIB),,--disable-zlib) \
|
$(if $(CONFIG_DROPBEAR_ZLIB),,--disable-zlib) \
|
||||||
--enable-bundled-libtom
|
--enable-bundled-libtom
|
||||||
|
|
||||||
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
|
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections
|
TARGET_LDFLAGS += -Wl,--gc-sections -flto=jobserver
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(Build/Configure/Default)
|
$(Build/Configure/Default)
|
||||||
|
|
|
@ -0,0 +1,33 @@
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -163,17 +163,17 @@ dropbearkey: $(dropbearkeyobjs)
|
||||||
|
dropbearconvert: $(dropbearconvertobjs)
|
||||||
|
|
||||||
|
dropbear: $(HEADERS) $(LIBTOM_DEPS) Makefile
|
||||||
|
- $(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS) $(LIBS) @CRYPTLIB@
|
||||||
|
+ +$(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS) $(LIBS) @CRYPTLIB@
|
||||||
|
|
||||||
|
dbclient: $(HEADERS) $(LIBTOM_DEPS) Makefile
|
||||||
|
- $(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS) $(LIBS)
|
||||||
|
+ +$(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS) $(LIBS)
|
||||||
|
|
||||||
|
dropbearkey dropbearconvert: $(HEADERS) $(LIBTOM_DEPS) Makefile
|
||||||
|
- $(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS)
|
||||||
|
+ +$(CC) $(LDFLAGS) -o $@$(EXEEXT) $($@objs) $(LIBTOM_LIBS)
|
||||||
|
|
||||||
|
# scp doesn't use the libs so is special.
|
||||||
|
scp: $(SCPOBJS) $(HEADERS) Makefile
|
||||||
|
- $(CC) $(LDFLAGS) -o $@$(EXEEXT) $(SCPOBJS)
|
||||||
|
+ +$(CC) $(LDFLAGS) -o $@$(EXEEXT) $(SCPOBJS)
|
||||||
|
|
||||||
|
|
||||||
|
# multi-binary compilation.
|
||||||
|
@@ -184,7 +184,7 @@ ifeq ($(MULTI),1)
|
||||||
|
endif
|
||||||
|
|
||||||
|
dropbearmulti$(EXEEXT): $(HEADERS) $(MULTIOBJS) $(LIBTOM_DEPS) Makefile
|
||||||
|
- $(CC) $(LDFLAGS) -o $@ $(MULTIOBJS) $(LIBTOM_LIBS) $(LIBS) @CRYPTLIB@
|
||||||
|
+ +$(CC) $(LDFLAGS) -o $@ $(MULTIOBJS) $(LIBTOM_LIBS) $(LIBS) @CRYPTLIB@
|
||||||
|
|
||||||
|
multibinary: dropbearmulti$(EXEEXT)
|
||||||
|
|
Loading…
Reference in a new issue