another madwifi update
SVN-Revision: 7866
This commit is contained in:
parent
df6477e242
commit
424e15a610
2 changed files with 2 additions and 15 deletions
|
@ -10,14 +10,14 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=madwifi
|
||||
PKG_VERSION:=r2525-20070630
|
||||
PKG_VERSION:=r2537-20070704
|
||||
PKG_BRANCH:=madwifi-ng
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_BRANCH)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_BRANCH)
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)
|
||||
PKG_MD5SUM:=4e0d01bc448bb1ba070ad34d4d6e1454
|
||||
PKG_MD5SUM:=ae4856030e5ffb939370bcd459e260af
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: madwifi-ng-r2525-20070630/net80211/ieee80211_input.c
|
||||
===================================================================
|
||||
--- madwifi-ng-r2525-20070630.orig/net80211/ieee80211_input.c 2007-07-03 23:02:31.005981500 +0200
|
||||
+++ madwifi-ng-r2525-20070630/net80211/ieee80211_input.c 2007-07-03 23:02:31.926039000 +0200
|
||||
@@ -2873,7 +2873,7 @@
|
||||
ieee80211_add_scan(vap, &scan, wh, subtype, rssi, rtsf);
|
||||
return;
|
||||
}
|
||||
- if (scan.capinfo & IEEE80211_CAPINFO_IBSS) {
|
||||
+ if ((vap->iv_opmode == IEEE80211_M_IBSS) && (scan.capinfo & IEEE80211_CAPINFO_IBSS)) {
|
||||
if (!IEEE80211_ADDR_EQ(wh->i_addr2, ni->ni_macaddr)) {
|
||||
/* Create a new entry in the neighbor table. */
|
||||
ni = ieee80211_add_neighbor(vap, wh, &scan);
|
Loading…
Reference in a new issue