xfsprogs: update to 4.11.0
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
d7a3120cdc
commit
3c7a99ea90
12 changed files with 49 additions and 341 deletions
|
@ -9,16 +9,15 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=xfsprogs
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=3.1.7
|
||||
PKG_SOURCE_URL:=ftp://oss.sgi.com/projects/xfs/previous/
|
||||
PKG_HASH:=e150914210ac5fd29c098ef0fd94bdec51d2fb231cf9faa765c16ec6d75c8eaa
|
||||
PKG_VERSION:=4.11.0
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
|
||||
PKG_HASH:=c3a6d87b564d7738243c507df82276bed982265e345363a95f2c764e8a5f5bb2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/xfsprogs/default
|
||||
SECTION:=utils
|
||||
|
@ -58,15 +57,12 @@ MAKE_FLAGS += \
|
|||
DEBUG= Q= \
|
||||
PCFLAGS="-Wall" \
|
||||
PKG_PLATFORM=linux \
|
||||
ENABLE_GETTEXT=no \
|
||||
prefix=$(PKG_INSTALL_DIR)/usr \
|
||||
exec_prefix=$(PKG_INSTALL_DIR)/usr \
|
||||
PKG_SBIN_DIR=$(PKG_INSTALL_DIR)/usr/sbin \
|
||||
PKG_ROOT_SBIN_DIR=$(PKG_INSTALL_DIR)/sbin \
|
||||
PKG_MAN_DIR=$(PKG_INSTALL_DIR)/usr/man \
|
||||
PKG_LOCALE_DIR=$(PKG_INSTALL_DIR)/usr/share/locale \
|
||||
PKG_ROOT_LIB_DIR=$(PKG_INSTALL_DIR)/lib \
|
||||
PKG_DOC_DIR=$(PKG_INSTALL_DIR)/usr/share/doc/xfsprogs
|
||||
ENABLE_GETTEXT=no
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libxfs crc32table.h CFLAGS="$(HOST_CFLAGS) -I$(PKG_BUILD_DIR)/include"
|
||||
$(call Build/Compile/Default)
|
||||
endef
|
||||
|
||||
define Package/xfs-mkfs/install
|
||||
mkdir -p $(1)/usr/sbin
|
||||
|
|
|
@ -1,78 +0,0 @@
|
|||
commit 2222aa77e11b959e0e5a0ded3482e56799593bc2
|
||||
Author: Jens Muecke <jens@nons.de>
|
||||
Date: Thu Jan 26 00:34:15 2012 +0100
|
||||
|
||||
001-automake-compat
|
||||
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -2,7 +2,8 @@ AC_INIT(include/libxfs.h)
|
||||
AC_PREREQ(2.50)
|
||||
AC_CONFIG_AUX_DIR([.])
|
||||
AC_CONFIG_MACRO_DIR([m4])
|
||||
-AC_CONFIG_HEADER(include/platform_defs.h)
|
||||
+# Put a dummy here (http://www.mail-archive.com/automake@gnu.org/msg09241.html)
|
||||
+AC_CONFIG_HEADERS([doesnotexist.h include/platform_defs.h])
|
||||
AC_PREFIX_DEFAULT(/usr)
|
||||
|
||||
AC_PROG_LIBTOOL
|
||||
--- a/include/builddefs.in
|
||||
+++ b/include/builddefs.in
|
||||
@@ -20,6 +20,8 @@
|
||||
ifndef _BUILDDEFS_INCLUDED_
|
||||
_BUILDDEFS_INCLUDED_ = 1
|
||||
|
||||
+SHELL = @SHELL@
|
||||
+
|
||||
DEBUG = @debug_build@
|
||||
OPTIMIZER = @opt_build@
|
||||
MALLOCLIB = @malloc_lib@
|
||||
--- a/m4/package_types.m4
|
||||
+++ b/m4/package_types.m4
|
||||
@@ -9,7 +9,7 @@ AC_DEFUN([AC_TYPE_PSINT],
|
||||
#include <stddef.h>
|
||||
], [
|
||||
__psint_t psint;
|
||||
- ], AC_DEFINE(HAVE___PSINT_T) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
+ ], AC_DEFINE([HAVE___PSINT_T], [1], [Define if __psint_t exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
])
|
||||
|
||||
#
|
||||
@@ -23,7 +23,7 @@ AC_DEFUN([AC_TYPE_PSUNSIGNED],
|
||||
#include <stddef.h>
|
||||
], [
|
||||
__psunsigned_t psuint;
|
||||
- ], AC_DEFINE(HAVE___PSUNSIGNED_T) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
+ ], AC_DEFINE([HAVE___PSUNSIGNED_T], [1], [Define if __psunsigned_t exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
])
|
||||
|
||||
#
|
||||
@@ -37,7 +37,7 @@ AC_DEFUN([AC_TYPE_U32],
|
||||
#include <stddef.h>
|
||||
], [
|
||||
__u32 u32;
|
||||
- ], AC_DEFINE(HAVE___U32) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
+ ], AC_DEFINE([HAVE___U32], [1], [Define if __u32 exists]) AC_MSG_RESULT(yes) , AC_MSG_RESULT(no))
|
||||
])
|
||||
|
||||
#
|
||||
@@ -50,15 +50,15 @@ AC_DEFUN([AC_SIZEOF_POINTERS_AND_LONG],
|
||||
AC_CHECK_SIZEOF(long, 4)
|
||||
AC_CHECK_SIZEOF(char *, 4)
|
||||
if test $ac_cv_sizeof_long -eq 4 -o $ac_cv_sizeof_long -eq 0; then
|
||||
- AC_DEFINE(HAVE_32BIT_LONG)
|
||||
+ AC_DEFINE([HAVE_32BIT_LONG], [1], [Define if long is 32bit])
|
||||
fi
|
||||
if test $ac_cv_sizeof_long -eq 8; then
|
||||
- AC_DEFINE(HAVE_64BIT_LONG)
|
||||
+ AC_DEFINE([HAVE_64BIT_LONG], [1], [Define if long is 64bit])
|
||||
fi
|
||||
if test $ac_cv_sizeof_char_p -eq 4 -o $ac_cv_sizeof_char_p -eq 0; then
|
||||
- AC_DEFINE(HAVE_32BIT_PTR)
|
||||
+ AC_DEFINE([HAVE_32BIT_PTR], [1], [Define if char* is 32bit])
|
||||
fi
|
||||
if test $ac_cv_sizeof_char_p -eq 8; then
|
||||
- AC_DEFINE(HAVE_64BIT_PTR)
|
||||
+ AC_DEFINE([HAVE_64BIT_PTR], [1], [Define if char* is 64bit])
|
||||
fi
|
||||
])
|
14
package/utils/xfsprogs/patches/100-no-selftest.patch
Normal file
14
package/utils/xfsprogs/patches/100-no-selftest.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/libxfs/Makefile
|
||||
+++ b/libxfs/Makefile
|
||||
@@ -118,9 +118,9 @@ LTLIBS = $(LIBPTHREAD) $(LIBRT)
|
||||
# don't try linking xfs_repair with a debug libxfs.
|
||||
DEBUG = -DNDEBUG
|
||||
|
||||
-LDIRT = gen_crc32table crc32table.h crc32selftest
|
||||
+LDIRT = gen_crc32table crc32table.h
|
||||
|
||||
-default: crc32selftest ltdepend $(LTLIBRARY)
|
||||
+default: ltdepend $(LTLIBRARY)
|
||||
|
||||
crc32table.h: gen_crc32table.c
|
||||
@echo " [CC] gen_crc32table"
|
|
@ -1,19 +0,0 @@
|
|||
commit e72b7bd12fdef06c3494b919376bfe886aa8bb4d
|
||||
Author: Jens Muecke <jens@nons.de>
|
||||
Date: Thu Jan 26 00:35:43 2012 +0100
|
||||
|
||||
100-no_aio
|
||||
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -92,8 +92,8 @@ AC_PACKAGE_GLOBALS(xfsprogs)
|
||||
AC_PACKAGE_UTILITIES(xfsprogs)
|
||||
AC_MULTILIB($enable_lib64)
|
||||
|
||||
-AC_PACKAGE_NEED_AIO_H
|
||||
-AC_PACKAGE_NEED_LIO_LISTIO
|
||||
+librt="-lrt"
|
||||
+AC_SUBST(librt)
|
||||
|
||||
AC_PACKAGE_NEED_UUID_H
|
||||
AC_PACKAGE_NEED_UUIDCOMPARE
|
12
package/utils/xfsprogs/patches/110-subdirs.patch
Normal file
12
package/utils/xfsprogs/patches/110-subdirs.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -46,8 +46,7 @@ HDR_SUBDIRS = include libxfs
|
||||
|
||||
DLIB_SUBDIRS = libxlog libxcmd libhandle
|
||||
LIB_SUBDIRS = libxfs $(DLIB_SUBDIRS)
|
||||
-TOOL_SUBDIRS = copy db estimate fsck growfs io logprint mkfs quota \
|
||||
- mdrestore repair rtcp m4 man doc debian
|
||||
+TOOL_SUBDIRS = db fsck growfs io mkfs repair
|
||||
|
||||
ifneq ("$(PKG_PLATFORM)","darwin")
|
||||
TOOL_SUBDIRS += fsr
|
|
@ -1,32 +0,0 @@
|
|||
commit 7b1d0a98e779170232c0a81b4749ab934ec67a7e
|
||||
Author: Jens Muecke <jens@nons.de>
|
||||
Date: Thu Jan 26 00:36:42 2012 +0100
|
||||
|
||||
110-uclibc_no_ustat
|
||||
|
||||
--- a/libxfs/linux.c
|
||||
+++ b/libxfs/linux.c
|
||||
@@ -21,7 +21,6 @@
|
||||
#include <mntent.h>
|
||||
#include <sys/stat.h>
|
||||
#undef ustat
|
||||
-#include <sys/ustat.h>
|
||||
#include <sys/mount.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/sysinfo.h>
|
||||
@@ -49,6 +48,7 @@ static int max_block_alignment;
|
||||
int
|
||||
platform_check_ismounted(char *name, char *block, struct stat64 *s, int verbose)
|
||||
{
|
||||
+#if 0
|
||||
/* Pad ust; pre-2.6.28 linux copies out too much in 32bit compat mode */
|
||||
struct ustat ust[2];
|
||||
struct stat64 st;
|
||||
@@ -68,6 +68,7 @@ platform_check_ismounted(char *name, cha
|
||||
progname, name);
|
||||
return 1;
|
||||
}
|
||||
+#endif
|
||||
return 0;
|
||||
}
|
||||
|
12
package/utils/xfsprogs/patches/120-disable_assert.patch
Normal file
12
package/utils/xfsprogs/patches/120-disable_assert.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/libxfs/libxfs_priv.h
|
||||
+++ b/libxfs/libxfs_priv.h
|
||||
@@ -84,9 +84,6 @@ extern uint32_t crc32c_le(uint32_t crc,
|
||||
/* for all the support code that uses progname in error messages */
|
||||
extern char *progname;
|
||||
|
||||
-#undef ASSERT
|
||||
-#define ASSERT(ex) assert(ex)
|
||||
-
|
||||
#ifndef EWRONGFS
|
||||
#define EWRONGFS EINVAL
|
||||
#endif
|
|
@ -1,45 +0,0 @@
|
|||
commit d2aef8b3967e53fe58178f5af50fef488ee0faed
|
||||
Author: Jens Muecke <jens@nons.de>
|
||||
Date: Thu Jan 26 00:37:52 2012 +0100
|
||||
|
||||
120-portability
|
||||
|
||||
--- a/copy/xfs_copy.c
|
||||
+++ b/copy/xfs_copy.c
|
||||
@@ -463,6 +463,15 @@ read_ag_header(int fd, xfs_agnumber_t ag
|
||||
}
|
||||
|
||||
|
||||
+static void sig_mask(int type)
|
||||
+{
|
||||
+ sigset_t mask;
|
||||
+ sigemptyset(&mask);
|
||||
+ sigaddset(&mask, SIGCHLD);
|
||||
+ sigprocmask(type, &mask, NULL);
|
||||
+}
|
||||
+
|
||||
+
|
||||
void
|
||||
write_wbuf(void)
|
||||
{
|
||||
@@ -478,9 +487,9 @@ write_wbuf(void)
|
||||
if (target[i].state != INACTIVE)
|
||||
pthread_mutex_unlock(&targ[i].wait); /* wake up */
|
||||
|
||||
- sigrelse(SIGCHLD);
|
||||
+ sig_mask(SIG_UNBLOCK);
|
||||
pthread_mutex_lock(&mainwait);
|
||||
- sighold(SIGCHLD);
|
||||
+ sig_mask(SIG_BLOCK);
|
||||
}
|
||||
|
||||
|
||||
@@ -847,7 +856,7 @@ main(int argc, char **argv)
|
||||
/* set up sigchild signal handler */
|
||||
|
||||
signal(SIGCHLD, handler);
|
||||
- sighold(SIGCHLD);
|
||||
+ sig_mask(SIG_BLOCK);
|
||||
|
||||
/* make children */
|
||||
|
|
@ -1,32 +0,0 @@
|
|||
commit 10d6058b24f18cb31889154f830b191849f45106
|
||||
Author: Jens Muecke <jens@nons.de>
|
||||
Date: Thu Jan 26 00:38:27 2012 +0100
|
||||
|
||||
130-uclibc_no_xattr
|
||||
|
||||
--- a/fsr/xfs_fsr.c
|
||||
+++ b/fsr/xfs_fsr.c
|
||||
@@ -35,7 +35,6 @@
|
||||
#include <sys/wait.h>
|
||||
#include <sys/vfs.h>
|
||||
#include <sys/statvfs.h>
|
||||
-#include <sys/xattr.h>
|
||||
|
||||
|
||||
#ifndef XFS_XFLAG_NODEFRAG
|
||||
@@ -990,6 +989,7 @@ fsr_setup_attr_fork(
|
||||
int tfd,
|
||||
xfs_bstat_t *bstatp)
|
||||
{
|
||||
+#if 0
|
||||
struct stat64 tstatbuf;
|
||||
int i;
|
||||
int last_forkoff = 0;
|
||||
@@ -1108,6 +1108,7 @@ fsr_setup_attr_fork(
|
||||
out:
|
||||
if (dflag)
|
||||
fsrprintf(_("set temp attr\n"));
|
||||
+#endif
|
||||
return 0;
|
||||
}
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -41,7 +41,7 @@ endif
|
||||
|
||||
LIB_SUBDIRS = libxfs libxlog libxcmd libhandle libdisk
|
||||
TOOL_SUBDIRS = copy db estimate fsck fsr growfs io logprint mkfs quota \
|
||||
- mdrestore repair rtcp m4 man doc po debian
|
||||
+ mdrestore repair rtcp m4 man doc debian
|
||||
|
||||
SUBDIRS = include $(LIB_SUBDIRS) $(TOOL_SUBDIRS)
|
||||
|
||||
@@ -135,7 +135,6 @@ ifeq ($(HAVE_BUILDDEFS), no)
|
||||
$(Q)$(MAKE) $(MAKEOPTS) -C . $@
|
||||
else
|
||||
$(Q)$(MAKE) $(MAKEOPTS) $(SRCDIR)
|
||||
- $(Q)$(MAKE) $(MAKEOPTS) -C po
|
||||
$(Q)$(MAKE) $(MAKEOPTS) source-link
|
||||
$(Q)cd $(SRCDIR) && dpkg-buildpackage
|
||||
endif
|
|
@ -1,72 +0,0 @@
|
|||
--- a/libhandle/handle.c
|
||||
+++ b/libhandle/handle.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <xfs/xfs.h>
|
||||
#include <xfs/handle.h>
|
||||
#include <xfs/parent.h>
|
||||
+#include <linux/limits.h>
|
||||
|
||||
/* just pick a value we know is more than big enough */
|
||||
#define MAXHANSIZ 64
|
||||
--- a/libhandle/jdm.c
|
||||
+++ b/libhandle/jdm.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <xfs/handle.h>
|
||||
#include <xfs/jdm.h>
|
||||
#include <xfs/parent.h>
|
||||
+#include <linux/limits.h>
|
||||
|
||||
/* internal fshandle - typecast to a void for external use */
|
||||
#define FSHANDLE_SZ 8
|
||||
--- a/libdisk/evms.c
|
||||
+++ b/libdisk/evms.c
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/sysmacros.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <disk/volume.h>
|
||||
#include "evms.h"
|
||||
|
||||
--- a/libdisk/evms.h
|
||||
+++ b/libdisk/evms.h
|
||||
@@ -16,6 +16,8 @@
|
||||
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#define EVMS_MAJOR 117
|
||||
#define EVMS_GET_VOL_STRIPE_INFO \
|
||||
_IOR(EVMS_MAJOR, 0xF0, struct evms_vol_stripe_info_s)
|
||||
--- a/libdisk/fstype.h
|
||||
+++ b/libdisk/fstype.h
|
||||
@@ -192,7 +192,7 @@ struct adfs_super_block {
|
||||
char s_dummy2[62];
|
||||
char s_checksum[1];
|
||||
};
|
||||
-#define adfsblksize(s) ((uint) s.s_blksize[0])
|
||||
+#define adfsblksize(s) ((unsigned int) s.s_blksize[0])
|
||||
|
||||
/* found in first 4 bytes of block 1 */
|
||||
struct vxfs_super_block {
|
||||
--- a/fsr/xfs_fsr.c
|
||||
+++ b/fsr/xfs_fsr.c
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <xfs/xfs_dinode.h>
|
||||
#include <xfs/xfs_attr_sf.h>
|
||||
|
||||
+#include <paths.h>
|
||||
#include <fcntl.h>
|
||||
#include <errno.h>
|
||||
#include <malloc.h>
|
||||
--- a/libdisk/xvm.c
|
||||
+++ b/libdisk/xvm.c
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
+#include <sys/types.h>
|
||||
#include <disk/volume.h>
|
||||
#include "xvm.h"
|
||||
|
|
@ -1,29 +0,0 @@
|
|||
From: Ben Myers <bpm@sgi.com>
|
||||
Date: Fri, 1 Feb 2013 21:50:22 +0000 (-0600)
|
||||
Subject: xfsprogs: fix warning in libxcmd/input.c
|
||||
X-Git-Tag: v3.1.11~25
|
||||
X-Git-Url: http://oss.sgi.com/cgi-bin/gitweb.cgi?p=xfs%2Fcmds%2Fxfsprogs.git;a=commitdiff_plain;h=50a3aa8977821ad072f3aa5b63645827f9b8ca1d
|
||||
|
||||
xfsprogs: fix warning in libxcmd/input.c
|
||||
|
||||
Fix an error when building with -Werror=format-security.
|
||||
|
||||
input.c: In function 'fetchline':
|
||||
input.c:91:2: error: format not a string literal and no format arguments [-Werror=format-security]
|
||||
|
||||
Signed-off-by: Ben Myers <bpm@sgi.com>
|
||||
Reported by: Arkadiusz Miśkiewicz <arekm@maven.pl>
|
||||
Reviewed-by: Mark Tinguely <tinguely@sgi.com>
|
||||
---
|
||||
|
||||
--- a/libxcmd/input.c
|
||||
+++ b/libxcmd/input.c
|
||||
@@ -88,7 +88,7 @@ fetchline(void)
|
||||
|
||||
if (!line)
|
||||
return NULL;
|
||||
- printf(get_prompt());
|
||||
+ printf("%s", get_prompt());
|
||||
fflush(stdout);
|
||||
if (!fgets(line, MAXREADLINESZ, stdin)) {
|
||||
free(line);
|
Loading…
Reference in a new issue