tools/cmake: update to 3.10.1
Update cmake to 3.10.1 Refresh patches Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
b0d513ec91
commit
3c4df661c0
7 changed files with 16 additions and 40 deletions
|
@ -7,13 +7,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cmake
|
||||
PKG_VERSION:=3.9.3
|
||||
PKG_VERSION:=3.10.1
|
||||
PKG_CPE_ID:=cpe:/a:kitware:cmake
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://cmake.org/files/v3.9/ \
|
||||
PKG_SOURCE_URL:=https://cmake.org/files/v3.10/ \
|
||||
https://fossies.org/linux/misc/
|
||||
PKG_HASH:=8eaf75e1e932159aae98ab5e7491499545554be62a08cbcbc7c75c84b999f28a
|
||||
PKG_HASH:=7be36ee24b0f5928251b644d29f5ff268330a916944ef4a75e23ba01e7573284
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
HOST_CONFIGURE_PARALLEL:=1
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- a/Source/kwsys/kwsysPlatformTestsCXX.cxx
|
||||
+++ b/Source/kwsys/kwsysPlatformTestsCXX.cxx
|
||||
@@ -265,6 +265,12 @@ int main()
|
||||
#ifdef TEST_KWSYS_CXX_HAS_UTIMENSAT
|
||||
#include <fcntl.h>
|
||||
#include <sys/stat.h>
|
||||
+#if defined(__APPLE__)
|
||||
+#include <AvailabilityMacros.h>
|
||||
+#if MAC_OS_X_VERSION_MIN_REQUIRED < 101300
|
||||
+#error "utimensat not available on macOS < 10.13"
|
||||
+#endif
|
||||
+#endif
|
||||
int main()
|
||||
{
|
||||
struct timespec times[2] = { { 0, UTIME_OMIT }, { 0, UTIME_NOW } };
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Tests/RunCMake/CMakeLists.txt
|
||||
+++ b/Tests/RunCMake/CMakeLists.txt
|
||||
@@ -246,15 +246,6 @@ add_RunCMake_test(no_install_prefix)
|
||||
@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
|
||||
add_RunCMake_test(configure_file)
|
||||
add_RunCMake_test(CTestTimeoutAfterMatch)
|
||||
|
||||
|
@ -18,14 +18,17 @@
|
|||
add_RunCMake_test(FindPkgConfig)
|
||||
--- a/Tests/CMakeLists.txt
|
||||
+++ b/Tests/CMakeLists.txt
|
||||
@@ -403,10 +403,6 @@ if(BUILD_TESTING)
|
||||
@@ -407,13 +407,6 @@ if(BUILD_TESTING)
|
||||
|
||||
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
||||
|
||||
- if(NOT QT4_FOUND)
|
||||
- if(NOT DEFINED CMake_TEST_Qt4)
|
||||
- set(CMake_TEST_Qt4 1)
|
||||
- endif()
|
||||
- if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
|
||||
- find_package(Qt4 QUIET)
|
||||
- endif()
|
||||
-
|
||||
if(QT4_FOUND)
|
||||
if(CMake_TEST_Qt4 AND QT4_FOUND)
|
||||
# test whether the Qt4 which has been found works, on some machines
|
||||
# which run nightly builds there were errors like "wrong file format"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Utilities/cmjsoncpp/include/json/assertions.h
|
||||
+++ b/Utilities/cmjsoncpp/include/json/assertions.h
|
||||
@@ -6,12 +6,12 @@
|
||||
@@ -6,11 +6,12 @@
|
||||
#ifndef CPPTL_JSON_ASSERTIONS_H_INCLUDED
|
||||
#define CPPTL_JSON_ASSERTIONS_H_INCLUDED
|
||||
|
||||
|
@ -11,7 +11,6 @@
|
|||
#endif // if !defined(JSON_IS_AMALGAMATION)
|
||||
|
||||
-#include <stdlib.h>
|
||||
-
|
||||
#if JSON_USE_EXCEPTION
|
||||
#include <stdexcept>
|
||||
#define JSON_ASSERT(condition) \
|
||||
#include <sstream>
|
||||
|
||||
/** It should not be possible for a maliciously designed file to
|
||||
|
|
|
@ -9,14 +9,3 @@
|
|||
#include <stdlib.h> /* malloc, free */
|
||||
#include <string.h> /* memset */
|
||||
static inline EVP_MD_CTX *EVP_MD_CTX_new(void)
|
||||
--- a/Utilities/cmlibarchive/libarchive/archive_openssl_hmac_private.h
|
||||
+++ b/Utilities/cmlibarchive/libarchive/archive_openssl_hmac_private.h
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <openssl/hmac.h>
|
||||
#include <openssl/opensslv.h>
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
#include <stdlib.h> /* malloc, free */
|
||||
#include <string.h> /* memset */
|
||||
static inline HMAC_CTX *HMAC_CTX_new(void)
|
||||
|
|
|
@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|||
---
|
||||
--- a/Utilities/cmcurl/CMakeLists.txt
|
||||
+++ b/Utilities/cmcurl/CMakeLists.txt
|
||||
@@ -456,6 +456,10 @@ if(CMAKE_USE_OPENSSL)
|
||||
@@ -461,6 +461,10 @@ if(CMAKE_USE_OPENSSL)
|
||||
set(USE_OPENSSL ON)
|
||||
set(HAVE_LIBCRYPTO ON)
|
||||
set(HAVE_LIBSSL ON)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/bootstrap
|
||||
+++ b/bootstrap
|
||||
@@ -1094,7 +1094,10 @@ int main(){ printf("1%c", (char)0x0a); r
|
||||
@@ -1130,7 +1130,10 @@ int main(){ printf("1%c", (char)0x0a); r
|
||||
' > "test.c"
|
||||
cmake_original_make_flags="${cmake_make_flags}"
|
||||
if [ "x${cmake_parallel_make}" != "x" ]; then
|
||||
|
|
Loading…
Reference in a new issue