bcm53xx: start working on Netgear R8500
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 48625
This commit is contained in:
parent
6219b3deae
commit
3b76c7cf0b
5 changed files with 84 additions and 0 deletions
|
@ -15,6 +15,9 @@ asus,rt-ac87u)
|
||||||
netgear,r8000)
|
netgear,r8000)
|
||||||
ifname=eth2
|
ifname=eth2
|
||||||
;;
|
;;
|
||||||
|
netgear,r8500)
|
||||||
|
ifname=eth2
|
||||||
|
;;
|
||||||
*)
|
*)
|
||||||
ifname=eth0
|
ifname=eth0
|
||||||
;;
|
;;
|
||||||
|
|
|
@ -177,5 +177,6 @@ $(eval $(call AsusDevice,rt-n18u,RT-N18U))
|
||||||
$(eval $(call DLinkDevice,dir-885l,wrgac42_dlink.2015_dir885l))
|
$(eval $(call DLinkDevice,dir-885l,wrgac42_dlink.2015_dir885l))
|
||||||
$(eval $(call LinksysDevice,ea6300-v1))
|
$(eval $(call LinksysDevice,ea6300-v1))
|
||||||
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
|
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
|
||||||
|
# $(eval $(call NetgearDevice,r8500,U12H334T00_NETGEAR))
|
||||||
|
|
||||||
$(eval $(call BuildImage))
|
$(eval $(call BuildImage))
|
||||||
|
|
|
@ -0,0 +1,57 @@
|
||||||
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Netgear R8500
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/Makefile | 1 +
|
||||||
|
arch/arm/boot/dts/bcm47094-netgear-r8500.dts | 31 ++++++++++++++++++++++++++++
|
||||||
|
2 files changed, 32 insertions(+)
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||||
|
bcm4709-netgear-r7000.dtb \
|
||||||
|
bcm4709-netgear-r8000.dtb \
|
||||||
|
bcm47094-dlink-dir-885l.dtb \
|
||||||
|
+ bcm47094-netgear-r8500.dtb \
|
||||||
|
bcm94708.dtb \
|
||||||
|
bcm94709.dtb \
|
||||||
|
bcm953012k.dtb
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
@@ -0,0 +1,31 @@
|
||||||
|
+/*
|
||||||
|
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
||||||
|
+ * DTS for Netgear R8500
|
||||||
|
+ *
|
||||||
|
+ * Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/dts-v1/;
|
||||||
|
+
|
||||||
|
+#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
+
|
||||||
|
+/ {
|
||||||
|
+ compatible = "netgear,r8500", "brcm,bcm47094", "brcm,bcm4708";
|
||||||
|
+ model = "Netgear R8500";
|
||||||
|
+
|
||||||
|
+ chosen {
|
||||||
|
+ bootargs = "console=ttyS0,115200";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ memory {
|
||||||
|
+ reg = <0x00000000 0x08000000>;
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ status = "okay";
|
||||||
|
+ clock-frequency = <125000000>;
|
||||||
|
+};
|
|
@ -178,4 +178,15 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||||
};
|
};
|
||||||
|
|
||||||
|
memory {
|
||||||
|
--- a/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
model = "Netgear R8500";
|
||||||
|
|
||||||
|
chosen {
|
||||||
|
- bootargs = "console=ttyS0,115200";
|
||||||
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||||
|
};
|
||||||
|
|
||||||
memory {
|
memory {
|
||||||
|
|
|
@ -183,3 +183,15 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
};
|
};
|
||||||
|
|
||||||
nand: nand@18028000 {
|
nand: nand@18028000 {
|
||||||
|
--- a/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
@@ -21,7 +21,8 @@
|
||||||
|
};
|
||||||
|
|
||||||
|
memory {
|
||||||
|
- reg = <0x00000000 0x08000000>;
|
||||||
|
+ reg = <0x00000000 0x08000000
|
||||||
|
+ 0x88000000 0x18000000>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue