gcc: refresh patches for version 7.3.0
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
fc54256bc8
commit
38dc678166
5 changed files with 6 additions and 6 deletions
|
@ -7,7 +7,7 @@ Date: Mon Mar 5 00:51:01 2012 +0000
|
||||||
SVN-Revision: 30814
|
SVN-Revision: 30814
|
||||||
--- a/gcc/config/rs6000/rs6000.c
|
--- a/gcc/config/rs6000/rs6000.c
|
||||||
+++ b/gcc/config/rs6000/rs6000.c
|
+++ b/gcc/config/rs6000/rs6000.c
|
||||||
@@ -26936,7 +26936,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
@@ -27001,7 +27001,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||||
/* Define cutoff for using out-of-line functions to save registers. */
|
/* Define cutoff for using out-of-line functions to save registers. */
|
||||||
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
||||||
{
|
{
|
||||||
|
|
|
@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||||
; On SVR4 targets, it also controls whether or not to emit a
|
; On SVR4 targets, it also controls whether or not to emit a
|
||||||
--- a/gcc/opts.c
|
--- a/gcc/opts.c
|
||||||
+++ b/gcc/opts.c
|
+++ b/gcc/opts.c
|
||||||
@@ -1928,6 +1928,9 @@ common_handle_option (struct gcc_options
|
@@ -1934,6 +1934,9 @@ common_handle_option (struct gcc_options
|
||||||
opts, opts_set, loc, dc);
|
opts, opts_set, loc, dc);
|
||||||
break;
|
break;
|
||||||
|
|
||||||
|
@ -126,7 +126,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||||
opts->x_warn_larger_than = value != -1;
|
opts->x_warn_larger_than = value != -1;
|
||||||
--- a/gcc/doc/invoke.texi
|
--- a/gcc/doc/invoke.texi
|
||||||
+++ b/gcc/doc/invoke.texi
|
+++ b/gcc/doc/invoke.texi
|
||||||
@@ -6567,6 +6567,17 @@ This option is only supported for C and
|
@@ -6569,6 +6569,17 @@ This option is only supported for C and
|
||||||
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
|
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
|
||||||
@option{-Wno-pointer-sign}.
|
@option{-Wno-pointer-sign}.
|
||||||
|
|
||||||
|
|
|
@ -7,7 +7,7 @@ Date: Sat Apr 21 03:02:39 2012 +0000
|
||||||
|
|
||||||
--- a/gcc/gcc.c
|
--- a/gcc/gcc.c
|
||||||
+++ b/gcc/gcc.c
|
+++ b/gcc/gcc.c
|
||||||
@@ -9280,8 +9280,10 @@ getenv_spec_function (int argc, const ch
|
@@ -9281,8 +9281,10 @@ getenv_spec_function (int argc, const ch
|
||||||
value = varname;
|
value = varname;
|
||||||
|
|
||||||
if (!value)
|
if (!value)
|
||||||
|
|
|
@ -22,7 +22,7 @@ Date: Fri Dec 12 17:01:57 2014 +0000
|
||||||
|
|
||||||
--- a/libstdc++-v3/include/Makefile.in
|
--- a/libstdc++-v3/include/Makefile.in
|
||||||
+++ b/libstdc++-v3/include/Makefile.in
|
+++ b/libstdc++-v3/include/Makefile.in
|
||||||
@@ -1476,7 +1476,7 @@ stamp-bits: ${bits_headers}
|
@@ -1475,7 +1475,7 @@ stamp-bits: ${bits_headers}
|
||||||
@$(STAMP) stamp-bits
|
@$(STAMP) stamp-bits
|
||||||
|
|
||||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
||||||
|
|
|
@ -63,7 +63,7 @@ Forward ported from attachment to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=4
|
||||||
When preprocessing, handle directives, but do not expand macros.
|
When preprocessing, handle directives, but do not expand macros.
|
||||||
--- a/gcc/doc/invoke.texi
|
--- a/gcc/doc/invoke.texi
|
||||||
+++ b/gcc/doc/invoke.texi
|
+++ b/gcc/doc/invoke.texi
|
||||||
@@ -11863,6 +11863,12 @@ by @option{-fplugin=@var{name}} instead
|
@@ -11865,6 +11865,12 @@ by @option{-fplugin=@var{name}} instead
|
||||||
@option{-fplugin=@var{path}/@var{name}.so}. This option is not meant
|
@option{-fplugin=@var{path}/@var{name}.so}. This option is not meant
|
||||||
to be used by the user, but only passed by the driver.
|
to be used by the user, but only passed by the driver.
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue