opkg: update to r618
SVN-Revision: 26598
This commit is contained in:
parent
e28b459b21
commit
37f7e8afdc
5 changed files with 7 additions and 71 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=opkg
|
PKG_NAME:=opkg
|
||||||
PKG_REV:=576
|
PKG_REV:=618
|
||||||
PKG_VERSION:=$(PKG_REV)
|
PKG_VERSION:=$(PKG_REV)
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
|
|
@ -1,64 +0,0 @@
|
||||||
This patch adds a new configuration option (overlay_root) specifying
|
|
||||||
what mount point opkg should check for available storage space.
|
|
||||||
|
|
||||||
Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
|
||||||
|
|
||||||
|
|
||||||
--- a/libopkg/opkg_conf.c
|
|
||||||
+++ b/libopkg/opkg_conf.c
|
|
||||||
@@ -63,6 +63,7 @@ opkg_option_t options[] = {
|
|
||||||
{ "download_only", OPKG_OPT_TYPE_BOOL, &_conf.download_only },
|
|
||||||
{ "nodeps", OPKG_OPT_TYPE_BOOL, &_conf.nodeps },
|
|
||||||
{ "offline_root", OPKG_OPT_TYPE_STRING, &_conf.offline_root },
|
|
||||||
+ { "overlay_root", OPKG_OPT_TYPE_STRING, &_conf.overlay_root },
|
|
||||||
{ "proxy_passwd", OPKG_OPT_TYPE_STRING, &_conf.proxy_passwd },
|
|
||||||
{ "proxy_user", OPKG_OPT_TYPE_STRING, &_conf.proxy_user },
|
|
||||||
{ "query-all", OPKG_OPT_TYPE_BOOL, &_conf.query_all },
|
|
||||||
--- a/libopkg/opkg_conf.h
|
|
||||||
+++ b/libopkg/opkg_conf.h
|
|
||||||
@@ -78,6 +78,7 @@ struct opkg_conf
|
|
||||||
int check_signature;
|
|
||||||
int nodeps; /* do not follow dependencies */
|
|
||||||
char *offline_root;
|
|
||||||
+ char *overlay_root;
|
|
||||||
int query_all;
|
|
||||||
int verbosity;
|
|
||||||
int noaction;
|
|
||||||
--- a/libopkg/opkg_install.c
|
|
||||||
+++ b/libopkg/opkg_install.c
|
|
||||||
@@ -21,6 +21,7 @@
|
|
||||||
#include <time.h>
|
|
||||||
#include <signal.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
|
|
||||||
#include "pkg.h"
|
|
||||||
#include "pkg_hash.h"
|
|
||||||
@@ -192,13 +193,24 @@ static int
|
|
||||||
verify_pkg_installable(pkg_t *pkg)
|
|
||||||
{
|
|
||||||
unsigned long kbs_available, pkg_size_kbs;
|
|
||||||
- char *root_dir;
|
|
||||||
+ char *root_dir = NULL;
|
|
||||||
+ struct stat s;
|
|
||||||
|
|
||||||
if (conf->force_space || pkg->installed_size == 0)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
- root_dir = pkg->dest ? pkg->dest->root_dir :
|
|
||||||
- conf->default_dest->root_dir;
|
|
||||||
+ if( pkg->dest )
|
|
||||||
+ {
|
|
||||||
+ if( !strcmp(pkg->dest->name, "root") && conf->overlay_root
|
|
||||||
+ && !stat(conf->overlay_root, &s) && (s.st_mode & S_IFDIR) )
|
|
||||||
+ root_dir = conf->overlay_root;
|
|
||||||
+ else
|
|
||||||
+ root_dir = pkg->dest->root_dir;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if( !root_dir )
|
|
||||||
+ root_dir = conf->default_dest->root_dir;
|
|
||||||
+
|
|
||||||
kbs_available = get_available_kbytes(root_dir);
|
|
||||||
|
|
||||||
pkg_size_kbs = (pkg->installed_size + 1023)/1024;
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/libopkg/Makefile.am
|
--- a/libopkg/Makefile.am
|
||||||
+++ b/libopkg/Makefile.am
|
+++ b/libopkg/Makefile.am
|
||||||
@@ -35,16 +35,10 @@ if HAVE_SHA256
|
@@ -38,16 +38,10 @@ if HAVE_SHA256
|
||||||
opkg_util_sources += sha256.c sha256.h
|
opkg_util_sources += sha256.c sha256.h
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/libopkg/opkg_cmd.c
|
--- a/libopkg/opkg_cmd.c
|
||||||
+++ b/libopkg/opkg_cmd.c
|
+++ b/libopkg/opkg_cmd.c
|
||||||
@@ -508,18 +508,6 @@ opkg_upgrade_cmd(int argc, char **argv)
|
@@ -551,18 +551,6 @@ opkg_upgrade_cmd(int argc, char **argv)
|
||||||
err = -1;
|
err = -1;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -19,7 +19,7 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
if (opkg_configure_packages(NULL))
|
if (opkg_configure_packages(NULL))
|
||||||
@@ -1215,7 +1203,7 @@ opkg_print_architecture_cmd(int argc, ch
|
@@ -1258,7 +1246,7 @@ opkg_print_architecture_cmd(int argc, ch
|
||||||
array for easier maintenance */
|
array for easier maintenance */
|
||||||
static opkg_cmd_t cmds[] = {
|
static opkg_cmd_t cmds[] = {
|
||||||
{"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
{"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
||||||
|
@ -30,7 +30,7 @@
|
||||||
{"list-installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
|
{"list-installed", 0, (opkg_cmd_fun_t)opkg_list_installed_cmd, PFM_SOURCE},
|
||||||
--- a/src/opkg-cl.c
|
--- a/src/opkg-cl.c
|
||||||
+++ b/src/opkg-cl.c
|
+++ b/src/opkg-cl.c
|
||||||
@@ -214,7 +214,7 @@ usage()
|
@@ -221,7 +221,7 @@ usage()
|
||||||
|
|
||||||
printf("\nPackage Manipulation:\n");
|
printf("\nPackage Manipulation:\n");
|
||||||
printf("\tupdate Update list of available packages\n");
|
printf("\tupdate Update list of available packages\n");
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/opkg-cl.c
|
--- a/src/opkg-cl.c
|
||||||
+++ b/src/opkg-cl.c
|
+++ b/src/opkg-cl.c
|
||||||
@@ -200,6 +200,9 @@ args_parse(int argc, char *argv[])
|
@@ -207,6 +207,9 @@ args_parse(int argc, char *argv[])
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue