soloscli: upgrade to 1.04
- The package does not compile at the moment. Since there is a new upstream version avaiable, use this new source instead. - Upstream has already included our both patches. - This is only compile tested, since I do not own any test hardware. Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 40940
This commit is contained in:
parent
3306a4f9ab
commit
35d3c91c86
5 changed files with 28 additions and 42 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,16 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=soloscli
|
||||
PKG_VERSION:=0.11
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.04
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/openadsl
|
||||
PKG_MD5SUM:=ab3f3fa654ef7c3a402980eca094e690
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_MD5SUM:=c398866de3c059b14eb953c89d698124
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/Makefile 2010-06-14 14:17:11.000000000 +1000
|
||||
+++ b/Makefile 2010-06-14 14:17:54.000000000 +1000
|
||||
@@ -13,6 +13,11 @@
|
||||
KDIR ?= /lib/modules/$(shell uname -r)/build
|
||||
PWD := $(shell pwd)
|
||||
|
||||
+soloscli/soloscli:
|
||||
+ $(MAKE) -C soloscli
|
||||
+
|
||||
+install:
|
||||
+
|
||||
default:
|
||||
$(MAKE) -C $(KDIR) M=$(PWD) modules
|
||||
|
||||
@@ -20,5 +25,6 @@
|
||||
rm -f *.o *.ko *.mod.c .*.cmd
|
||||
rm -rf .tmp_versions
|
||||
rm -f Module.symvers
|
||||
+ $(MAKE) -C soloscli clean
|
||||
|
||||
endif
|
|
@ -1,15 +0,0 @@
|
|||
--- a/soloscli/soloscli.c
|
||||
+++ b/soloscli/soloscli.c
|
||||
@@ -238,7 +238,11 @@
|
||||
}
|
||||
if (strcmp(buf,pid) == 0) {
|
||||
/* printf("Sequence matches.\n"); */
|
||||
- printf("%s",bufp);
|
||||
+ if(buf[(len-1)] == '\n'){
|
||||
+ printf("%s",bufp);
|
||||
+ } else {
|
||||
+ printf("%s\n",bufp);
|
||||
+ }
|
||||
} else {
|
||||
printf("Sequence incorrect.\n");
|
||||
buf[i] = '\n';
|
11
package/network/config/soloscli/patches/001-no-driver.patch
Normal file
11
package/network/config/soloscli/patches/001-no-driver.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -11,7 +11,7 @@ else
|
||||
KDIR ?= /lib/modules/$(shell uname -r)/build
|
||||
PWD := $(shell pwd)
|
||||
|
||||
-all: soloscli driver
|
||||
+all: soloscli
|
||||
|
||||
soloscli: soloscli/soloscli
|
||||
|
12
package/network/config/soloscli/patches/002-cflags.patch
Normal file
12
package/network/config/soloscli/patches/002-cflags.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/soloscli/Makefile
|
||||
+++ b/soloscli/Makefile
|
||||
@@ -4,9 +4,6 @@
|
||||
# Last Mod: 2009-06-16
|
||||
#
|
||||
|
||||
-CC=gcc
|
||||
-CFLAGS=-Wall
|
||||
-
|
||||
soloscli: soloscli.c soloscli.h
|
||||
|
||||
clean:
|
Loading…
Reference in a new issue