iperf: Drop single-threaded variant
Signed-off-by: Bert Vermeulen <bert@biot.com>
This commit is contained in:
parent
b4a23f83f9
commit
34b6c8b075
2 changed files with 4 additions and 50 deletions
|
@ -24,61 +24,29 @@ PKG_BUILD_PARALLEL:=1
|
|||
include $(INCLUDE_DIR)/uclibc++.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/iperf/Default
|
||||
define Package/iperf
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:= $(CXX_DEPENDS)
|
||||
DEPENDS:= $(CXX_DEPENDS) +libpthread
|
||||
TITLE:=Internet Protocol bandwidth measuring tool
|
||||
URL:=http://sourceforge.net/projects/iperf2/
|
||||
endef
|
||||
|
||||
define Package/iperf/Default/description
|
||||
define Package/iperf/description
|
||||
Iperf is a modern alternative for measuring TCP and UDP bandwidth
|
||||
performance, allowing the tuning of various parameters and
|
||||
characteristics.
|
||||
endef
|
||||
|
||||
define Package/iperf
|
||||
$(call Package/iperf/Default)
|
||||
TITLE+= (with single thread support)
|
||||
VARIANT:=single
|
||||
endef
|
||||
|
||||
define Package/iperf/description
|
||||
$(call Package/iperf/Default/description)
|
||||
This package is built with single thread support.
|
||||
endef
|
||||
|
||||
define Package/iperf-mt
|
||||
$(call Package/iperf/Default)
|
||||
DEPENDS+= +libpthread
|
||||
TITLE+= (with multithread support)
|
||||
VARIANT:=mt
|
||||
endef
|
||||
|
||||
define Package/iperf-mt/description
|
||||
$(call Package/iperf/Default/description)
|
||||
This package is built with multithread support.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -D_GNU_SOURCE
|
||||
CONFIGURE_ARGS += --disable-multicast
|
||||
|
||||
ifeq ($(BUILD_VARIANT),single)
|
||||
CONFIGURE_ARGS += --disable-threads
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
|
||||
|
||||
ifeq ($(BUILD_VARIANT),mt)
|
||||
CONFIGURE_VARS += LIBS="-lpthread"
|
||||
endif
|
||||
CONFIGURE_VARS += LIBS="-lpthread"
|
||||
|
||||
define Package/iperf/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iperf $(1)/usr/bin/iperf
|
||||
endef
|
||||
Package/iperf-mt/install = $(Package/iperf/install)
|
||||
|
||||
$(eval $(call BuildPackage,iperf))
|
||||
$(eval $(call BuildPackage,iperf-mt))
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- a/src/Reporter.c
|
||||
+++ b/src/Reporter.c
|
||||
@@ -308,6 +308,11 @@ ReportHeader* InitReport( thread_Setting
|
||||
#else
|
||||
// set start time
|
||||
gettimeofday( &(reporthdr->report.startTime), NULL );
|
||||
+
|
||||
+ // set next time
|
||||
+ reporthdr->report.nextTime = reporthdr->report.startTime;
|
||||
+ TimeAdd( reporthdr->report.nextTime, reporthdr->report.intervalTime );
|
||||
+
|
||||
/*
|
||||
* Process the report in this thread
|
||||
*/
|
Loading…
Reference in a new issue