libreadline: cleanup Makefile, fix shlib perms
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 45223
This commit is contained in:
parent
d1457d5db4
commit
32085b22b0
2 changed files with 24 additions and 16 deletions
|
@ -19,6 +19,8 @@ PKG_LICENSE:=GPL-3.0
|
|||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -38,27 +40,22 @@ define Package/libreadline/description
|
|||
history expansion on previous commands.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(CP) $(SCRIPT_DIR)/config.guess $(SCRIPT_DIR)/config.sub $(PKG_BUILD_DIR)/support/
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--without-curses \
|
||||
bash_cv_wcwidth_broken=no \
|
||||
bash_cv_func_sigsetjmp=yes \
|
||||
)
|
||||
endef
|
||||
# prevent "autoreconf" from removing "aclocal.m4"
|
||||
PKG_REMOVE_FILES:=
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-curses \
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
bash_cv_wcwidth_broken=no \
|
||||
bash_cv_func_sigsetjmp=yes \
|
||||
|
||||
TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
|
||||
|
|
11
package/libs/libreadline/patches/001-install_perm.patch
Normal file
11
package/libs/libreadline/patches/001-install_perm.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/support/shlib-install
|
||||
+++ b/support/shlib-install
|
||||
@@ -73,7 +73,7 @@ fi
|
||||
case "$host_os" in
|
||||
hpux*|darwin*|macosx*|linux*|solaris2*)
|
||||
if [ -z "$uninstall" ]; then
|
||||
- chmod 555 ${INSTALLDIR}/${LIBNAME}
|
||||
+ chmod +x ${INSTALLDIR}/${LIBNAME}
|
||||
fi ;;
|
||||
cygwin*|mingw*)
|
||||
IMPLIBNAME=`echo ${LIBNAME} \
|
Loading…
Reference in a new issue